Groma v. 7.0
След.

Groma v. 7.0

Jan Sehnal

Copyright © 1993, 2002 Jan Sehnal

Содержание

I. Руководство для потребителя
1. Введение
Требования программы
Защита программы
2. Инсталяция программы
Инсталяция
Запуск программы
Параметры для запуска
Инициализационный файл
3. Управление программой
Управление программой
Главное окно программы
Панель средств
Панель функций расчета
Панель установки
Окна данных
Работа с окнами
Диалоговые окна
Справка
4. Файлы данных
Проекты
Координатные файлы
Файлы с измеренными данными
Ведомости
Текстовые файлы
Графические файлы
Индексирование файлов
Компрессия файла
Управление файлами
Открытие файла
Создание нового файла
Импорт файлов со старых версий системы GROMA
5. Массивы
Информация о пунктах
Курсор
Редактирование
Добавление позиций
Отстранение позиций
Обозначение
Поиск позиций
Выбор изображенных данных
Шаг назад
Перетягивание данных
Перенумерация массива
Массовые изменения в массивах
6. Каталог координат
Передвижение в каталоге координат
Закрытие пунктов на замок
Группирование каталога координат
Активный каталог координат
Поиск в каталоге координат
Сохранение пунктов
Графическое изображение пунктов
Группирование каталога координат согласно номенклатуры
Сравнение каталогов координат
Контроль дублирующихся номеров
Отстранение идентичных пунктов
Контроль нумерации пунктов
Округление координат
Восстановление отстраненных позиций
Присоединение файла
Координаты в разных координатных системах
7. Журнал измерений
Выбор деталей изображения
Перенумерация журнала измерений
Обработка журнала
Обозначение ориентации
Соединение файлов измерений
Восстановление отстраненных позиций
8. Проекты
Закладка проекта
Добавление / отстранение файлов
Сохранение проекта
Открытие проекта
9. Кодирование пунктов
Принцип кодирования
Кодирующая таблица
Присоединение и отсоединение кодирующей таблицы
Эдитация кодирующей таблицы
Многократные коды
Ненайденные коды
Обозначение пуктов согласно кодов
Задавание кодов с помощью описания
Перекодирование при импорте
10. Расчеты
Расчетное диалоговое окно
Ввод данных
Сохранение результатов
Контрольный чертеж
Допуск
Тестирование согласно предписаний для работы в кадастре недвижимостей
Трансформация координат
Ориентация горизонтальных направлений
11. Расчетные задачи
Полярный метод
Ортогональный метод
Полярный метод групповой
Свободная станция
Линейная засечка
Угловая засечка (по направлениям)
Многократная угловая засечка (по ориентированным направлениям)
Пересечение прямых
Пересечение прямой и окружности
Полигонометрический ход
Высотный ход
Трансформация координат
Дирекционный угол и длина
Контрольные длины
Файл контрольных длин
Конструкционные контрольные длины
Вычисление элементов проекции на прямую
Расчет площадей
Полярные разбивочные элементы
Ортогональные разбывочные элементы
Расчет трассы
Кубатуры
Расчет высоты станции
Расчет высот
Внесение изменения на КП-Ц на существующем пункте
Внесение изменения на КП-Ц на новом пункте
Групповой расчет файла MAPA2
12. Экспорт – Импорт файлов
Каталоги координат
Записи измерений
Чертеж
13. Определение теодолита
Определение теодолита
14. Ведомости
Открытие ведомости
Принцип работы с ведомостью
Локальная ведомость
Запись каталога координат в ведомость
Запись каталога координат в ведомость
Кодирование чешского языка
Параметры ведомости
15. Графика
Принцип сохранения графики
Открытие графического окна
Работа с графическим окном
Зацепка за пункты
Рефереционные чертежи
Кодирование четежа
16. Дигитализация растровых данных
Начтение растровых данных в программу
Графические координаты
Трансформация координат
Манипуляция с лупой
Определение
Дигитализация
17. Графическое определение пунктов
Принцип графического определения пунктов
Порядок действия при графическом определении пунктов
18. Печатные выходы
Драйвер
Выбор выходного устройства
Просмотр перед печатью
Печать каталогов
19. Менеджер конфигурации
20. Сотрудничество с CAD системами
Запуск с поддержкой CAD системы
Атрибуты для переноса пунктов
II. Руководство по применению
21. Работа с Руководством по применению
22. Главное меню
23. Меню Файл
Новый
Открой
Сохрани
Сохрани как
Закрой все
Компрессия файла
Индексирование файла
Информация о файле
Активный каталог координат
Установка
Менеджер конфигурации
CAD установка
Печать
Установка принтера
Изобрази ведомость расчета
Сохрани ведомость расчета
Конец
24. Диалоговое окно Установка
Среда
Расчеты
Редукция
Журнал
Теодолит
Кодирование пунктов
Ведомость
Вход/Выход
Входной / выходной формат координат
Входной / выходной формат измерений
DXF
25. Меню Расчеты
26. Меню Окно
Закрой
Мозаика горизонтально – вертикально
Каскад
Выравнивание икон
Параметры изображения
27. Меню Эдитация
Шаг назад
Перенеси
Скопируй
Вложи
Смазать
28. Меню Проект
Добавь файл
Отбери файл
Открой файл
Установка
29. Меню Координаты / Измерения
Добавь позицию
Отстрани позицию
Эдитируй позицию
Найди позицию
Обозначь
Массовые изменения
Перенумерация каталога
Перекодирование согласно таблицы
Восстановление смазанных позиций
В ведомость
30. Меню Координаты
Изобрази графически
Группировка согласно листов карты (плана)/
Сравнение каталогов координат
Контроль номеров-дубликатов
Контроль нумерации пунктов
Отстранение идентических пунктов
Округление координат
Координаты в двух системах
Параметры изображения
31. Меню Измерения
Обработка журнала
Соединение станций
Обозначь ориентации
Группирование
Присоедини файл
Параметры изображения
32. Меню План
Параметры изображения
Изображение
Увеличить
Уменьшить
Перечерти
Вырез
Выбор элементов
Отстранение элементов
Соединение пунктов
Ограждение
Вычитание координат
33. Меню Битовая карта
Ключ трансформации
Дигитализация
III. Приложения
34. Параметры при запуске
35. Инсталяция в сети
Инсталяция в сети
Конфигурационный файл
36. Типы файлов данных
37. Коммуникация с системой MicroStation
Конфигурация системы MicroStation
Конфигурационные файлы MDL модулей
Запуск системы GROMA из MicroStation
Коммуникация GROMA - MicroStation
Информация о пунктах
Кодирование пунктов
Конфигурация коммуникационного модуля
Дальнейшие функции модулей
38. Форматы входных файлов с измеренными величинами
39. Входной / выходной текстовый формат
Альфанумерические знаки
Символы позиций данных
Ширина форматированных данных
Количество десятичных долей
Другие установки
Примеры выходного формата
Особенности входного формата
Начитывание с помощью фиксированного формата
Начитывание с помощью свободного формата
IV. Расширяющиеся модули
40. Расширяющиеся модули
41. Контрольный чертеж для расчетов
Изображение всего чертежа
Вырез
Увеличение
Уменьшение
Отстранение
Фонт
Печать
Экспорт в DXF
42. Искажение в проекции Кршовака
43. Треугольный калькулятор
44. Перенос файлов
Выбор размещения файла
Параметры переноса
Начтение файла
Перенос файла в прибор
Дальнейшие установки
45. Присоединение дигитайзера
Подготовка приспособления дигитайзера
Тест коммуникации
Калибрация цифрового приспособления
Вычитание пунктов
Определение площадей
46. Уравнивающая плоскость
Задание плоскости
Положение плоскости
Уравнение плоскости
Результирующие величины
47. Топографические (Геометрические) планы
Ввод
Управление программой
Установка модуля и описательное поле
Данные кадастра недвижимостей
Данные прошлого учета земельных участков
Данные для pro BPEJ
Дополнительные данные
Результирующие таблицы
Входы и выходы
48. Расчет трассы коммуникации
Введение
Управление программой
Определение трассы
Расчетные контроли
Расчет пунктов на оси коммуникации
Расчет пикетов на нормалях
Расчет разбивочных элементов
49. Уравнивание сети
Введение
Управление программой
Варианты уравнивания и присоединения сети
Характеристики пунктов
Параметры сети
Вводимые данные
Уравнивание сети
Сохранение уравненных координат
Сравнение этапов
Математическая модель уравнивания
Меню ФАЙЛ
Меню СЕТЬ
50. Заключение
След.
Часть I. Руководство для потребителя


Часть I. Руководство для потребителя
Пред. След.

Руководство для потребителя

Содержание

1. Введение
Требования программы
Защита программы
2. Инсталяция программы
Инсталяция
Запуск программы
Параметры для запуска
Инициализационный файл
3. Управление программой
Управление программой
Главное окно программы
Панель средств
Панель функций расчета
Панель установки
Окна данных
Работа с окнами
Диалоговые окна
Справка
4. Файлы данных
Проекты
Координатные файлы
Файлы с измеренными данными
Ведомости
Текстовые файлы
Графические файлы
Индексирование файлов
Компрессия файла
Управление файлами
Открытие файла
Создание нового файла
Импорт файлов со старых версий системы GROMA
5. Массивы
Информация о пунктах
Курсор
Редактирование
Добавление позиций
Отстранение позиций
Обозначение
Поиск позиций
Выбор изображенных данных
Шаг назад
Перетягивание данных
Перенумерация массива
Массовые изменения в массивах
6. Каталог координат
Передвижение в каталоге координат
Закрытие пунктов на замок
Группирование каталога координат
Активный каталог координат
Поиск в каталоге координат
Сохранение пунктов
Графическое изображение пунктов
Группирование каталога координат согласно номенклатуры
Сравнение каталогов координат
Контроль дублирующихся номеров
Отстранение идентичных пунктов
Контроль нумерации пунктов
Округление координат
Восстановление отстраненных позиций
Присоединение файла
Координаты в разных координатных системах
7. Журнал измерений
Выбор деталей изображения
Перенумерация журнала измерений
Обработка журнала
Обозначение ориентации
Соединение файлов измерений
Восстановление отстраненных позиций
8. Проекты
Закладка проекта
Добавление / отстранение файлов
Сохранение проекта
Открытие проекта
9. Кодирование пунктов
Принцип кодирования
Кодирующая таблица
Присоединение и отсоединение кодирующей таблицы
Эдитация кодирующей таблицы
Многократные коды
Ненайденные коды
Обозначение пуктов согласно кодов
Задавание кодов с помощью описания
Перекодирование при импорте
10. Расчеты
Расчетное диалоговое окно
Ввод данных
Сохранение результатов
Контрольный чертеж
Допуск
Тестирование согласно предписаний для работы в кадастре недвижимостей
Трансформация координат
Ориентация горизонтальных направлений
11. Расчетные задачи
Полярный метод
Ортогональный метод
Полярный метод групповой
Свободная станция
Линейная засечка
Угловая засечка (по направлениям)
Многократная угловая засечка (по ориентированным направлениям)
Пересечение прямых
Пересечение прямой и окружности
Полигонометрический ход
Высотный ход
Трансформация координат
Дирекционный угол и длина
Контрольные длины
Файл контрольных длин
Конструкционные контрольные длины
Вычисление элементов проекции на прямую
Расчет площадей
Полярные разбивочные элементы
Ортогональные разбывочные элементы
Расчет трассы
Кубатуры
Расчет высоты станции
Расчет высот
Внесение изменения на КП-Ц на существующем пункте
Внесение изменения на КП-Ц на новом пункте
Групповой расчет файла MAPA2
12. Экспорт – Импорт файлов
Каталоги координат
Записи измерений
Чертеж
13. Определение теодолита
Определение теодолита
14. Ведомости
Открытие ведомости
Принцип работы с ведомостью
Локальная ведомость
Запись каталога координат в ведомость
Запись каталога координат в ведомость
Кодирование чешского языка
Параметры ведомости
15. Графика
Принцип сохранения графики
Открытие графического окна
Работа с графическим окном
Зацепка за пункты
Рефереционные чертежи
Кодирование четежа
16. Дигитализация растровых данных
Начтение растровых данных в программу
Графические координаты
Трансформация координат
Манипуляция с лупой
Определение
Дигитализация
17. Графическое определение пунктов
Принцип графического определения пунктов
Порядок действия при графическом определении пунктов
18. Печатные выходы
Драйвер
Выбор выходного устройства
Просмотр перед печатью
Печать каталогов
19. Менеджер конфигурации
20. Сотрудничество с CAD системами
Запуск с поддержкой CAD системы
Атрибуты для переноса пунктов
Пред. | Начало | След.
Groma v. 7.0 | Уровень выше | Глава 1. Введение


Глава 1. Введение
Пред. Часть I. Руководство для потребителя След.

Глава 1. Введение

Вы получаете программу GROMA, предназначенную для геодезических расчетов, упрощенной графики и ведения каталога координат в среде Microsoft Windows.

Требования программы

  • Компьютер: Программа GROMA работает на любом компьютере типа PC, на котором имеется Microsoft Windows 95, 98, Windows NT 4.0, Windows 2000 или Windows XP.

  • Монитор: Рекомендуем использовать качественный цветной монитор с повышенным разрешением. Минимальное требуемое разрешение 800 x 600 пикслов. Его имеют практически все используемые VGA-карты со стандартными мониторами. При разрешении 1024 x 768 и большем значительно лучше используются возможности программы (возможность работы с большим количеством окон одновременно).

  • Мышь: К работе с программой необходимо иметь мышь, лучше всего трехклавишную.

Пред. | Начало | След.
Часть I. Руководство для потребителя | Уровень выше | Защита программы


Защита программы
Пред. Глава 1. Введение След.

Защита программы

Программа защищена против незаконного использования т.н. гардверским ключем. Гардверский ключ представляет собой приспособление, которое присоединяется к параллельному порту компьютера. В начале работы программа его тестирует. Если ключ не обнаружен, то она включается автоматически в ограниченном демонстрационном режиме.

Гардверский ключ можно использовать в локальном или сетевом исполнении. Локальный ключ должен быть присоединен непосредственно к компьютеру, на котором программа GROMA работает. Сетевой ключ присоединяется к т.н. лицензионному серверу, к которому присоединены отдельные инсталяции системы GROMA

Ключ может быть подключен к какому-либо порту LPT1 - LPT3. Он полностью проходим для стандартных сигналов принтера, т.е. Вы можете его подключить через принтер. Если Вы используете больше ключей, подключенных каскадом, и появляются некоторые компликации (например, некоторые программы не работают), то попробуйте изменить порядок подключения ключей или разделите их и подключите к другим портам компьютера.

Важно

Windows NT и Windows 2000 не позволяют аппликациям прямо выходить на гардвер, по-этому в этих операционных системах необходимо наисталировать драйвер для гардверского ключа. Для Windows 95, 98 и ME инсталяции драйвера не требуется, но с ее помощью можно избежать конфликтов при печати. При инсталяции системы GROMA драйвер наинсталируется автоматически.
Важно

У некоторых типов принтеров, которые используют разнонаправленную коммуникацию, может возникнуть ситуация, когда программа GROMA не разыщет гардверский ключ. В этом случае необходимо наинсталировать драйверы для гардверного ключа, которые имеються к диспозиции на наших страницах http://www.groma.cz или в нашем оффисе.

Пред. | Начало | След.
Глава 1. Введение | Уровень выше | Глава 2. Инсталяция программы


Глава 2. Инсталяция программы
Пред. Часть I. Руководство для потребителя След.

Глава 2. Инсталяция программы

Инсталяция

Инсталяционный диск содержит программу INSTALL.EXE, которая автоматически инсталирует все необходимые файлы.

Инсталяционную программу можете запустить напр. через меню Старт

D:\INSTALL.

После запуска она задает вопрос о имени папки, в который Вы хотите программу GROMA наинсталировать(implicitne C:\Groma7). Папка для программы GROMA может не существовать, однако его сама создаст. После выбора папки программы инсталяционная программа спросит о том, которые компоненты системы Вы хотите наинсталировать. Рекомендуем Вам оставить предварительно предлагаемую комплесную инсталяцию. Инсталяцию запустите клавишей <Enter>. После запуска, инсталяция осуществится полностью автоматически. После инсталяции в меню Старт появится группа для системы GROMA a в ней икона для запуска программы. Эту икону можете перетянуть мышью в какую-либо иную группу, а пустую группу GROMA отстранить.

Пред. | Начало | След.
Защита программы | Уровень выше | Запуск программы


Запуск программы
Пред. Глава 2. Инсталяция программы След.

Запуск программы

Программу можно запустить двойным нажатием на ее икону в меню Старт или с помощью Помощник.

Пред. | Начало | След.
Глава 2. Инсталяция программы | Уровень выше | Параметры для запуска


Параметры для запуска
Пред. Глава 2. Инсталяция программы След.

Параметры для запуска

Программа GROMA можно запустить с некоторыми параметрами приказной строкой. Параметры приведены за знаком "/" или "-". Перечень параметров приведен в приложении.

Пред. | Начало | След.
Запуск программы | Уровень выше | Инициализационный файл


Инициализационный файл
Пред. Глава 2. Инсталяция программы След.

Инициализационный файл

Все установки программы GROMA, включая толеранцию входных/выходных форматов, размещение открытых окон на мониторе и т.п., вкладывают в инициализационный файл GROMA.INI. Расположение этого файла отличается в зависимости от используемой версии MS Windows. Если в среде существует переменная USERPROFILE, то конфигурационный файл будет размещен в папке, на которую переменная показывает. Эта переменная установлена в системех Windows NT a Windows 2000. Если эта переменная определена, то конфигурационный файл будет размещен в папке, где наинсталирован MS Windows (обычно C:\WINDOWS).

Местонахождение конфигурационного файла можно изменить с помощью параметров при запуске. Перечень используемых параметров приведен в приложении.

Если при первом запуске системы GROMA в соответствующей папке не найден инициализационный файл, то программа скопирует на это место стандартную предварительно определенную конфигурацию, которая находится в папке системы GROMA.

Kонфигурационный файл - это текстовый файл, который теоретически можно редактировать, но этот вариант мы не рекомендуем, потому-что все части файла можно предварительно установить из среды программы GROMA, если же этот файл нарушен, т.е. если содержит не предусмотренные или не допустимые данные, то нельзя гарантировать корректное поведение программы.

Учитывая что в программе можно установить сравнительно большое количество различных параметров (а в некоторых случаях, как, например, во входных/выходных форматах, можно установить сравнительно трудно), рекомендуем инициализационный файл время от времени сохранять.

Пред. | Начало | След.
Параметры для запуска | Уровень выше | Глава 3. Управление программой


Глава 3. Управление программой
Пред. Часть I. Руководство для потребителя След.

Глава 3. Управление программой

Управление программой

Программа управляется так же, как и большинство прикладных програм для MS Windows. Для потребителя, который к этой среде привык, это не должно создавать никакие трудности.

Пред. | Начало | След.
Инициализационный файл | Уровень выше | Главное окно программы


Главное окно программы
Пред. Глава 3. Управление программой След.

Главное окно программы

После первого запуска программы GROMA появится ее главное окно. В верхней части этого окна изображено меню с командами, которые служат для управления программой. Это меню реагирует на тот тип окна данных, которое в настоящее время активизировано и приспосабливает для него предлагаемые команды. После первого запуска программы не открыто ни одно окно данных, потому-что меню содержит только приказы для открывания окна и для расчетов.

Пред. | Начало | След.
Глава 3. Управление программой | Уровень выше | Панель средств


Панель средств
Пред. Глава 3. Управление программой След.

Панель средств

В этом меню находится панель средств. Эта панель содержит некоторые наиболее используемые команды из главного меню и служит к их ускоренному запуску. Как и меню, так и панель средств реагирует своими предложениями на тип активированного окна.

Пред. | Начало | След.
Главное окно программы | Уровень выше | Панель функций расчета


Панель функций расчета
Пред. Глава 3. Управление программой След.

Панель функций расчета

Под панелью инструментов изображена панель с предожениями функций расчета. Все предлагаемые задачи можно запустить также с помощью меню Расчёты.

Пред. | Начало | След.
Панель средств | Уровень выше | Панель установки


Панель установки
Пред. Глава 3. Управление программой След.

Панель установки

Под панелью функций расчета имеется панель установки. На этой панели можно непосредственно изменять некоторые установки системы GROMA. Более того, из этой панели доступен менеджер конфигурации, с помощью которого можно управлять большим количеством файлов с конфигурациями.

Все массивы на панели изображают несколько величин, которые использовались в предпоследний раз. При выборе ранее установленной величины, в большинстве случаев, нет необходимисти задавать данные с помощью клавиатуры, достаточно найти ее в массиве величин.

На панели установки доступны следующие статьи:

  • Выбор активного конфигурационного файла. Здесь можно выбрать набор конфигураций, с которым желаете работать. Программа предлагает все конфигурации, найденные в папке s для конфигураций. Размещение конфигурации можно определить с помощью установки в файле network.ini, или с помощью параметров при запуске системы GROMA.

    Возле перечня с предложениями конфигурационных файлов находится клавиша для запуска менеджера конфигурации.

  • За перечнем конфигурации находится предложение неполного номера, которое используется при задании неполного номера пункта. Этот неполный номер можно задать также в диалоговом окне Редукция.

  • Далее изображен перечень кодов качества. Выбраный код качества имеет влияние, напр., на предельные невязки при расчетах.

  • В конце панели установки имеются предложения в предпоследний раз использованных масштабных коеффициентов.

Пред. | Начало | След.
Панель функций расчета | Уровень выше | Окна данных


Окна данных
Пред. Глава 3. Управление программой След.

Окна данных

Под панелью расчетных функций имеется свободная рабочая площадь, в которую помещаются окна данных.

У нижнего края окна расположена строка состояния, которая представляет потребителю некоторую дальнейшую информацию.

Главное окно программы, которое появляется после первого запуска, создает как бы рамку для иных окон, которые содержат собственные обработанные данные. Программа GROMA позволяет работать с семью типами окон данных:

  • координатные окна,

  • окна с измеренными данными,

  • графические окна,

  • окна с растровыми данными,

  • окно с ведомостью о расчетах,

  • окно с проектом,

  • окна текстовые.

Координатные окна и окна с измеренными данными – это т.н. перечни, т.е. текстовые информации в виде строчек и столбиков.

Одновременно можно открыть любое количество окон (их число ограничивается только объемом памяти). Для одного файла данных можно открыть больше окон, причем все изменения данных автоматически изображаются во всех открытых окнах.

Пред. | Начало | След.
Панель установки | Уровень выше | Работа с окнами


Работа с окнами
Пред. Глава 3. Управление программой След.

Работа с окнами

С отдельными окнами можно манипулировать так, как это принято у остальных аппликаций MS Windows. Окна можно передвигать по экрану, увеличивать или уменьшать, минимизировать на икону или увеличить на всю площадь главного окна программы. Эти же операции можно выполнять с главным окном. Подробные информации о манипуляции с окнами можно получить в Руководстве по MS Windows.

Программа сохраняет информации об открытых окнах в инициализационном файле, поэтому они, после окончания работы с программой и ее повторном запуске, снова автоматически открываются.

Для манипуляции с окнами служат команды в меню Окно.

Пред. | Начало | След.
Окна данных | Уровень выше | Диалоговые окна


Диалоговые окна
Пред. Глава 3. Управление программой След.

Диалоговые окна

Для коммуникации с потребителем используются т.н. диалоговые окна. В соответствии со способами обслуживания их можно разделить на модальные и немодальные.

Модальные диалоговые окна

Модальные окна – это окна, которые после открытия блокируют вход во все остальные части программы, а потребитель может продолжать работу только после их закрытия. Этот тип окон используется для большинства конфигураций программы, для ошибочных объявлений или если, перед дальнейшей акцией, требуется вход потребителя. Между отдельными пoзициями модальных окон можно передвигаться с помощью клавиш <Tab> и <Shift-Tab>, a в случае редакционных окон и с помощью клавиш <Стрелка вверх> a <Стрелка вниз>.

Немодальные диалоговые окна

Немодальные окна в отличие от окон модальных не блокируют вход в остальные части программы, поэтому могут быть открыты как угодно долго, а Вы при этом можете работать с иной частью программы. Эти окна всегда изображаются сверху и перекрывают окна данных. Немодальные окна используются для всех вычислительных задач, для ввода координат и для других частей программы. Между отдельными позициями можно передвигаться также, как и у окон модальных, в случае редакционных окон еще и с помощью клавиши <Enter>.

Входные строчки с формулами

Все вводимые данные записывают во входных редакционных окнах. В окнах можно использовать стандартные клавишные сокращения, т.е. так, как это принято в MS Windows (копирование, добавление, отстранение). Более того, при задании величин можно непосредственно использовать математические операции (суммирование, вычитание, умножение, деление, скобки и т.п.)

Следовательно во входную строчку для задания длины можно задать напр. 128.56+1.411 или (56.378+195.339)*0.999985

Увеличение / уменьшение номера пункта

Если Вы находитесь во входном окне для задание номера пункта, можно величину, которая приведена в окне, увеличить или уменьшить на единицу с помощью клавиши <+> или <-> на численной клавиатуре.

Если идентификатор задан во входном окне альфанумерически (содержит текст или комбинацию текста и чисел), программа разыщет в нем первое число или цифру и увеличит/уменьшит его. Если идентификатор только текстовый, то программа дополнит на его конце.

Выбор файлов данных

Некоторые диалоговые окна содержат входные строчки для выбора файлов данных для дальнейших операций (напр. обозначения, массовые изменения, перенумерация и т.п.). При открытии такого диалогового окна выбирают обычно, как файл данных, тот файл, который в настоящее время активизирован (идет ли речь о файле подходящего типа). Если Вы хотите изменить файл данных, то можете выбрать один из следующих способов:

  • Перенесите на площадь входной строки любую позицию из файла данных, который хотите выбрать.

  • Надавите кнопку с тремя точками вправо от входной строчки с названием файла, тогда программа предложит Вам выбор из всех открытых файлов соответствующего типа. В изображенном диалоговом окне можно также с помощью нажатия кнопки (Новый) заложить навый файл без названия соответствующего типа.

Пред. | Начало | След.
Работа с окнами | Уровень выше | Справка


Справка
Пред. Глава 3. Управление программой След.

Справка

В программе GROMA имеется к диспозиции контекстовая справка. Справку можно открыть тремя способами:

  • Выбором команды Справка->Содержание справки из главного меню. После выбора этой команды появится содержание справки, с помощью которого можно постепенным выбором выделенных позиций получить необходимую информацию.

  • Нажатием клавиши <F1>. После нажатия этой клавиши в сответствии с ситуацией изображена контекстовая справка (справка о мгновенной ситуации в программе, о выбранной позиции и т.п.) или содержание справки.

  • Нажатием клавиши (Справка) в диалоговом окне. После нажатия этой клавиши всегда изображается контекстовая справка, относящаяся к соответствующему диалоговому окну.

Кроме главной справки программа изображает при выборе в меню краткое описание выбраной позиции в строчке состояния.

Пред. | Начало | След.
Диалоговые окна | Уровень выше | Глава 4. Файлы данных


Глава 4. Файлы данных
Пред. Часть I. Руководство для потребителя След.

Глава 4. Файлы данных

Программа GROMA сохраняет все файлы данных в своем внутреннем формате. Откроете-ли файл в ином формате, чем каталог координат (.crd), журнал измерений (.mes), ведомость (.pro), графика (.pic) или растровые данные (.rnf), программа прежде всего переведет файл в соответствующий внутренний формат с похожим названием, но со стандартной припоной, а потом откроет.

Проекты

Проекты – это файлы, определяюшие отдельные заказы. После закладки проекта изображается окно, в которое можно добавлять файлы, которые относятся к соответствующему заказу. Проекты содержат также некоторые части конфигурации (присоединенную кодирующую таблицу и т.п.). Работа с проектами подробнее описана здесь.

Пред. | Начало | След.
Справка | Уровень выше | Координатные файлы


Координатные файлы
Пред. Глава 4. Файлы данных След.

Координатные файлы

Каталог координат создается двумя файлами, которые имеют одинаковые названия, но отличаюся припоной. Первый, данных, содержит собственно координаты (файл с припоной .crd), а второй, т.н. индекса, содержит информации о распределении пунктов (файл с припоной .crx). При нарушении или утрате файла данных теряются координаты всех пунктов, при этом потерянный файл индекса можно на основе файла данных когда-либо восстановить. Из этого выплывает, что необходимо тщательно дублировать файлы данных, в то же время дублирование файлов индекса излишне.

Пред. | Начало | След.
Глава 4. Файлы данных | Уровень выше | Файлы с измеренными данными


Файлы с измеренными данными
Пред. Глава 4. Файлы данных След.

Файлы с измеренными данными

Способ сохранения массива измеренных данных почти похож с сохранением каталога координат. Массив снова создается двумя файлами – данных (.mes) и индекса (.mex). Манипуляция с этими файлами такая же, как и у каталога координат.

Пред. | Начало | След.
Координатные файлы | Уровень выше | Ведомости


Ведомости
Пред. Глава 4. Файлы данных След.

Ведомости

При расчетах можно открыть файл с ведомостью. Разговор идет о редакционное текстовое окно, в которое программа добавляет ведомости вычислений. Ведомость может быть открыта только одна. Подробнее работа с ведомостями описана в самостоятельной главе.

Пред. | Начало | След.
Файлы с измеренными данными | Уровень выше | Текстовые файлы


Текстовые файлы
Пред. Глава 4. Файлы данных След.

Текстовые файлы

Программа GROMA позволяет работать с текстовыми файлами. Текстовые файлы можно открыть в редакционном окне тем же способом, как и другие файлы. Текстовых файлов можно открыть любое количество, но в отличие от массивов для каждого файла можно открыть только одно окно.

В некоторых случаях система GROMA открывает текстовые файлы автоматически (напр. после экспорта в текстовый файл результирующий файл изображается автоматически, а при импорте, в случае ошибки, начитанный файл изображается, но курсор помещается на ошибочную строку).

Если Вы захотите импортировать текстовый файл, который только что открыт и который был в редакторе системы GROMA изменен, то будете предупреждены, что актуальная версия файла находится в редакторе, и спрошены о том, если не желаете перед импортом файл сохранить.

Если текстовый файл, который находится в системе GROMA открыт, а Вы изменинили какую-либо аппликацию, то при возвращении в систему GROMA будете предупреждены об этом изменении и спрошены, если не желаете начесть с диска актуальную версию файла.

Пред. | Начало | След.
Ведомости | Уровень выше | Графические файлы


Графические файлы
Пред. Глава 4. Файлы данных След.

Графические файлы

Графические файлы (файлы с припоной .pic) содержат только предписание чертежа, т.е. всегда соединены с соответствуюшими координатными файлами с такими же названиями. Если Вы откроете графический файл, то в память автоматически будет начтен и соответствующий каталог координат (и в том случае, если не изображен в окне). Преимуществом этого способа создания графики является прежде всего то, что для расчетов и создания чертежа используется один каталог координат, а все изменения в нем автоматически проектируются и на начерченый план. Когда ситуация вокруг пунктов вычерчена, можно произвольно изменять их координаты (как у отдельных пунктов, так и в целом для всего файла, напр. трансформацией из местной в главную систему). Созданный план эти изменения акцептирует и нет необходимости в его работу вмешиваться. Более того, использование одного каталога координат приводит к экономии места в памяти и на диске.

Пред. | Начало | След.
Текстовые файлы | Уровень выше | Индексирование файлов


Индексирование файлов
Пред. Глава 4. Файлы данных След.

Индексирование файлов

Чтобы программа могла с каталогами работать, они должны быть индексированы. При индексировании для файла данных создается соответствующий файл индекса, в котором пункты сгруппированы согласно неполных номеров и номеров. В файле данных пункты остаются не сгруппироваными, т.е. такими, какими их постепенно при расчете или при импорте добавляли.

При работе с каталогом файл индекса расположен в памяти компьютера (по причине ускоренной манипуляции с каталогом), в то время, как файл данных расположен на диске. В этом случае все изменения данных мгновенно сохраняются на диске.

Изменения данных постепенно заносятся на диск, в то время, как изменения в файле индекса происходят в операционной памяти, а актуальный файл индекса нормально сохраняется только при закрытии окна с каталогом координат. При насильственном прерывании работы программы на диске остается актуальный файл данных, но исходный файл индекса. Согласно определенных критериев программа тестирует соответствие файлов данных и индекса и сама распознает, что эти файлы себе не соответствуют, в этом случае она автоматически создает новый файл индекса.

Пред. | Начало | След.
Графические файлы | Уровень выше | Компрессия файла


Компрессия файла
Пред. Глава 4. Файлы данных След.

Компрессия файла

При смазывании в файле данных (координатном и с измеренными данными) отстраняются позиции только выделенные как смазанные, но в файле данных и они дальше остаются. Может случится, что после сложных операций и передвижении пунктов, каталог координат пустой или содержит только несколько пунктов, однако на диске занимает скажем несколько десятков или сотен KB. В этом случае целесообразно выполнить компрессию файла данных. При компрессии исходный файл данных переименовывается на запасной (.~cr), кроме того, создается новый файл данных (.crd), который уже ранее отстраненные позиции не содержит.

Компрессию файла данных целесообразно выполнить и по другим причинам. Если, например, импортирован каталог координат (напр. из текстового файла), в котором пункты не сгруппированы, то его индексирование может продолжаться сравнительно долго(в особенности, если его объем большой). Если в процессе дальнейшей работы произойдет нарушение файла индекса или этот файл отстранен, тогда все длинное индексирование необходимо повторить снова. При компрессии файла пункты записывают сгруппироваными по номерам, поэтому дальнейшее индексирование займет значительно меньше времени. После импорта не сгруппированного каталога или после усложненного дополнения каталога во время расчетов целесообразно произмести компрессию файла данных.

Пред. | Начало | След.
Индексирование файлов | Уровень выше | Управление файлами


Управление файлами
Пред. Глава 4. Файлы данных След.

Управление файлами

Для понимания метода работы с файлами, открытыми в окнах, необходимо сначала объяснить, каким образом программа управляется.

При открытии любого файла данных, данные, которые нужны для дальнейшей работы с ним (напр. файл индекса для каталога координат и т.п.), начтены в памяти компьютера, а соответствующая его презентация изображена в окне (каталог координат, план и т.п.) При новом открытии этого же файла изображено уже только новое окно, а в памяти компьютера файл открывается физически только один раз. Поэтому новое окно можно понимать действительно как второе "окошко", в котором просматривается этот же файл. При открытии двух окон с графикой можно просматривать два выреза плана одновременно.

Из этого выплывает, что все изменения, проводимые в файле в любом открытом окне, физически проводятся в одном файле. Программа об этой действительности сигнализирует тем, что окна, изображающие один файл последовательно пронумерованы. Если та же часть файла видна в большем количестве окон, то изменения, которые в нем проведете, автоматически изображаются во всех окнах.

Пред. | Начало | След.
Компрессия файла | Уровень выше | Открытие файла


Открытие файла
Пред. Глава 4. Файлы данных След.

Открытие файла

Для работы с файлом данных в программе необходимо его сначала открыть.

Файл можно открыть тремя способами:

  • с помощью диалогового окна,

  • с помощью параметра при запуске программы GROMA,

  • перетягиванием его названия из Помощника.

Открытие файла с помощью диалогового окна

Наиболее распространенным способом открытия файла является способ с помощью диалогового окна.

Выберете-ли команду Файл->Открой, программа GROMA изобразит диалоговое окно для выбора файла.

Порядок работы при открытии файла:

  1. Выберите необходимый тип файла из перечня Файлы типа. Импортируете-ли массив измерений из журнала, необходимо сначала выполнить установку журнала и формата в диалоговом окне Файл->Установка->Журнал. Согласно этой установки будет активизировано предложение типов файлов в массиве Файлы типа.

  2. Выберите соответствующий диск и папку из массива Где искать.

  3. Существует-ли файл, который необходимо открыть, его название появится в массиве. Выделите его курсором с помощью мыши или клавиатуры. Желаете-ли открыть одновременно больше файлов, выделите их в перечне с помощью клавиш <Shift> и <Ctrl>.

  4. Нажмите кнопку (Открыть). Если файл существует, программа GROMA его откроет и изобразит в окне.

Открытие файла с помощью параметра при запуске

Напишете-ли при запуске программы GROMA за названием программы название одного или большего числа файлов данных, программа после запуска предпримет попытку автоматически их открыть.

Открытие файла с помощью Помощника

Если запущены Помощник и программа GROMA, можно открыть файл данных перетягиванием его названия из перечня, изображенного в Помощнике, на площадь главного окна программы GROMA. При перетягивании изменяется вид курсора мыши в зависимости от области, на которой он в этот момент расположен. Подробности можно найти в Руководстве для потребителя MS Windows.

Открытие файла только для чтения

Работаете-ли в среде компьютерной сети, может случится, что необходимо будет открыть один файл с упоминаемого диска (напр. на сервере) одновременно на нескольких компьютерах. Эта ситуация является обычной, напр. при работе с общими каталогами координат пунктов сети. Файл обычно открывают для чтения и записи. В этом случае его открывают только один раз, потому-что запись в один файл с большего количества станций привела бы к его повреждению. Программа Вас об этот предупредит и не позволит открыть файл, который открыт для чтения и записи.

Однако, если при открытии файла командой Файл->Открой зачеркнете позицию Только для чтения, то перечень откроется только для чтения. В этом режиме его может открыть любое количество потребителей. Если же таким образом открытый файл попробуете открыть в нормальном режиме, т.е. для чтения и записи, то программа Вас предупредит, что файл уже открыт и предложит Вам возможность его открытия только для чтения.

В файле открытом только для чтения невозможно выполнять какие-либо изменения, а только использовать сохраненные в нем данные. Однако, позиции файла можно скопировать в другой файл, на который эти ограничения не распространяются.

Открытие файла только для чтения можно использовать и в случае, если Вы сами с ним работаете, но не желаете его изменять. Этим снижается риск повреждения ценных файлов данных.

Пред. | Начало | След.
Управление файлами | Уровень выше | Создание нового файла


Создание нового файла
Пред. Глава 4. Файлы данных След.

Создание нового файла

Желаете-ли создать новый файл, выберите команду Файл->Новый. Изобразится диалоговое окно, где можете выбрать тип файла, который хотите создать. После нажатия кнопки (OK) файл создан и изобразится его пустое окно. Файл создан как временный в рабочей папке. Желаете-ли его сохранить, выберите приказ Файл->Сохрани как и сохраните его под иным названием. Если же попытаетесь не сохраненный временный файл закрыть, то программа Вас предупредит, что файл еще не сохранен, и спросит Вас о том, если не желаете его сохранить. Не сохраненный файл автоматически отстраняется с диска.

Пред. | Начало | След.
Открытие файла | Уровень выше | Импорт файлов со старых версий системы GROMA


Импорт файлов со старых версий системы GROMA
Пред. Глава 4. Файлы данных След.

Импорт файлов со старых версий системы GROMA

В версии 6.0 были в файлы данных дополнены некоторые новые данные, поэтому перечни, созданные старшими версиями системы GROMA, имеют иную структуру чем новые файлы. Если при открытии каталога координат или массива измерений выберете файл, который был создан одной из старших версий системы GROMA, программа Вас предупредит, что необходимо перевести файл на новый формат. Если подтверждаете, что с переводом соглашаетесь, программа оставит исходный файл как запасной и создаст файл такого же названия в новом формате. Этот файл однако невозможно будет открыть в старших версиях системы GROMA. Исходный файл со старшей версии будет сохранен как запасной (.~cr, .~me).

Если необходимо открыть файл в формате 6.0 в одной из старших версий, то необходимо его сначала экспортировать в старший формат приказом Файл->Сохрани как. В перечне форматов выберите формат Версия 2-5. Таким образом созданный файл можно будет без проблем открыть в старших версиях программы. Новые типы данных (дата и время создания и модификация записи, дополнительные данные о пункте, комментарии возле файла и т.п.) при конверсии в старший формат потеряются.

Пред. | Начало | След.
Создание нового файла | Уровень выше | Глава 5. Массивы


Глава 5. Массивы
Пред. Часть I. Руководство для потребителя След.

Глава 5. Массивы

Термином „Массивы” обозначаются окна с каталогом координат и окна с массивами измеренных величин. Эти два типа окон имеют много общих свойств.

Массивы создаются данными, записанными в строчках. Первые два всегда являются неполным номером и номером пункта, остальные зависят от типа окна.

Информация о пунктах

Каждый пункт в каталоге обозначен идентификатором, по-которому его ищут. Он содержит еще и другие описательные информации, из которых некоторые являются общими для каталога координат и массива измерений, а некоторые являются специфическими.

Идентификатор пункта

Пункты в каталогах однозначно идентифицированы численным или альфанумерическим идентификатором. Массив измерений может содержать любое количество пунктов того же идентификатора, а в каталоге координат идентификатор может встретиться только один раз.

Численный идентификатор

Численный идентификатор состоит из двух частей : неполного номера и собственно номера пункта. Неполный номер может содержать максимально восемь цифр, а собственный номер пункта - максимально четыре цифры. В этом случае полный номер пункта может состоять из 12 цифр.

Aльфанумерический идентификатор

Если заданный идентификатор не отвечает требованиям, предъявляемым к численному идентификатору (содержит буквы или другие не численные знаки, напр. имеет больше чем 12 знаков), то его считают альфанумерическим идентификатором. Для альфанумерических идентификаторов существует только одно ограничение, т.е. они не могут иметь больше 16 знаков. Если же количество знаков превысит 16, то в этом случае идентификатор будет обрезан справа.

Численный идентификатор имеет преимущество перед альфанумерическим, потому-что любой идентификатор, который можно интерпретировать как 12-значный номер пункта, считается численным. Если Вы желаете, чтобы, не смотря на вид, он был акцептирован как альфанумерический, то необходимо его обозначить значком ' (апострофом) или взять в скобки. Этот значек не будет частью идентификатора и при выходе будет отстранен.

Дата создания пункта

Эта позиция содержит дату, когда пункт занесен в каталог. В случае пунктов, перевзятых из старших версий системы GROMA, эта позиция не заполняется.

Дата последней модификации пункта

Здесь содержится информация о последней модификации пункта, напр. эдитацией, массовым изменением и т.п. По этим данным можно определить, когда данные о пункте изменялись в последний раз.

Код пункта

Код пункта содержит текстовое описание пункта, состоящее из почти 20-ти знаков, и которое может быть использовано напр. для сохранения описательной информации пунктов, кода для автоматического соединения, названия графической ячейки и т.п. Код может содержать любые альфанумерические знаки. С помощью кодирующей таблицы он может быть переведен в описание, к которому ограничение в 20 знаков не применяется.

Код качества

Однознаковая величина, которую можно использовать для обозначения качества пункта (напр. при работе в кадастре недвижимостей используются численные коды характеристики качества пункта).

Тип пункта

Тип пункта – это однознаковая альфанумерическая величина, похожая на код качества, которую можно использовать любым способом для дальнейшего уточнения информации о пунктах (эту величину можно использовать напр. при выборе в каталогах).

Другие данные в каталогах координат

Координаты X, Y, Z

Координаты пункта в выбраной системе координат. Координаты X и Y являются объязательными, координата Z – не объязательна.

Дополнительные данные 1-4

Другие четыре дополняющие данные, которые можно использовать напр. для глубины закладки инженерных сетей, для другой пары координат и т.п. Эти данные можно произвольно назвать и определить, как должны быть изображены (количество знаков, количество десятичных знаков). Данные можно использовать для обозначения пунктов и можно изменять в массовом порядке.

Другие данные в массивах измерений

Горизонтальный угол

Горизонтальный угол (измеренное направление), получаемый обычно при импорте журнала. Угол, так же как и остальные угловые данные системы GROMA, сохранен в файле в радианах и при всех выписках изображается согласно предварительно установленных угловых единиц. По-этому в момент задания угловых данных необходимо, чтобы были установлены соответствующие угловые единицы. После задания можно где-либо в конфигурации системы GROMA изменить угловые единицы, тогда во всех выписках будут изображаться угловые данные в предварительно установленных угловых единицах.

Длина

Расстояние между станцией и измеряемым пунктом. Эта длина в системе GROMA всегда горизонтальна. Если Вы измеряете (или вводите клавиатурой) наклонные расстояния, то при входе в журнал они будут автоматически приводиться к горизонту. Так что в окнах с журналами измерений всегда изображаются горизонтальные длины, а все расчетные задачи предполагают задание горизонтальных длин. Условием автоматической редукции длин является задание зенитного расстояния или превышения, без которых невозможно выполнить приведение к горизонту.

Более того, при импорте из журнала в длины автоматически вводится поправка за масштаб (влияние высоты над уровнем моря и картографического искажения).

Зенитное расстояние

Зенитное расстояние (угол измереный от зенита). Эта величина используется при высотных расчетах и при детектировании измерений при ином круге.

Превышение

Некоторые приборы при регистрации автоматически переводят измеренное зенитное расстояние в превышение, которое регистрируют. В рамках обработки журнала можно регистрированные зенитные расстояния перевычислить в превышения.

В высотных расчетах можно задать как зенитное расстояние, так и превышение. Если заданы обе величины, то преимущество имеет превышение.

Высота прибора/цели

Эта величина содержит предварительно установленную высоту цели. На станциях в неё включена высота прибора.

Пред. | Начало | След.
Импорт файлов со старых версий системы GROMA | Уровень выше | Курсор


Курсор
Пред. Глава 5. Массивы След.

Курсор

Если массив не пустой, то на одной из его позиций размещен курсор, т.е. черточка, равная высоте строки. Курсор можно передвигать с помощью клавиш <Стрелка Вверх>, <Стрелка Вниз>, <PageUp>, <PageDown>, <Home> a <End>. Курсор обозначает только что выбранную позицию (пункт или измерение), на которую автоматически относятся некоторые операции (редактирование, отстранение и т.п.). Курсор можно передвинуть на любую позицию с помощью мыши.

Пред. | Начало | След.
Глава 5. Массивы | Уровень выше | Редактирование


Редактирование
Пред. Глава 5. Массивы След.

Редактирование

Позицию, на которой находится курсор, можно редактировать нажатием клавиши <Enter> или двойным нажатием мыши. Для редактирования отдельных данных изображается редакц. окно, вид которого зависит от типа массива (редакц. окно для пунктов или измеренных данных).

Пред. | Начало | След.
Курсор | Уровень выше | Добавление позиций


Добавление позиций
Пред. Глава 5. Массивы След.

Добавление позиций

К массиву можно добавить позиции с помощью клавиши <Insert>. После ее нажатия появится диалоговое окно, в которое записывают необходимые информации.

Добавление в каталог координат

Для добавления позиций в каталог координат изображается немодальное окно, поэтому между отдельными позициями можно передвигаться и с помощью клавиши <Enter>. Чтобы ненужно было oтщелкивать данные, которые не заданы, напр. которые не изменяются, можно некоторые позиции выключить с помощью зачеркиваемого окошка вправо от соответствующей позиции. Выключенные окна будут при задавании автоматически не учитываться. В случае выключения номера пункта, он автоматически увеличится на единицу, при этом не нужно его постоянно подтверждать (отщелкивать). В случае выключения установленного кода, он будет без подтверждения отнесен к последующим пунктам вплоть до следующего изменения.

После задания последних необходимых данных пункт автоматически добавляется в каталог, во всех окнах соответствующего каталога на нем размещается курсор, а номер пункта увеличиваетсч на единицу. Неполный номер подтверждать не нужно, если же необходимо его изменить, то можно на него выйти с помощью мыши или клавиши <Shift-Tab>.

Пункт включен в каталог согласно установленного способа распределения пунктов. Если же пункт с данным номером уже существует, то программа предложит оставить в каталоге старый пункт, сохранит новый пункт или сохранит пункт, координаты которого являются средним арифметическим координат старого и нового пунктов.

Если в каталог добавляется пункт с номером, который уже существует, то программа изобразит окно, в котором приводится информация об исходном пункте, новом пункте, приращения координат и другая информация (см. рисунок).

Добавление пункта в каталог координат

В этом случае имеются следующие возможности:

  • Выбрать для пункта новый номер. Номер можно задать во входном окне для номера.

  • Оставить исходные координаты. Для планового и высотного положения выберите в предложении позицию Старые.

  • Сохранить новые координаты. Для планового и высотного положения выберите в предложении позицию Новые.

  • Осреднить новые координаты с исходными. Для планового и высотного положения выберите в предложении позицию Ср. арифметическое В этом случае можно также выбрать вес для исходных и новых координат.

  • Комбинация выше приведенных возможностей. Способ обработки можно выбрать отдельно для планового и высотного положения. Следовательно, можно напр. оставить исходные координаты X и Y, но выбрать новую высоту.

Информация о так обработанном пункте появится в ведомости, включая приращения координат и других данных.

Добавление в журнал измерений

Диалоговое окно для добавления измерений является модальным, т.е. между позициями можно передвигаться с помощью клавиши <Tab>.

Для задания величин выберем тип пункта (Станция / Ориентация / Измеряемый пункт). Кроме того, определив, что длина наклонная, редуцируем ее, и при целесообразности переводим в масштаб плана с помощью масштабного коэффициента.

В журналах измеренных величин позиция добавлена на место курсора.

Пред. | Начало | След.
Редактирование | Уровень выше | Отстранение позиций


Отстранение позиций
Пред. Глава 5. Массивы След.

Отстранение позиций

Позиции в журналах можно отстранять с помощью клавиши <Del>, выбором Эдитация->Отстрани или Эдитация->Перенеси

Если в массиве некоторые позиции обозначены, то программа их отстранит (после вопроса Отстранить все обозначенные позиции?).

Если ни одна из позиций не обозначена, то программа отстранит ту позицию, на которой разместился курсор (после вопроса Отстранить обозначенную позицию?).

Если позиции отстранены командой Эдитация ->Перенеси, то программа перенесла их в ячейку, из которой их можно командой Эдитация->Вложи вложены в любое-другое окно данных или как текст – в другую аппликацию (MS Excel, текстовые эдиторы и т.п.). Вложенные координаты располагаются согласно номеров, а измеренные данные вкладываются перед актуальной позицией курсора.

Пред. | Начало | След.
Добавление позиций | Уровень выше | Обозначение


Обозначение
Пред. Глава 5. Массивы След.

Обозначение

Любые позиции массива можно обозначить для использования некоторой другой функцией (вкладывание в файл, перенесение, отстранение и т.п.).

Обозначение клавиатурой

Для обозначения позиций массива с помощью клавиатури можно использовать следующие клавиши:

Таблица 5.1. Клавиши

Клавишa | Акция
<Пропуск> | Изменит обозначенную позицию на не обозначенную и наоборот, передвинет курсор на следующую позицию.
<Shift+Стрелка вверх> | Обозначает позиции и передвигает курсор в направлении вверх.
<Shift+Стрелка вниз> | Обозначает позиции и передвигает курсор в направлении вниз.
<+> | Обозначит все позиции.
<-> | Отменит обозначение всех позиций.
<*> | Заменит все обозначенные позиции на не обозначенные и наоборот.

Обозначение мышью

Позицию можно обозначить и с помощью левой кнопки мыши. Если держать правую кнопку нажатой и при этом двигать мышью, то программа обозначит все позиции, на которые мышью указываете. Если курсор мыши располагается над или под окно данных, то массив начнет передвигаться вверх или вниз, причем автоматически обозначаются появляющиеся позиции.

При отмене обозначения мышью или клавиатурой поступают также, как и при обычном обозначении.

Массовое обозначение

Позиции в журналах можно обозначать и массово с помощью распределяющего диалогового окна, появляющегося после команды Измерение-> Обозначь nebo Координаты->Обозначь .

В этом диалоговом окне можно задать границы для обозначения (минимальные величины, максимальные величины).

Если у некоторой из позиций задано только максимальное значение, то программа обозначит все позиции, у которых это значение меньше. Аналогично, если задано только минимальное значение, то программа обозначит все позиции, у которых это значение не меньше, чем заданная.

Можно выбрать и режим обозначения:

  • Новое обозначение: Программа обозначит только те позиции, которые отвечают критериям. Обозначение ранее обозначенных позиций отменяется.

  • Добавить к обозначенным: Все позиции, которые отвечают критериям, программа придаст к ранее обозначенным позициям.

  • Отобрать от обозначенных: Все позиции, которые отвечают критериям, программа отберет от ранее обозначенных позиций.

Замечание

При обозначении согласно кода, следует запомнить, что код – это параметр текстовый и в случае, если содержит только цифры. Если заданы при обозначении границы от "1" до "20", то в этом случае не будут обозначены напр. позиции с кодом "5".

Далее можно выбрать, чтобы программа обозначила позиции, которые отвечают хотя бы одному из приведенных условий или только позиции, которые отвечают всем приведенным условиям. Собственно обозначение произойдет после нажатия кнопки (Обозначь).

Диалоговое окно для обозначения содержит также некоторые другие функции:

  • (Обозначить все) Этой кнопкой обозначите все позиции в массиве. Этот же результат можно достичь нажатием клавиши <+> на численной клавиатуре.

  • (Отменить обозначение) Этой кнопкой отмените обозначение всех позиций в массиве. Этот же результат можно достичь нажатием клавиши <-> на численной клавиатуре.

  • (Обозначить альфанумерические) Этой кнопкой обозначите в массиве все позиции с альфанумерическим идентификатором.

  • (Обозначить закрытые) Этой кнопкой обозначите все закрытые позиции в массиве. Наоборот, если Вы желаете обозначить все открытые позиции, тогда обозначьте этим способом закрытые позиции, а нажатием клавиши <*> на численной клавиатуре замените обозначенные на не обозначенные.

  • (Обозначить станции) Этой кнопкой обозначите все станции в массиве измерений.

  • (Обозначить Oznacit orientace) Этой кнопкой обозначите все ориентации в журнале измерений. Если желаете обозначить только измеряемые пункты, обозначьте выше указанным способом все станции и все ориентации, а потом нажатием клавиши <*> на численной клавиатуре замените обозначенные за не обозначенные.

  • (Отменить установку) Этой кнопкой отмените все установки заданные в диалоговом окне для обозначения.

Пред. | Начало | След.
Отстранение позиций | Уровень выше | Поиск позиций


Поиск позиций
Пред. Глава 5. Массивы След.

Поиск позиций

Нажмете ли в перечне какую-либо численную клавишу, то в левом нижнем углу монитора появится малое окно, в котором можете задать номер искомого пункта. Программа обозначит первый пункт заданного номера (без учета неполного номера). В случае, если пункт с данным номером в каталоге отсутствует, то она обозначит ближайший большим номером. Если Вы желаете обозначить следующий пункт с данным номером, то нажмите Стрелку вниз. Поиск можно производить также командой Координаты->Найди позицию или Измерение-> Найди позицию. Окна для поиска закрываем нажатием клавиши <Esc>.

Пред. | Начало | След.
Обозначение | Уровень выше | Выбор изображенных данных


Выбор изображенных данных
Пред. Глава 5. Массивы След.

Выбор изображенных данных

Если некоторые из данных, показанных в массивах, не используются (напр. зенитное расстояние, тип пункта, превышение и т.п.), то можно командой Массив ->Параметры изображения соответствующие столбцы выключить. Изображение установлено только для соответствующего массива и записано в заглавии файла, поэтому сохранится и при следующем открытии. Выбрать можно также щелкнув правой кнопкой мыши по заглавию массива (но не по названию файла, а по первой строке с заглавиями столбиков). Установка изображенных данных сохраняется и при печати.

Подсказка

Желаете-ли некоторые данные отключить надолго для всех файлов, рекомендуем создать основные файлы, в которых соответствующие данные будут отключены. Установку основных файлов перенимает каждый новый создаваемый файл.

Пред. | Начало | След.
Поиск позиций | Уровень выше | Шаг назад


Шаг назад
Пред. Глава 5. Массивы След.

Шаг назад

Операции проведенные в каталогах (изменение, добавление, отстранение позиций) можно вернуть назад Эдитация->Шаг назад. Система GROMA сохраняет информацию об изменениях в каталогах в особой компенсирующей памяти. Эта память для каждого открытого каталога независима, поэтому операции можно возвращать независимо в каждом открытом каталоге отдельно. Количество последних сохраненных операций ограничено объемом памяти, которая для каждого файла составляет 256 KB.

Замечание

Компенсирующая память для шага назад разгружается после переиндексации файла. Поэтому после переиндексации уже нельзя возвратить ранее произведенные изменения.

Пред. | Начало | След.
Выбор изображенных данных | Уровень выше | Перетягивание данных


Перетягивание данных
Пред. Глава 5. Массивы След.

Перетягивание данных

Данные в каталогах можно перетягивать с помощью мыши в разные окна данных. Перетягивать можно как актуальную позицию (т.е. ту, на которой находится курсор), так и весь блок обозначенных позиций.

Порядок действия при перетягивании отдельных позиций

  1. Поместите курсор мышью на нужную позицию.

  2. Нажмите левую кнопку мыши. Тогда на выбранной позиции появится курсор.

  3. Держите нажатой левую кнопку мыши и передвигайте курсор по экрану. При движении можно наблюдать, как курсор мыши изменяется в зависимости от того, в котором окне теперь находится.

    • Закрытая рука: Этот вид курсор имеет в окне, из которого позицию перетягиваем.

    • Открытая рука: Этот вид курсор имеет в окне, которое способно перетягиваемые данные акцептировать (другой каталог одинакового типа, расчетное диалоговое окно и т.п.).

    • Крест: Крест появится в случае размещения курсора на площади главного окна программы.

    • Запрет: Эту форму курсор имеет, если размещен на площади окна, которое не может принять перетягиваемые данные.

  4. Если курсор размещен в соответствующем окне, отпустите левую кнопку мыши. Данные перетянуты или скопированы на необходимие место.

Порядок работы при перетягивании блока позиций

  1. Обозначте необходимые позиции в массиве.

  2. Поместите курсор мышью куда-либо в окно, из которого хотите перетягивать данные.

  3. Нажмите среднюю кнопку мыши. В случае, если имеется только двухкнопочная мышь, нажмите левую кнопку совместно с клавишей <Shift>.

  4. Держите нажатой среднюю (левую) кнопку мыши и двигайте курсором по монитору. Дальнейшие действия те же, как и при перетягивании одной позиции. Отличаются только некоторые формы курсора:

    • Закрытые руки: Эту форму курсор имеет в площади окна, из которого перетягиваете блок.

    • Открытые руки: Эту форму курсор имеет в площади окна, которое способно акцептировать перетягиваемые данные (иной массив того же типа, расчетное диалоговое окно и т.п.).

Копирование данных

Перетягиваете-ли пункты из одного каталога в другой, то после этого в исходном каталоге они отстраняются. Если желаете их скопировать, т.е. оставить и в исходном каталоге, то при освобождении кнопки мыши держите нажатой клавишу <Ctrl>.

Этот порядок действия имеет влияние только на перетягивание в каталог. На перетягивание в расчетные окна не имеет клавиша <Ctrl> влияние, а пункт из каталога не устраняется никогда.

Измерения между окнами данных перетягивать нельзя. Желаете-ли перенести или скопировать измерения из одного файла в другой, используйте копирование через память - функция Эдитация->Перенеси resp. Эдитация->Скопируй и Эдитация->Вложи .

Пред. | Начало | След.
Шаг назад | Уровень выше | Перенумерация массива


Перенумерация массива
Пред. Глава 5. Массивы След.

Перенумерация массива

После выбора команды Координаты->Перенумерация или Измерение-> Перенумерация появится диалоговое окно для перенумерации массива.

Выбор входного и выходного файла

Название входного файла задайте рамке Файл. В случае перенумерации каталога координат можно задать и название выходного файла, так что исходный файл останется без изменения. Это выгодно, в частности, когда исходная и новая нумерация перекрываются, т.е. в случае, если во время перенумерации дошло до конфликта обеих нумераций.

Изменение неполного номера

При изменении неполного номера можно поступать двумя способами:

Установка неполного номера-константы

Желаете-ли, чтобы при изменении у всех пунктов было одинаковый неполный номер, достаточно его значение записать во входное окно. После перенумерации все пункты получат заданный неполный номер.

Желаете-ли, чтобы неполный номер у пунктов отстранить, оставьте входную строчку незаполненной или запишите туда значение 0.

Установка неполного номера с помощью маски

Желаете-ли изменить некоторые части исходного неполного номера, тогда можно использовать изменение неполного номера с помощью маски. Маска позволяет изменить только некоторые цифры в неполном номере. Маску можно задать двумя способами:

  • Маска с вопрос. знаками

    Задаете-ли маску в форме ???xx??? (предварительно можно использовать и эквивалентную запись ###xx###), то цифры на позициях, на которых в маске стоят вопрос. знаки (или решетки), будут сохранены, а остальные цифры будут заменены знаками, заданными в маске.

    Исходный неполный номер 12345678 по заданию маски ???9???? изменилось бы на 12395678. Знаки на позициях вопрос. знаков были бы сохранены, четвертая цифра неполного номера была бы заменена цифрой 9.

  • Маска с позициями

    Предыдущий способ пригоден в случае, когда заменяют отдельные цифры, но не изменяют их очередность. В случае, если необходимо напр. первые три цифры передвинуть на конец неполного номера, то предыдущим способом этого не достичь. Однако, маску можно задать и способом, когда на место вопрос. знаков запишем позиции знаков, находящихся в неполном номере в ломанных скобках (напр. <8><7><6>9<4><3><2><1>).

    Учитывая, что все неполные номера не должны иметь одинаковое количество знаков, все позиции нумеруются не слева, а справа. Тогда приведенной маской получим теже изменения, как и в предыдущем случае (результирующий неполный номер будет опять 12395678).

    Желаете-ли использовать индексы, которые пронумерованы слева, можете писать цифры в ломанных скобках со знаком минус. Тогда запись <1> обозначает первый знак справа, запись <-1> - первый знак слева. Такого же результата, как и в предыдущем случае, можно достичь и с помощью маски <-1><-2><-3>9<-5><-6><-7><-8>.

    Более того, при перенумерации с помощью маски, цифры можно как-либо перебрасывать. Зададите-ли напр. маску <3><2><1>??<8><7><6>, первые три цифры будут заменены на последние три цифры, а четвертая и пятая цифры останутся без изменений. Исходный неполный номер 12345678 бы был по заданию этой маски изменен на 67845123.

Изменение номера

Желаете-ли изменить номера пунктов, включите зачеркиваемым окошком изменение номера и задайте начальный номер пункта.

В случае, если желаете, чтобы при перенумерации каталога координат шаг был иной чем 1, то его можно задать во входном окне Шаг. Если, как начальный номер пункта зададите наибольший необходимый номер, а шаг зададите -1, то каталог координат будет перенумерован по нисходящей от заданного номера пункта (тем самым, одновременно произойдет изменение очередности пунктов в каталоге).

В случае каталога координат перенумерацию можно провести в новом файле (в старом файле пункты останутся без изменений, а пункты с новыми номерами появятся в новом файле), или в рамках одного файла (пунктам будут изменены номера).

Кроме стандартного способа изменения номеров можно использовать и изменение номера с помощью маски, так же, как и неполного номера.

Замечание

Если при перенумерации каталога координат в неполном номере или номере пункта использована маска, рекомендуем выполнить перенумерацию в новом незаполненном каталоге координат. Если перенумерация будет произведена в исходном файле, то появится предупреждение с вопросом, если программа должна с перенумерацией продолжать.
Внимание

После перенумерации в рамках одного файла перенумерованный файл автоматически переиндексовывается, поэтому перенумерацию нельзя возвратить командой Эдитация->Шаг назад.

Перенумерацию массива включите кнопкой ( Перенумерация). Можно выбрать перенумерацию всего массива или только обозначенной позиции. Более того, при перенумерации массива измерений, программа предлагает следующие варианты:

  • Перенумерация станции

    Если выберете этот вариант, то при перенумерации будут изменены и номера станций. Если этот вариант не выбран, то номера станций останутся без изменений.

  • Перенумерация напралений Если выберете этот вариант, то при перенумерации будут изменены и номера направлений. Если этот вариант не выбран, то номера направлений останутся без изменений.

  • Перенумерация альфанумерическая

    Если выберете этот вариант, то при перенумерации будут изменены и номера пунктов с альфанумерическими идентификаторами.

  • Сохранить дубликаты

    В массивах измерений некоторые номера пунктов могут повторяться (напр. в случае повторного измерения). При нормальной перенумерации оба измерения получили бы разные номера, согласно позиции, на которой они в массиве находятся. Если выберете этот вариант, то после перенумерации все эти измерения будут иметь опять идентичный номер пункта (такой, который получит первое измерение на данном пункте).

После перенумерации изображается ведомость, содержащая таблицу старых и новых номеров пунктов.

Пред. | Начало | След.
Перетягивание данных | Уровень выше | Массовые изменения в массивах


Массовые изменения в массивах
Пред. Глава 5. Массивы След.

Массовые изменения в массивах

В каталогах координат и в массивах измерений можно выполнять массовые изменения. Командой Координаты->Массовые изменения или Измерения->Массовые изменения появится диалоговое окно, в котором можно определять изменения, которые необходимо в массиве провести.

Диалоговое окно содержит рамки для отдельных данных, которые можно с помощью массовых изменений исправлять. Каждая рамка содержит зачеркиваемое окошко Изменить, которым выбираете, какие из данных с помощью массовых изменений изменить. Если это окошко включите, то программа покажет Вам установку изменения для соответствующего данного. В редакц. окошко можно записать численную константу или функциональную зависимость, результатом которого есть численная величина.

Тип изменения

Под редакц. окошком можно выбрать, как программа должна при массовых изменениях поступить с полученным результатом. В зависимости от типа данного программа предлагает все или некоторые из следующих возможностей:

  • Установка

    Данное будет установлено на заданную величину или на результат заданного выражения, не смотря на исходную величину данного.

  • Умножить

    Исходное данное будет на заданую величину или на результат заданного выражения умножено. Если необходимо вместо умножения делить, то задайте величину коеффициента с противоположным знаком.

  • Прибавить

    просуммировано с заданной величиной или с результатом заданного выражения. Если необходимо заданную величину отнять, то задайте ее с противоположным знаком.

  • Отстранить

    Исходное данное будет из массива отстранено. Таким образом, можно напр. отстранить высоту цели и т.п. Исходное данное можно из массива отстранить и так, что выберем команду Установить а редакц. окошко с соответствующим данным остаким незаполненным.

Замечание

Некоторые данные (напр. координаты X и Y) объязательны, поэтому отстранить их из каталога нельзя.

Функциональные зависимости

В редакц. окна, кроме численных величин, можно записывать и функциональные зависимости, в которых можно использовать обычные математические операции, константы и предопределенные переменные. Предопределенные переменные приведены в следующих таблицах:

Таблица 5.2. Переменные для массовых изменений в каталоге координат

Название переменной | Содержание переменной
PREFIX | Неполный номер пункта
NUM | Номер пункта
X, Y, Z | Координаты X, Y, Z
INFO1, INFO2, INFO3, INFO4 | Потребительские информации 1-4

Таблица 5.3. Переменные для массовых изменений в массиве измерений

Название переменной | Содержание переменной
PREFIX | Неполный номер пункта
NUM | Номер пункта
HZ | Горизонтальное направление
Z | Зенитное расстояние
DIST | Горизонтальное проложение
DH | Превышение
SIGNAL | Высота прибора/цели

Таблица 5.4. Общие переменные для всех типов выражений

Название переменной | Содержание переменной
XRED, YRED, ZRED | Редукция координат согласно установки
SCALE | Установленный масштабный коэффициент
PI | Константа ? (3.14159265358979)
RO | Радиан в g (63.66197723675813)

Желаете-ли напр. прибавить к абсциссе X константу 100 м, можно поступить двумя способами:

  • В эдитационном окошке запишем константу 100 и выберем команду Прибавить.

  • В эдитационном окошке запишем функциональную зависимость X+100 и выберем команду Установить.

Результаты, полученные обеими способами, будут похожи.

В этом случае безусловно проще первый способ, но с примера видно, что второй способ предлагает значительно больше возможностей:

  • Им можно записать любую сложную математическую операцию

    В выражении может быть любое количество математических операций.

  • В выражении можно использовать и остальные переменные.

    Это значит, что можно записать напр. зависимость (X+Y)/2, которая вычыслит ср. арифметическое из обеих координат.

  • Можно заменить отдельные данные.

    Этим способом можно менять данные местами. Например, можно заменить отдельные потребительские данные. Скажем, если в редакц. окно для Info 1 запишем INFO2, а в редакц. окно для Info 2 запишем INFO1, то эти двое данных будут поменяны местами. Аналогично можем заменить напр. потребительские информации о координатах, т.е. для каждого пункта в одном файле можем иметь несколько пар координат.

Замыкание пунктов

При изменениях в каталоге координат можно одновременно менять и атрибут пункта. Если выберите команду Замкнуть, то все изменяемые пункты будут замкнуты. При выборе команды Открыть все изменяемые пункты будут открыты. При выборе команды Неменять атрибут изменяемых пунктов останется без изменений.

Изменение атрибута измеряемого пункта

При изменении в массиве измерений можно изменить атрибут пункта. Если выберете команду Измеряемый пункт, то все изменяемые пункты будут заменены на измеряемые пункты. При выборе команды Ориентация у всех измеряемых пунктов будет изменена ориентация. При выборе команды Неменять атрибут изменяемых пунктов останется без изменений.

Замена X и Y

С помощью кнопки (Заменить X и Y), можно взаимно заменить координаты X и Y во всем файле или у обозначенных пунктов. Эта возможность целесообразна напр. тогда, когда в систему GROMA начтете текстовый каталог координат, а потом вияснится, что в нем взаимозаменены координаты X и Y.

Обозначение пунктов

После нажатия кнопки (Обозначить) появится диалоговое окно для обозначения позиций в каталоге. Если в каталоге некоторые позиции обозначены, то можно выбрать изменение в целом файле или только у этих обозначенных позиций.

Пред. | Начало | След.
Перенумерация массива | Уровень выше | Глава 6. Каталог координат


Глава 6. Каталог координат
Пред. Часть I. Руководство для потребителя След.

Глава 6. Каталог координат

Важнейшим файлом при работе с программой GROMA является обычно каталог координат. Каталог координат содержит координаты пунктов, которые используют большинство функций программы, а много функций в каталоге пункты сохраняет.

Программа позволяет одновременно открыть любое количество каталогов координат.

Передвижение в каталоге координат

Файл с координатами изображается в виде каталога, причем видно только ту его часть, с которой в этот момент работаете. Курсор размещен на актуальной строке, а передвигать его можно с помощью клавиатуры или мыши.

Таблица 6.1. Клавиши

Клавиша | Акция
<Стрелка вверх> | Передвижение курсора на строку вверх
<Стрелка вниз> | Передвижение курсора на строку вниз
<PageUp> | Передвижение курсора на страницу вверх
<PageDown> | Передвижение курсора на страницу вниз
<Home> | Передвижение курсора на начало файла
<End> | Передвижение курсора на конец файла

Пред. | Начало | След.
Массовые изменения в массивах | Уровень выше | Закрытие пунктов на замок


Закрытие пунктов на замок
Пред. Глава 6. Каталог координат След.

Закрытие пунктов на замок

Пункты в каталогах координат можно закрыть на замок, чтобы их нельзя было переписать или отстранить. О том, что пункты под замком сигнализирует символ замка в левой части каталога координат (перед номером пункта). Пункты можно замкнуть двумя способами:

  • Отдельные пункты

    При эдитации пункта (напр. нажатием клавиши <Enter>) можно, как одно из свойств, выбрать его закрытие на замок.

    Если включена команда Файл->Установка->Среда: Быстрое закрытие на замок/окрытие пунктов, то отдельные пункты можно закрыть и открыть щелкнув мышью у левого края каталога (перед номером пункта).

  • Массово

    Весь каталог координат или обозначенные пункты можно закрыть на замок или открыть с помощью массового изменения (команда Координаты->Массовое изменение).

Закрытые пункты нельзя отстранить или переписать. Изменить их можно только с помощью эдитации пунктов (напр. клавишей <Enter>) или после открытия. Если в каталог добавить пункт с номером, который уже в каталоге существует, но закрыт, то тогда появится диалоговое окно с информацией о приращениях координат и с предлагаемой единственной возможностью: оставить в каталоге исходный пункт без изменения.

Пред. | Начало | След.
Глава 6. Каталог координат | Уровень выше | Группирование каталога координат


Группирование каталога координат
Пред. Глава 6. Каталог координат След.

Группирование каталога координат

Для быстрой манипуляции каталог координат сгруппирован. В то время, как собственно каталог координат физически размещен на диске (файл .crd), данные о группировании пунктов (файл .crx) сохранены в памяти компютера для быстрой манипуляции.

Каталог координат может быть сгруппирован тремя способами:

  • По неполному номеру

    Пункты в каталоге координат сгруппированы, по-первых, по неполному номеру пункта, а во-вторых, по номеру пункта. Тогда в файле пункты распределены последовательно с одинаковым неполным номером и разным номером пункта. Это наиболее распространенный способ группирования.

  • По номеру

    Пункты сгруппированы, во-первых, по номеру пункта и, во-вторых, по неполному номеру пункта. Тогда в файле пункты распределены последовательно с одинаковым номером и разным неполным номером.

  • Несгруппировано

    В этом случае пункты в каталогах координат не сгруппированы, а приведены в такой последовательности, в какой файл добавлялись. Эта последовательность однако нарушится, напр. при компрессии файла, если в момент компрессии установлен иной способ группирования (при компрессии файла создается новый файл, в котором все пункты записаны в такой последовательности, в какой в момент компрессии изображены).

Группирование по неполному номеру и по номеру касается только пунктов с идентификатором. В случае альфанумерического идентификатора и неполный номер и номер не различаются. Эти пункты сгруппированы по алфавиту (т.е. как в телефонном справочнике).

Способ группирования можно установить только для целой системы GROMA сразу, т.е. нельзя выбрать для каждого каталога иной способ группирования. Способ группирования устанавливается в Файл->Установка->Среда.

Пред. | Начало | След.
Закрытие пунктов на замок | Уровень выше | Активный каталог координат


Активный каталог координат
Пред. Глава 6. Каталог координат След.

Активный каталог координат

Если открыто несколько каталогов координат, то один из них имеет обычно такое свойство, что выбран как активный. Название активного файла изображено в информационной строке. При запуске программы установлен как активный тот каталог координат, который открыт как первый.

То, который каталог координат активный, имеет влияние на много других функций программы (напр. поиск и сохранение пунктов).

В некоторых случаях целесообразно не иметь ни один из открытых каталогов координат активным (напр. при предварительных расчетах, результаты которых не должны сохраняться).

Выбор активного каталога координат

Активный каталог координат можно выбрать тремя способами:

  • После команды Файл->Актуальный каталог координат появится диалоговое окно с перечнем открытых файлов,из которых можно выбрать активный каталог. Если не хотите иметь активным ни один каталог, то выберите позицию [Никакой].

  • Дважды щелкнув на информационную строку, появится тоже диалоговое окно, как и при выборе с помощью меню.

  • Перетяните мышью из каталога любую позицию на информационную строку, так же, как перетягиваются данные в расчетные окна.

Пред. | Начало | След.
Группирование каталога координат | Уровень выше | Поиск в каталоге координат


Поиск в каталоге координат
Пред. Глава 6. Каталог координат След.

Поиск в каталоге координат

Если программе когда-либо нужны координаты одного из пунктов, то она стремится разыскать их в каталоге координат. Этот поиск происходит согласно одного и того же алгоритма, не смотря на то, по какой причине (которой функцией) пункт разыскивается. Порядок поиска зависит от установки некоторых параметров среды.

Если в диалоге Файл->Установка->Среда включен выбор "Искать во всех открытых файлах", программа всегда будет искать во всех открытых каталогах координат. В противном случае будет искать только в активном каталоге координат.

Если в диалоге Файл->Установка->Среда включен выбор "Искать только неполные номера", программа будет искать такие пункты, у которых соответствуют номер и неполный номер. В противном случае она неполный номер игнорирует, но разыщет все пункты с данным номером, не глядя на их неполные номера.

Замечание

Если установлен поиск по неполному номеру, то ход поиска значительно быстрее, чем при поиске только по номеру (у больших каталогов координат различие может быть значительным). Это вызвано тем, что каталог координат не может содержать больше пунктов с одинаковим неполным номером и номером. Более того, каталог сгруппирован, во-первых, по неполному номеру и, во-вторых, по номеру, поэтому для поиска пунктов можно использовать сравнительно быстрый алгоритм. После того, как пункт найден, нет необходимости каталог дальше просматривать. Пунктов же с одинаковим номером и различным неполным номером может быть в каталоге больше (в каталоге они могут располагаться в любом месте), поэтому при поиске только по номеру необходимо всегда просмотреть весь файл.

В случае, если программа разыщет больше пунктов с отличающимися оординатами, но которые отвечают критериям, изобразит диалоговое окно с каталогом координат (в т.ч. с названиями файлов, в которых пункты найдены) и разрешит выбрать соответствуюший пункт, то, если Вы теперь выберете в этом каталоге позицию [Никакой], программа будет себя вести так, как будто бы никакой пункт не нашла.

Пред. | Начало | След.
Активный каталог координат | Уровень выше | Сохранение пунктов


Сохранение пунктов
Пред. Глава 6. Каталог координат След.

Сохранение пунктов

В некоторых расчетных функциях вычисленные пункты автоматически сохраняются в активном каталоге координат (напр. полярный метод). Если никакой активный каталог координат не установлен, то программа сама расчитанный пункт не сохранит, но его можно сохранить ручным перетягиванием в любой каталог координат. Это может быть целесообразно, например, при предварительных расчетах, результаты которых не должны сохраняться.

В расчетных функциях, где необходимо задать выходной файл для расчитанных координат (полярный метод дохой и т.п.), автоматически установлен при запуске расчета активный каталог координат (если преварительно не установлен иной файл).

Пред. | Начало | След.
Поиск в каталоге координат | Уровень выше | Графическое изображение пунктов


Графическое изображение пунктов
Пред. Глава 6. Каталог координат След.

Графическое изображение пунктов

Если необходимо каталог координат изобразить графически, выберите команду Координаты->Изобрази графически. Программа откроет для соответствующего каталога координат предписание по черчению (файл .pic). Если файл с предписанием по черчению не существует, то программа создаст пустой файл.

Пред. | Начало | След.
Сохранение пунктов | Уровень выше | Группирование каталога координат согласно номенклатуры


Группирование каталога координат согласно номенклатуры
Пред. Глава 6. Каталог координат След.

Группирование каталога координат согласно номенклатуры

Командой Координаты->Сгруппируй согласно номенклатуры вызовете диалоговое окно, которое поможет сгруппировать каталог координат в файлы согласно номенклатуры.

Использование этого окна подробно описано в Руководстве по применению.

Пред. | Начало | След.
Графическое изображение пунктов | Уровень выше | Сравнение каталогов координат


Сравнение каталогов координат
Пред. Глава 6. Каталог координат След.

Сравнение каталогов координат

После командыКоординаты->Сравнение каталогов координат появится диалоговое окно для проведения статистического теста каталогов координат. Программа сравнит два каталога координат, вычислит приращения координат для отдельных пунктов, предварительные средние квадратические ошибки и другие данные. Подробное описание приведено в Руководстве по применению .

Пред. | Начало | След.
Группирование каталога координат согласно номенклатуры | Уровень выше | Контроль дублирующихся номеров


Контроль дублирующихся номеров
Пред. Глава 6. Каталог координат След.

Контроль дублирующихся номеров

После команды Координаты->Контроль дублирующихся номеров будет выпонен поиск в каталоге координат дублирующихся номеров. Результат сохраняется в ведомости.

Пред. | Начало | След.
Сравнение каталогов координат | Уровень выше | Отстранение идентичных пунктов


Отстранение идентичных пунктов
Пред. Глава 6. Каталог координат След.

Отстранение идентичных пунктов

После командыКоординаты->Отстранение идентичных пунктов появится диалоговое окно, которое служит для поиска пунктов с отличающимися номерами, но с тождественными (или близкими) координатами. Подробное описание приведено в Руководстве по применению.

Пред. | Начало | След.
Контроль дублирующихся номеров | Уровень выше | Контроль нумерации пунктов


Контроль нумерации пунктов
Пред. Глава 6. Каталог координат След.

Контроль нумерации пунктов

С помощью этой функции можно сконтролировать последовательность номеров пунктов в каталоге координат. Программа сконтролирует нумерацию и изобразит ведомость, в которой покажет информацию о пропусках в нумерации.

Пред. | Начало | След.
Отстранение идентичных пунктов | Уровень выше | Округление координат


Округление координат
Пред. Глава 6. Каталог координат След.

Округление координат

После приказа Координаты->Округление координат появится диалоговое окно для округления всего каталога координат (или обозначенных позиций) до установленного числа десятичных знаков. Подробное описание приведено в Руководстве по применению .

Пред. | Начало | След.
Контроль нумерации пунктов | Уровень выше | Восстановление отстраненных позиций


Восстановление отстраненных позиций
Пред. Глава 6. Каталог координат След.

Восстановление отстраненных позиций

После приказа Координаты->Восстановление отстраненных позиций появится диалоговое окно, с помощью которого в новом файле можно восстановить все позиции, которые были в данном каталоге отстранены, начиная от последней компримации файла. Подробное описание приведено в Руководстве по применению.

Пред. | Начало | След.
Округление координат | Уровень выше | Присоединение файла


Присоединение файла
Пред. Глава 6. Каталог координат След.

Присоединение файла

После приказа Координаты->Присоедини файл появится диалоговое окно для выбора файла, с помощью которого можно к существующему каталогу координат присоединить пункты из другого каталога. Импортированный файл может быть в формате системы GROMA или в каком-либо другом формате, в который GROMA может импортировать пункты (текстовый файл, файл в формате XML и т.п.).

Пред. | Начало | След.
Восстановление отстраненных позиций | Уровень выше | Координаты в разных координатных системах


Координаты в разных координатных системах
Пред. Глава 6. Каталог координат След.

Координаты в разных координатных системах

Система GROMA позволяет иметь в каталогах координат для каждого пункта две пары координат X и Y. В этом случае каждый пункт может иметь координаты, напр. в государственной и местной системе или в общем в двух разных системах координат.

Вторая пара координат сохранена в каталоге с помощью потребительских информаций о пункте (INFO1 a INFO2). Поэтому способ изображения (название, количество десятичных знаков и т.п.) можно установить в информациях о файле командой Файл->Информация о файле.

Программа всегда включает в расчет первые приведенные координаты (как активные координаты), а вторые считает вспомогательными. Если необходимо начать работать с вторым комплектом координат, то необходимо заменить первые координаты вспомогательными. Эту замену можно выполнить с помощью диалогового окна, которое появится после команды Координаты->Координаты в двух системах .

Система содержит и другие функции для работы с разными координатными системами:

  • Массовое дополнение второй пары координат из дополнительного каталога по номерам пунктов.

  • Экспорт вспомогательных координат в новый файл.

  • Отстранение всех или только нулевых вспомогательных координат.

  • Замена первых и вспомогательных координат.

Описание отдельных функций приведено в Руководстве по применению.

Пред. | Начало | След.
Присоединение файла | Уровень выше | Глава 7. Журнал измерений


Глава 7. Журнал измерений
Пред. Часть I. Руководство для потребителя След.

Глава 7. Журнал измерений

Выбор деталей изображения

В журналах измерений можно выбрать детали изображения. Программа предлагает следующие возможности:

  • Избразить все позиции

  • Избразить только станции и ориетацию

  • Избразить только станции

Детали изображения можно выбрать двумя способами:

  • Выбор для целого файла

    С помощью диалогового окна Измерение->Параметры изображения можно выбрать, что необходимо изобразить: все позиции, станции с ориентациями или только станции. Эта установка будет введена для всего файла.

  • Выбор для отдельных станций

    Если необходимо изменить детали изображения для отдельных станций, то изменение можно выполнить щелкнув мышью по символу деталей изображения в левом столбике каталога (перед номером станции). Щелкнув повторно циклически изменяются детали изображения.

Пред. | Начало | След.
Координаты в разных координатных системах | Уровень выше | Перенумерация журнала измерений


Перенумерация журнала измерений
Пред. Глава 7. Журнал измерений След.

Перенумерация журнала измерений

После команды Измерение->Перенумерация появится диалоговое окно для перенумерации журнала измерений. В отличие от каталога координат перенумерация журнала измерений происходит в рамках одного файла (не нужно проводить перенумерацию из одного файла в другой). В диалоговом окне выберем величины, которые необходимо изменить (неполный номер, номер), и обозначим то, что нужно изменить: ориентации и станции. Перенумерацию начнем кнопкой (Перенумеровать). Если в журнале измерений повторяюся номера пунктов, то эти пункты опять получат тождественные номера. После перенумерации появится ведомость, содержащая таблицу старых и новых номеров пунктов.

Пред. | Начало | След.
Глава 7. Журнал измерений | Уровень выше | Обработка журнала


Обработка журнала
Пред. Глава 7. Журнал измерений След.

Обработка журнала

Программа GROMA позволяет комплексную обработку журнала измеренных величин, включая обработку измерений при обеих положениях трубы, измерения линий в прямом и обратном направлениях и т.п.

После команды Измерение->Обработка журнала появится диалоговое окно, в котором можно установить, какие исправления журнала необходимы.

Перед расчетом журнала необходимо сначала определить теодолит с помощью команды Файл->Установка->Теодолит. При определении теодолита установите допуск для измерений при круге право и круге лево, невязку для линии, измеренной в прямом и обратном направлениях и т.п. После этого, отдельные измерения в журнале обозначаются согласно установленных допусков как ненадежные или ошибочные.

Программа поставляется с предварительно определенным теодолитом под названием "Неизвестный теодолит", в определении которого установлены имплицитные допуски для тестирования ненадежных и ошибочных измерений.

Информация о всех изменениях в журнале измерений сохраняются в ведомости. В некоторых случаях целесообразно записать изменения только в ведомость, а журнал измерений оставить в первоначальном состоянии. В этом случае выберем Только в ведомость и программа оставит журнал без изменения.

Далее можно выбрать, если исправить весь файл измерений или только обозначенные позиции.

Собственно обработку журнала запустим нажатием кнопки (Исправить). Программа постепенно выполнит все исправления, которые были выбраны.

При обработке журнала программа руководствуется следующими правилами:

  • Если тестируемое значение (невязка длин, измеренных в прямом и обратном направлениях; расхождение направлений, измеренных при обеих положениях кругах) меньше, чем значение, установленное у избранного теодолита как Ненадежное, то программа данный расчет выполнит.

  • Если тестируемое значение находится в интервале, который дан значением, установленным как Ненадежное и значением, установленным как Ошибочное, то программа данный расчет выполнит, но в ведомости его обозначит вопросительным знаком "?" как ненадежный.

  • Если тестируемое значение превысит значение, установленное как Ошибочное, то программа данный расчет не выполнит, в журнале оставит исходное измерение, а данные о не выполненном расчете сохранит в ведомости со знаком "x" как ошибочные.

Обработка измерений при обеих положениях круга

На каждой станции программа разыщет два направления, измеренных на один пункт при обеих положениях круга трубы. После этого вычислит коллимационную ошибку, отнимет ее от коллимационной ошибки, которая приведена в определении теодолита, и сранит полученное расхождение с допусками, приведенными в определении теодолита.

Подобным образом обработает и зенитные расстояния (если измерялись) и длины.

Если все полученные расхождения отвечают допускам, приведенным в определении теодолита, то программа исправит измерение при первом положении круга так, чтобы содержало среднее значение из обеих измерений.

Если хотя бы одно из вычисленных расхождений превышает значение, приведенное в определении теодолита как ненадежное, то программа обозначит в ведомости все измерение как ненадежное.

После обработки журнала измерений в протоколе сохраняется также оценка действительных значений инструментальных ошибок.

Редукция направлений

При редукции направлений программа исправит все направления на станции так, чтобы значение ориентации первого направления (первая позиция в журнале измерений) было равно нулю, т.е. от всех направлений отнимет значение ориентации первого направления.

Исправление места зенита (МЗ) или места нуля (МО)

Если Ваш прибор автоматически не исправляет ошибку места зенита, но если Вы знаете ее значение, то установите ее в определении теодолита и используйте этот выбор для исправления измеренных зенитных расстояний.

Исправление рефракции

Этот выбор позволяет исправить измеренные зенитные расстояния или превышения за влияние рефракции и кривизну Земли. Перед началом расчета выберите с помощью кнопки (Установка) значение рефракционного коеффициента, а также которые исправления необходимо выполнить.

Расчет превышений

После обозначения этой позиции, у всех измерений, которые содержат длину и зенитное расстояние, программа расчитает превышение и сохранит его в массиве измерений.

Редукция превышений на горизонтальную линию, соединяющую пункты, между которыми определяется превышение

У измерений, у которых определено превышение (или зенитное расстояние), высота прибора и высота цели, программа расчитает превышения непосредственно между пунктами, т.е. превышения, исправленные за высоту прибора и высоту цели. Высоту прибора и цели потом установит на нулевое значение, чтобы не происходили ошибки при высотных расчетах. Эту редукцию необходимо выполнить перед введением данных для высотного уравнивания.

Обработка повторных ихмерений

На каждой станции программа разыщет группы измерений на туже цель и при том же положении круга теодолита. Из найденных измерений расчитает результирующее среднее измерение. Если исправленные отдельные измерения будет соответствовать установленным допускам, то соответствующие измерения будут из журнала исключены, а первое измерение булет исправлено так, чтобы равнялось средним значениям.

Обработка линий и превышений, измеренных в прямом и обратном направлениях

Программа постепенно разыщет во всем журнале измерений для каждой измеренной длины соответствующую длину, измеренную в противоположном направлении. После ее нахождения, расчитает среднее значение и, в случае, если его исправление не превышает установленного допуска, то сохранит ее у обеих измерений. Подобным образом поступает и у превышений.

Если хотя бы одна из вычисленных невязок больше, чем величина, установленная в определении теодолита как ненадежная, то программа обозначит в ведомости все измерение как ненадежное.

Пред. | Начало | След.
Перенумерация журнала измерений | Уровень выше | Обозначение ориентации


Обозначение ориентации
Пред. Глава 7. Журнал измерений След.

Обозначение ориентации

В некоторых задачах система GROMA использует обозначение ориентации. Ориентация в журнале измерений изображается утолщенно и может располагаться в любом месте (т.е. может и не быть вначале записи на станции). При импорте из формата журнала программа автоматически обозначит ориентацию (если это позволяет формат соответствующего журнала). Для отдельных пунктов можно атрибут ориентации изменять с помощью эдитации. Если необходимо изменить этот атрибут для большего числа пунктов, то можно использовать это диалоговое окно.

В окне выберите, согласно каких критериев должна обозначаться ориентация, а также, если пункты, отвечающие данным критериям, должны быть присоединены к уже имеющимся ориентациям или необходимо выполнить новое ее обозначение (в этом случае необходимо сначала атрибут Ориентация у всех пунктов отменить).

Пункты, использованные как станции

При этом выборе будут обозначены как ориентация все измерения на пункты, которые былы также использованы как станции.

Пункты, найденные в каталогах координат

При этом выборе, как ориентация, будут обозначены измерения на пункты, которые в данный момент сохраняются в журналах / каталогах координат (с учетом установленного режима поиска пунктов).

Пункты с кодом ориентации

как ориентация будут обозначены те измерения, у которых в коде содержится установленный код ориентации (может быть составной частью длинного кода, но в этом случае должен быть правильно установлен разделитель кодов в установке кодирования).

Пункты с номером большим чем

Можно установить численную границу, от которой пункты считаются ориентирными. Эта граница обычно бывает 2000, 4000 или 5000.

Пункты с неполным номером

Здесь можно установить неполный номер, которым обозначены измерения на ориентирные пункты.

Пункты с неполным номером большим чем

Здесь можно установить численную границу неполного номера, от которой пункты считаются как ориентирные.

Пред. | Начало | След.
Обработка журнала | Уровень выше | Соединение файлов измерений


Соединение файлов измерений
Пред. Глава 7. Журнал измерений След.

Соединение файлов измерений

С помощью командыИзмерение->Присоедини файл можно к концу открытого журнала измерений присоединить другой журнал измерений. Такого же результата можно достичь, если откроете другой файл и скопируете его в первый с помощью памяти. В этом случае новые пункты скопируются на позицию курсора, а не на конец файла.

Пред. | Начало | След.
Обозначение ориентации | Уровень выше | Восстановление отстраненных позиций


Восстановление отстраненных позиций
Пред. Глава 7. Журнал измерений След.

Восстановление отстраненных позиций

После команды Координаты->Восстановление отстраненных позиций появится диалоговое окно, с помощью которого можно в новом файле восстановить все позиции, которые были в данном журнале отстранены, начиная последней компрессией файла. Подробное описание приведено в Руководстве по применению .

Пред. | Начало | След.
Соединение файлов измерений | Уровень выше | Глава 8. Проекты


Глава 8. Проекты
Пред. Часть I. Руководство для потребителя След.

Глава 8. Проекты

Если начинаете работаете над большым заказом или над повторным заказом, то целесообразно разработать для этого проект. Проект – это самостоятельное окно данных, в котором можно создать перечень файлов, касающихся соответствующего заказа. В проект можно записать файлы данных (каталоги координат, измерения, журналы, текстовые файлы) и файлы с сохраненными расчетами (полигонометрические хода, площади, результаты обмеров, трансформации и т.п.).

В проекте, кроме использованых файлов, сохраняют и некоторые установки программы (масштабный коэффициент, количество десятичных знаков, исходные файлы и т.п.).

Закладка проекта

Новый проект закладываем командой Файл->Новый и выбором типа файла Проект. После закладки проекта откроется пустое окно, в которое можно добавлять, относящиеся к заказу, файлы.

Пред. | Начало | След.
Восстановление отстраненных позиций | Уровень выше | Добавление / отстранение файлов


Добавление / отстранение файлов
Пред. Глава 8. Проекты След.

Добавление / отстранение файлов

Файлы можно добавлять двойным способом:

  • Командой Проект->Добавить файл

    После этой команды появится диалоговое окно с перечнем всех открытых файлов (тех, которые еще в проект не включены). Здесь можно выбрать файл (или файлы), которые необходимо добавить в проект. Этим способом можно добавлять только файлы данных (каталоги координат, журналы измерений, ведомости, графику, текстовые и растровые файлы).

  • Перетягивание мышью

    Каталоги координат или журналы измерений можно добавить в проект обычным перетягиванием мышью. Этим способом можно добавить и сохраненные файлы с расчетами (полигонометрические хода, площады, результаты обмеров, трансформации и т.п.). Последовательность действий, при перетягивании файлов в окно с проектом, идентична сохранению результатов в каталоге.

В окне с проектом изображена структура в виде дерева, где файлы расположены согласно типов. Любой файл можно открыть дважды щелкнув мышью по его названию в перечне. Окно с файлом открывается на том месте и с такими же размерами, какие имело при предыдущем закрытии.

Если файл данных, который будет добавлен к проекту, находится в той же папке, что и сам проект, то будет добавлен к проекту только с помощью самого названия файла не по полному адресу. Целый проект вместе с файлами данных может быть пересунут в иную папку или на другой диск, а файлы данных будут и в дальнейшем открываться нормально. Однако, если добавляемый файл находится в другой папке чем проект, то будет добавлен по полному адресу, а если будет пересунут, то его нельзя будет в проекте снова открыть.

Если Вам необходимо отстранить какой-либо файл из проекта, то выберите его командой Проект->Отстранить файл.

Пред. | Начало | След.
Глава 8. Проекты | Уровень выше | Сохранение проекта


Сохранение проекта
Пред. Глава 8. Проекты След.

Сохранение проекта

Новый проект можно сохранить командой Файл->Сохрани или Файл->Сохрани как. Стандартная припона проекта .prj.

Адреса к отдельным файлам в проекте сохраняются относительно расположения собственно файла с проектом. Если проект с соответствующими файлами пересунут на другое место и, если при этом сохранены местоположения файлов относительно проекта, нет необходимости в проекте проводить изменения, потому-что и на новом месте все будет работать.

Важно

Относительные адреса можно использовать только в случае, если файлы данных находятся на том же приспособлении, что и файл с проектом (напр. все на диске C:).

Пред. | Начало | След.
Добавление / отстранение файлов | Уровень выше | Открытие проекта


Открытие проекта
Пред. Глава 8. Проекты След.

Открытие проекта

  • Командой в меню

    Проект можно открыть также, как какой-либо файл данных - командой Файл->Открой. В перечень типов файлов выберите тип Проект.

  • Из перечня закрытых файлов

    Ранее закрытый проект можно открыть с помощью перечня закрытых файлов в меню Файл.

При открытии проекта обновляется вся рабочая площадь системы GROMA, т.е. открываются все окна, которые были открыты при предыдущем закрытии проекта.

В проекте вместе с перечнем файлов сохраняеся и часть установки системы GROMA, поэтому можно делать разные установки для разных заказов:

  • Параметры входа / выхода

    • Количество десятичных частей

    • Округление координат

    • Способ изображения номеров пунктов

    • Масштабный коэффициент

  • Редукция

  • Установленные потребительские входные / выходные форматы

  • Присоединенная кодирующая таблица

В проекте сохраняется и перечень, перед этим открытых файлов, которые доступны через меню Файл.

Пред. | Начало | След.
Сохранение проекта | Уровень выше | Глава 9. Кодирование пунктов


Глава 9. Кодирование пунктов
Пред. Часть I. Руководство для потребителя След.

Глава 9. Кодирование пунктов

Программа GROMA позволяет кодировать пункты в каталогах координат и в журналах измеренных величин. При измерении с приборами, которые позволяют записывать коды пунктов, можно обозначать пункты кодами в процессе измерения в поле, а потом использовать полученную информацию при обработке программой GROMA и другими, связанными с ней, программами.

Принцип кодирования

Код пункта может состоять из любого альфанумерического ряда, но не больше двадцати знаков. Двадцать знаков вполне хватает для однозначной идентификации пунктов и не способствует выразительному увеличению объема файлов координат. При всех выходах программа GROMA переводит коды на описания (напр. для автоматического размещения условных знаков) согласно присоединенной припоныкодирующей таблицы.

Пред. | Начало | След.
Открытие проекта | Уровень выше | Кодирующая таблица


Кодирующая таблица
Пред. Глава 9. Кодирование пунктов След.

Кодирующая таблица

Кодирующая таблица – это простой текстовый файл, в котором каждому коду отвечает описание. Структура кодирующего файла понятна из следующего примера:

1=Строение
2=Забор
3=Дерево
4=Столб
5=Фонарь
6=Мачта
7=Межевой столб
8=Вход
9=Ориентация
10=PBBP
11=Нивелирный знак
12=Стена вверху
13=Стена внизу
14=Шоссе

В этом кодирующем файле использованы только численные коды, но обычно коды могут состоять из любых альфанумерических знаков.

Кодирующая таблица может содержать также такие специальные позиции:

Таблица 9.1. Специальные позиции кодирующей таблицы

Позиция | Описание
@Title= | Название кодирующей таблицы
@Default= | Это описание изображено у всех позиций, код которых не был найден в кодирующей таблице. Если этот выбор не использован, то программа вместо описания изобразит исходный код.
@Empty= | Это описание изображено у всех позиций, которые не имеют никакой код.
@Separator= | Если пункты при измерении обозначены большим количеством кодов, то с помощью этой позиции можно установить, какими знаками должны быть на выписке отдельные описания отделены. Если этот выбор не использован, то программа отделит описания только одним пропуском. (Знак, которым отделены исходные коды, может отличаться, поэтому необходимо его установить в Файл->Установка->Кодирование: Отделитель кодов

Кодирующие таблицы сохранены в текстовых файлах с неявной припоной .cod. Можем создать любое количество кодирующих таблиц для разных целей. Программа GROMA использует таблицу, которая в этот момент пpисоединена. Если не присоединена никакая таблица, то программа вместо описаний использует исходные коды.

Пред. | Начало | След.
Глава 9. Кодирование пунктов | Уровень выше | Присоединение и отсоединение кодирующей таблицы


Присоединение и отсоединение кодирующей таблицы
Пред. Глава 9. Кодирование пунктов След.

Присоединение и отсоединение кодирующей таблицы

Если необходимо работать с конкретной кодирующей таблицей, то необходимо еесначала приссоединить. Кодирующая таблица присоединяется с помощью кнопки (Присоединить) в диалоговом окне Файл->Установка->Кодирование. После нажатия этой кнопки программа предложит для присоединения все кодирующие таблицы, найденные в актуальной папке. После выбора и присоединения таблицы мгновенно появляюся в открытых каталогах координат и измеренных величин соответствующие описания пунктов вместо вместо их кодов.

Если необходимо, чтобы программа опять начала показывать коды, то необходимо присоединенную таблицу отсоединить с помощью кнопки (Отсоединить).

Пред. | Начало | След.
Кодирующая таблица | Уровень выше | Эдитация кодирующей таблицы


Эдитация кодирующей таблицы
Пред. Глава 9. Кодирование пунктов След.

Эдитация кодирующей таблицы

Если необходимо эдитировать кодирующую таблицу, то можно ееоткрыть непосредственно в системе GROMA как текстовый файл. Наиболее удобно она открывается с помощью кнопки (Редактировать) в Файл->Установка->Кодирование. Изменения, проведенные в кодирующей таблице проявятся мгновенно после ее сохранения на диске (команда Файл->Сохрани). Кодирующая таблица – это обычный текстовый файл, поэтому его можно эдитировать и любым другим текстовым эдитором.

Пред. | Начало | След.
Присоединение и отсоединение кодирующей таблицы | Уровень выше | Многократные коды


Многократные коды
Пред. Глава 9. Кодирование пунктов След.

Многократные коды

Система позволяет использовать больше кодов для одного пункта. Коды должны быть отделены т.н. отделителем кодов (один знак – обычно пропуск или запятая). Этот отделитель устанавливается в Файл->Установка->Кодирование: Отделитель кодов. Потом они переводятся на описания всех частичных кодов у пунктов. Если некоторый из частичных кодов не найден в кодирующей таблице, то будет изображен без перевода на описание. На выписке отдельные описания отделены пропуском. Если необходимо отделить их другим знаком или последовательностью знаков, то приведите их в кодирующей таблице как позицию @Separator="xx", где xx последовательность отделяющих знаков.

В случае, если бы у пункта был код, например, "1 2", то при использовании вышеуказанной кодирующей таблицы было бы у пункта изображено описание "Строение Забор". В случае, если кодирующая таблица несодержит позицию "1=Строение", то изображается описание "1 Забор". В случае, если в таблице имеется на одну строку

@Separator=", "

то результирующий код бы выглядел такто: "1, Забор".

Пред. | Начало | След.
Эдитация кодирующей таблицы | Уровень выше | Ненайденные коды


Ненайденные коды
Пред. Глава 9. Кодирование пунктов След.

Ненайденные коды

В случае, если в каталоге координат появится код, который не приведен в кодируюшей таблице, то программа его не переведет, а изобразит так, как он был зарегистрирован. В случае, если нет необходимости изображать коды, которые небыли найдены в кодируюшей таблице, то можно в ней добавить строку

@Default=""

Этой строкой выбираете описание, которое должно быть приведено на месте кодов ненайденных в кодируюшей таблице. Если между кавычками не будет ничего написано, то ненайденный код будет пропущен. Если между кавычками напишете любой текст, то он ненайденный код заменит.

Пред. | Начало | След.
Многократные коды | Уровень выше | Обозначение пуктов согласно кодов


Обозначение пуктов согласно кодов
Пред. Глава 9. Кодирование пунктов След.

Обозначение пуктов согласно кодов

Позиции в каталогах координат и измеренных величин можно обозначить согласно их кодов. При обозначении необходимо помнить, что программа работает с кодами как с текстовыми даже в том случае, если для кодирования используются только цифры. Если выбрать, скажем, обозначение всех позиций от 5 до 59, то не будут обозначены, напр., позиции с кодом 8 (текст начинающийся знаком "8" больше, чем текст начинающийся знаком "5").

Пред. | Начало | След.
Ненайденные коды | Уровень выше | Задавание кодов с помощью описания


Задавание кодов с помощью описания
Пред. Глава 9. Кодирование пунктов След.

Задавание кодов с помощью описания

Если в некотором диалоговом окне задаете код пункта, то возле эдитационного окошка изображена для кода кнопка с тремя точками. После нажатия этой кнопки программа изобразит комплексный перечень описаний с присоединенной кодирующей таблицы, поэтому можно выбрать код с помощью описания.

Пред. | Начало | След.
Обозначение пуктов согласно кодов | Уровень выше | Перекодирование при импорте


Перекодирование при импорте
Пред. Глава 9. Кодирование пунктов След.

Перекодирование при импорте

При регистрации многознаковых описаний, программа GROMA позволяет переводить их на максимально двадцатизнаковые коды, с которыми внутренне работает. При всех записях (на экран, в текстовые файлы и т.п.) она автоматически переводит внутренние коды опять в примечания.

Коды, на которые должны быть переведены описания, определены с помощью кодирующей таблицы. Эту же кодирующую таблицу можно использовать и для обратного перевода кодов в описания, чем гарантируется сохранение исходных описаний. Иногда для выхода можно использовать иную таблицу.

Если необходимо при импорте перевести описания на коды, то необходимо присоединить соответствующую кодирующую таблицу, а в диалоговом окне Файл->Установка->Среда включить в данных о кодирующей таблице позицию Перекодировать при импорте. После этого программа переводит все описания на коды согласно присоединенной таблицы, а если какое-либо описание в таблице не найдет, то покажет сообщение об ошибке.

Пред. | Начало | След.
Задавание кодов с помощью описания | Уровень выше | Глава 10. Расчеты


Глава 10. Расчеты
Пред. Часть I. Руководство для потребителя След.

Глава 10. Расчеты

Все расчетные задачи решаются с помощью диалоговых окон, которые появляются после выбора соответствующей задачи в меню или на планке приспособлений.

Расчетное диалоговое окно

Диалоговые окна для расчетов немодальные, поэтому можно открыть их сразу несколько, a если необходимо работать с другими частями системы, то при этом можно оставить их открытыми. Между отдельными эдитационными окошками в диалоговом окне можно передвигаться с помощью клавиши <Tab>, <Shift-Tab>, <Стрелка вверх>, <Стрелка вниз> или <Enter>.

Расчетные окна состоят из нескольких областей, обычно ограниченных рамками. Они всегда содержат область для входных данных, область для результатов и область с кнопками. Окна сложнее могут содержать и больше областей (ориентация основ, каталог координат и т.п.), иногда закладки, под которыми скрыты дальнейшие части окон. Порядок работы почти при всех расчетах (имеются несколько исключений), похож, поэтому опишем подробно только расчет полярного метода, а у остальных - только отличия от стандартного порядка расчетов.

Подсказка

Если в окошке для номера пункта (в случае, если номер пункта заполнен) нажмем клавишу <+> или <->, то номер увеличится или уменьшится на единицу. Это действительно для всех окошек для задания номера пункта.

Пред. | Начало | След.
Перекодирование при импорте | Уровень выше | Ввод данных


Ввод данных
Пред. Глава 10. Расчеты След.

Ввод данных

Данные в диалоговых окнах можно вводить двумя способами:

  • прямым вводом клавиатурой,

  • перетягиванием из другого окна.

При прямом вводе данных, они заполняются во входные строчки диалогового с помощью клавиатуры.

Если уйдем с входной строчки с номером пункта (клавишей <Tab>, <Enter> или любым иным способом), то программа будет стремиться найти в каталоге (каталогах) координат пункт с заданным номером. В случае его нахождения она автоматически дополнит его координаты.

Перетягивание данных с каталогов

Данные с диалоговых окон можно перетягивать из открытых каталогов координат и измеренных величин. Они перетягиваются с помощью левой кнопки мыши. В каталоге выберем курсором соответствующую позицию (координаты пункта или измеренные данные), нажмем левую кнопку мыши и передвинем курсор на то место, которое необходимо заполнить.

При передвижении курсора обратите внимание, как изменяется его форма в зависимости от области, по которой в данный момент он передвигается. На площади каталога, откуда данные происходят, курсор имеет вид закрытой руки. При передвижении через площадь, которая не имеет ничего общего с перетягиваемыми данными и не может их акцептировать, курсор имеет форму знака "запрет". Если курсор находится над любой областью, которая может данные принять, то курсор имеет форму открытой руки. После освобождения левой кнопки мыши данные будут передвинуты в эту область (конкретное действие зависит от типа области).

Таким образом, можно перетягивать данные из каталога в расчетные окна, а результаты из расчетных окон опять в каталог или координаты из каталога в каталог.

Автоматическая ориентация основы горизонтальных направлений

Исключение составляет область расчетных окон для ориентации горизонтальных направлений. Перетянем-ли в эту область станцию из журнала измеренных величин (красная строка с номером пункта,приведена в журнале всегда в начале новой станции), то программа автоматически разыщет все измеренные направления соответствующей станции, а к ориентации прибавит все измерения, для которых разыскала в каталогах координаты цели. Из проедложенных ориентаций можно безусловно какую-либо выпустить с помощью кнопки (Отстранить).

Пред. | Начало | След.
Глава 10. Расчеты | Уровень выше | Сохранение результатов


Сохранение результатов
Пред. Глава 10. Расчеты След.

Сохранение результатов

Координаты вычисленных пунктов можно сохранять в каталогах координат перетягиванием мышью..

Порядок работы при перетягивании пунктов

  1. Дополните в расчетное диалоговое окно все недостающие данные (номер или неполный номер пункта и т.п.).

  2. Передвиньте курсор мыши на площадь диалогового окна, в область с результатами (на серую площадь заднего плана, а не на площадь входного окна или каталога координат).

  3. Нажмите левую кнопку мыши.

  4. Держа кнопку нажатой, передвигайте курсор по экрану. При передвижении можно наблюдать, как курсор изменяется в зависимости от того, в котором окне в данный момент находится.

  5. Если курсор размещен в нужном окне, то освободите левую кнопку мыши. Данные скопируются на соответствующее место.

Этим способом можно передвигать данные не только в каталоги координат, но и в иные расчетные окна, на контрольные чертежи и т.п.

Некоторые расчетные задачи автоматически сохраняют расчитанные пункты в активный каталог координат. Если мы не хотим их автоматически сохранять, установите активный каталог координат на [Zadny]. После этого вычисленные пункты можно вручную сохранять в каком-либо каталоге координат.

Пред. | Начало | След.
Ввод данных | Уровень выше | Контрольный чертеж


Контрольный чертеж
Пред. Глава 10. Расчеты След.

Контрольный чертеж

Пред началом расчетов можно с помощью команды Средства->Контрольный чертеж изобразить диалоговое окно, в котором, сразу после окончания какого-либо расчета, изобразится контрольный чертеж конфигурации данных и вычисленных величин. Входные пункты изображены черным цветом, а измеренные величины – красным. Окно для контрольного чертежа немодальное, поэтому может быть постоянно открытым. Его местонахождение и размеры можно произвольно изменять. Отдельные пункты в нем можно изобразить также перетягиванием мышью с каталогов координат или расчетных окон. Контрольный чертеж подробно описан в той части руковоства, которая посвящена расширяющимся модулям.

Пред. | Начало | След.
Сохранение результатов | Уровень выше | Допуск


Допуск
Пред. Глава 10. Расчеты След.

Допуск

При некоторых расчетах программа GROMA имеет возможность предрасчитать точность результатов, напр. согласно геометрических параметров (конфигурации), после исправления (при расчетах избыточных измерений) и т.п.

Контролировать параметры для каждого расчета бы было очень трудоемко и долго. Поэтому программа GROMA позволяет автоматически сравнивать некоторые параметры с предварительно установленными допусками. При превышении установленного допуска программа изобразит предупреждающее объявление и позволит потребителю продолжать или окончить расчеты.

Потребитель имеет возможность определить отдельные наборы допусков. Согласно требуемой точности он только выберет соответствующий набор, с которым программа от этого момента работает.

Допуск устанавливается в диалоговом окне Файл->Установка->Допуск. В этом окне можно также выбрать активный набор допусков.

Тестирование допусками можно отменить, выбрав набор [Нетестировать].

Пред. | Начало | След.
Контрольный чертеж | Уровень выше | Тестирование согласно предписаний для работы в кадастре недвижимостей


Тестирование согласно предписаний для работы в кадастре недвижимостей
Пред. Глава 10. Расчеты След.

Тестирование согласно предписаний для работы в кадастре недвижимостей

Кроме тестирования потребителем определенных допусков можно еще использовать тестирование отклонений и параметров согласно предписаний для работы в кадастре недвижимостей. Это тестирование включается в диалоговом окне для определения допусков. После включения этого тестирования, система GROMA сравнит в некоторых расчетах достигнутые отклонения с предельными отклонениями, а действительные геометрические параметры рисунков с лимитированными разрешенными параметрами. Если данный расчет отвечает требованиям предписаний для работы в кадастре недвижимостей, то в ведомость добавляется вывод, что допуски соблюдены. Если данный расчет не отвечает требованиям предписаний, то появится диалоговое окно с превышением параметра, а в ведомость добавляется результат тестирования.

Тестируются эти параметры:

Таблица 10.1. Тесты при расчетах

Расчетная задача | Тип теста
Полигонометрические хода | угловая невязка, polohova odchylka, предельная длина хода, предельная длина линии, предельное соотношение длин соседних линий, предельное число пунктов
Засечка, пересечение прямых | минимальный угол пересечения, максимальное расстояние от данного до определяемого пункта
Свободная станция | минимальный угол пересечения
Полярный метод | предельное отклонение в ориентации
Ортогональный метод | предельная линейная невязка измеренной прямой
Контролные промеры | предельное расхождение между длиной, измеренной непостредственно, и длиной, вычисленной по координатам

Пред. | Начало | След.
Допуск | Уровень выше | Трансформация координат


Трансформация координат
Пред. Глава 10. Расчеты След.

Трансформация координат

Программа GROMA имеет одну встроенную универсальную трансформацию координат, используемую теми расчетными задачами, которым она нужна.

Идентические пункты

В зависимости от типа трансформации необходимо иметь минимально два или три т.н. идентических пункта. Однако термин "Идентические пункты" не совсем пригоден и сущность пунктов не раскрывает (при трансформации эти пункты в обеих системах обычно не тождествены). Не смотря на это, в практической деятельности он используется, поэтому, чтобы было понятно, он используется и здесь.

Идентические пункты – это пункты, координаты которых известны в обеих системах и поэтому могут быть использованы для расчета ключа трансформации. Используемая трансформация линейная, поэтому в общем случае отождествит обе системы только на одном пункте, в центре тяжести идентических пунктов. Для всех остальных пунктов, по которым был определен ключ трансформации, действует правило, что их координаты, трансформированные из одной системы в другую, в общем не равны координатам в другой системе (только выполняют условие минимальной суммы квадратов поправок), т.е. в действительности не "идентичны".

Ключ трансформации

Ключ трансформации можно вместе с перечнем идентических пунктов сохранить в файле, а позже опять начесть в программу. Большинство расчетных функций, которые используют трансформацию, позволяют изобразить конечные параметры трансформации.

К параметрам трансформации относятся:

  • Ключ трансформации:

    • сдвиг в направлении оси Х,

    • сдвиг в направлении оси У,

    • ротация системы,

    • один или два масштабных коэффициента,

  • Идентический пункт:

    Координаты пункта, на котором обе системы отождествены (т.е. центр тяжести пунктов, по которым был определен ключ трансформации).

Параметры трансформации определены на основе метода наименьших квадратов с условием минимализации суммы квадратов ошибок координат на идентичных пунктах.

Большинство задач, где использована трансформация координат, содержит кнопку (Ключ), после нажатия которого появится окошко с параметрами трансформации. Это окошко содержит кнопки (Сохранить ключ) и (Начесть ключ), которые служат для записи определенного ключа трансформации в файл и для его повторного начитывания. Файлы с ключом трансформации между собой компатибильны, поэтому можно напр. при трансформации координат начесть и использовать ключ, который определен в ортогональном методе (и наоборот).

Трансформация идентичности

Трансформация идентичности – это линейная трансформация координат, которая сохраняет размер (масштабный коэффициент равен единице). В этом случае трансформация имеет три параметра (две трансляции и ротацию), а для определения ключа трансформации необходимо хотя бы два идентичных пункта.

Подробная трансформация

Подробная трансформация - это линейная трансформация координат, которая использует один масштабный коэффициент для направлений осей X и Y. В этом случае трансформация имеет четыре параметра (две трансляции, ротацию и масштабный коэффициент), а для определения ключа трансформации необходимо хотя бы два идентичных пункта.

Афинная трансформация - 5 степеней свободы

Афинная трансформация имеет, в отличие подробной трансформации, два разные масштабные коэффициенты для направлений осей X и Y. Количество параметров трансформации пять (две трансляции, ротация и два масштабные коэффициенты), в этом случае количество идентичных пунктов вырастет на три.

Афинная трансформация - 6 степеней свободы

У этого типа трансформации не определяются геометрические параметры трансформации. Параметров трансформации шесть (две трансляции и четыре элементы матрицы трансформации). В этом случае элементы матрицы уже не взаимосвязаны геометриметрическими связями, поэтому по ним нельзя определить геометрические параметры трансформации. Минимальное количество идентичных пунктов для этого типа трансформации – три.

Потребительская трансформация

При этой трансформации, нет необходимости задавать идентичные пункты, но можно непосредственно задать уравнение трансформации для расчета координат пунктов.

Пред. | Начало | След.
Тестирование согласно предписаний для работы в кадастре недвижимостей | Уровень выше | Ориентация горизонтальных направлений


Ориентация горизонтальных направлений
Пред. Глава 10. Расчеты След.

Ориентация горизонтальных направлений

В некоторых задачах (напр. полярный метод, угловая засечка, свободная станция, полигонометрический ход) необходимо выполнить ориентацию горизонтальных направлений, т.е. выбрать исходное горизонтальное направление. Последовательность ориентации направлений всегда похожа, несмотря на тип решаемой задачи.

При ориентации горизонтальных направлений можно поступать двумя способами. В первом случае можно отдельные ориентации заполнить самостоятельно, во-втором – можно оставить программу автоматически сориентировать горизонтальные направления.

Ручная ориентация горизонтальных направлений

Сначала в область для задания станции задайте с помощью номера пункта или перетягиванием мышью координаты станции (этот пункт не касается свободной станцией, так как в этой задаче координаты станции будут определяться).

В область для ориентации горизонтальных направлений заполните необходимые данные соответствующего направления (измеренная длина не объязательна и используется только для контроля) и нажмите кнопку (Добавить). Oриентация будет придана в каталог, программа пересчитает все ориентации направлений и, если в каталоге больше ориентаций, чем одна, то программа изобразит поправки во все отдельные направления. Таким образом заполните все ориентации, которые предполагаете использовать.

Автоматическая ориентация горизонтальных направлений

Если необходимо, чтобы программа автоматически сориетировала основы, перетяните мышью в область для ориентации только номер станции (красное данное в журнале измеренных величин). Из всех направлений, которые были на станции измерены, программа выберет те, у которых известны координаты цели и автоматически придаст их в перечень ориентаций. В этом случае, перед автоматической ориентацией направлений, необходимо иметь открытым каталог координат, который содержит координаты станции и пунктов ориентации. Более того, должен быть установлен такой способ поиска пунктов, чтобы программа могла найти в каталогах соответствующие пункты (координаты должны в активном каталоге координат или должно быть разрешено искать пункты во всех открытых каталогах координат).

Таким образом, созданный перечень ориентаций можно в дальнейшем как угодно эдитировать (Добавлять, убирать или исправлять позиции). Данные добавляются с помощью кнопки (Добавить), a убираются кнопкой (Отстранить).

Если необходимо какое-либо направление исключить из ориентации, но при этом не желаете его полностью исключить (для случая его возможного использования в будущем), то можно его отключить с помощью зачеркиваемого окошка перед номером пункта. Таким образом отключенное направление в каталоге останется для дальнейшего использования, причем у него изображаюся поправки, но для собственно ориентации направлений он не используется (не изображен он также в ведомости).

Если необходимо исправить какую-либо позицию, обозначьте ее в перечне ориентаций, чтобы величины изобразились в эдитационных окнах, после этого эти величины исправте, исправленную позицию добавте, а исходную позицию отстраните.

Веса ориентаций

При ориентации направлений необходимо в расчет ввести веса отдельных направлений. Веса устанавливаются в конфигурации программы (Файл->Установка->Расчеты). Можно выбрать из трех стандартных установок:

  • 1

    Веса всех измеренных направлений равны 1. Такой способ расчета был использован в предыдущих версиях системы GROMA.

  • 1/s

    Для отдельных направлений использованы веса, которые определены из соотношения

    p = 1/s

    где s – длина на ориентирный пункт.

  • s/1000

    Для отдельных направлений использованы веса, определенные из соотношения

    p = s/1000

    где s – длина на ориентирный пункт.

  • Потребительская установка

    Кроме этих трех предопределенных возможностей можно во входную строку для задания весов записать любое функциональное соотношение, содержащее параметр s.

Замечание

При выборе предопределенных весов обратите внимание, как во входном окошке изменяется функциональное соотношение для расчета весов.

Численные величины весов отдельных направлений найдем в ведомости ориентации направлений.

Пред. | Начало | След.
Трансформация координат | Уровень выше | Глава 11. Расчетные задачи


Глава 11. Расчетные задачи
Пред. Часть I. Руководство для потребителя След.

Глава 11. Расчетные задачи

Полярный метод

Диалог Полярный метод служит для ручного вычисления координат пунктов, измеренных полярным методом.

Перед расчетом измеренных пунктов необходимо задать координаты станции и сориентировать горизонтальные направления.

Координаты станции

Координаты станции можно заполнить вручную (напр. заполнить только номер пункта, а координаты оставить дополнить автоматически), или перетянуть с каталога координат.

Ориентация направлений

Порядок действий при ориентации направлений приведен в предыдущей главе.

Пикеты

Если выбрано исходное горизонтальное направление, то можно с помощью закладки Определяемый пункт переключиться во вторую часть диалогового окна и начать вычислять измеренные пункты. Заполнять данные в диалоговые окна можно вручную или перетянуть из журнале измерений. Если выбран активный каталог координат, то расчитанные пункты в нем автоматически сохраняются. Если не желаете сохранять, то можно перед расчетом отменить активный каталог (команда Файл->Актуальный каталог координат, позиция [Никакой]). Если активный каталог не выбран (или желаете сохранить пункт в ином каталоге, напр. использовать в ином расчетном окне как исходные данные), то можно его перетянуть с помощью мыши так же, как перетягиваются пункты из каталогов координат.

Если необходимо расчитать координаты большего числа пунктов сразу, то эти пункты следует обозначить в журнале измерений и сразу перетянуть весь обозначенный блок.

Замечание

При этом способе расчета обозначенный блок не может задевать другую станцию, потому-что эта задача не умеет автоматически выполнить новую ориентацию основ. В случае, кода необходимо вычислить больше станций сразу, используйте Полярный метод групповой.

Перетягиваете-ли данные мышью, координаты будут вычислены сразу после перетягивания. Задаете-ли данные с помощью клавиатуры, необходимо нажать кнопку (Расчет) (можно нажать откуда-либо клавишей <Alt-V>).

Пред. | Начало | След.
Ориентация горизонтальных направлений | Уровень выше | Ортогональный метод


Ортогональный метод
Пред. Глава 11. Расчетные задачи След.

Ортогональный метод

Перед расчетом пиветов, измеренных ортогональным методом, необходимо сначала определить ключ трансформации в такой же последовательности, как и при ориентации горизонтальных направлений в полярном методе. Во входные строчки в части Идентичные пункты необходимо задать для каждого пункта, который будете использовать для определения ключа трансформации, координаты в главной системе координат и в местной системе координат (перпендикуляр) и с помощью кнопки (Добавить) добавить его в перечень идентичных пунктов.

Если в каталоге имеются хотя-бы два идентичных пункта, то программа автоматически вычислит ключ трансформации и поправки в координаты для всех пунктов. В то же время изобразит поправку длины между первыми двумя идентичными пунктами (невязка длины, которая определена по координатам, и длины, которая определена по перпендикулярам и пикетажу. Максимальное количество идентичных пунктов не ограничено.

Ключ трансформации можно сконтролировать после нажатия кнопки (Ключ). Из диалогового окна, которое программа изобразит (применительно для всех типов трансформации), Вас будет верояно занимать только часть Масштабные коэффициенты (в этом случае используется подробностная трансформация и оба масштабные коэффициенты будут совпадать). Это окно содержит кнопки (Начесть ключ) и (Сохранить ключ), с помощью которых можно заданный ключ трансформации сохранить в файле для дальнейшего использования или из файла начесть ранее определенный ключ.

В расчетном диалоговом окне автоматически изображается исправление длины измеренной длины. Если задано больше чем два идентических пункта или, если разговор идет о свободной, то за поправку измеряемой прямой считается невязка расстояний между первыми двумя идентичными пунктами.

После определения ключа трансформации можно обычным способом вычислить отдельные пункты. Если выбран некоторый каталог координат, как активный, программа в нем автоматически сохраняет вычисленные пункты. Если не желаете их сохранять, необходимо перед расчетом отменить активный каталог (команда Файл->Актуальный каталог координат, позиция [Никакой]). Если активный каталог координат не установлен (или пункт необходимо сохранить в ином каталоге, напр. использовать в ином расчетном окне, чем вводимое данное), можно его перетянуть с помощью мыши так же, как перетягиваются пункты из каталога координат.

Кнопкой (Новая прямая) отстраните содержание всего диалогового окна и можно вычислять другие прямые.

Подсказка

Вычисляете-ли большее количество пунктов и можете-ли их перпендикуляры и пикетаж каким-либо способом импортировать в каталог координат, можно для расчета использовать трансформацию координат.

Пред. | Начало | След.
Глава 11. Расчетные задачи | Уровень выше | Полярный метод групповой


Полярный метод групповой
Пред. Глава 11. Расчетные задачи След.

Полярный метод групповой

Полярный метод групповой

Эта задача решает в целом журнале измеренных величин или его часть. Может вычислить координаты пунктов полярным методом, методом свободной станции и угловой засечкой. Если желаете при групповом вычислении использовать только некоторые из этих методов, то в конфигурации программы (Файл->Установка->Расчеты) отдельные методы можно отключить. Это может быть целесообразно напр. в том случае, когда в журнале измерений появится сначала измерение с еще не определенной станции и только потом измерение на этой станции полярным методом. Если включены все расчетные задачи, то программа попытается определить координаты незнакомой станции как свободной станции. Если задачу „Свободная станция“ для массовых расчетов выключить, то уже при первом решении программа эту станцию пропустит (так как не будут еще определены ее координаты), но позже определит ее полярным методом, а при следующем решении довычислит пункты на ней измеренные.

В случае, если некоторые пункты нельзя вычислить (напр., если невозможно определить координаты станции и т.п.), то в ведомости будет приведена информация о том, почему программа не могла расчет выполнить.

Подготовка расчета

Перед началом расчета необходимо выполнить некоторые подготовительные установки:

  • Откройте файл с журналом измерений.

  • Откройте каталог координат, в котором находятся пункты, необходимые для расчета (пункты сети и т.п.).

  • Обеспечьте, чтобы программа GROMA при расчете могла найти координаты из этого файла. Этого можно достичь двумя способами:

    • В диалоговом окне Файл->Установка->Среда включите выбор Искать во всех открытых файлах, или

    • установите этот каталог координат как активный (Файл->Актуальный каталог координат).

  • В диалоговом окне Файл->Установка->Расчеты выберите способ поиска ориентации (все пункты с известными координатами или только с атрибутом Ориентация. В этом диалоговом окне или прямо в расчетном окне для полярного метода группового выберите с помощью позиции Эдитировать ориентации, если хотите, чтобы программа перед расчетом каждой станции изображала перечень ориентаций и позволяла Вам его эдитацию.

  • Выберите входной и выходной файлы для расчета (см. ниже).

Файлы

В этой части диалогового окна необходимо выбрать, из которого открытого файла должны быть начтены измеренные данные и в которым файле должны сохраняться вычисленные координаты. Имена файлов установите следующим образом:

  • Укажите куда-либо в окне с файлом, который хотите выбрать.

  • Перетяните любую позицию мышью (при нажатой левой кнопке) в область расчетного окна с надписью Файлы. В диалоговом окне появится название файла.

файлы можно выбрать также с помощью кнопок с тремя точками, которая находится возле окон для названий файлов.

Если не установлено название входного файла, то программа автоматически использует активный каталог координат. Входной файл должен быть установлен всегда.

Мгновенное состояние расчета

После включения кнопкой (Расчет) программа изобразит в диалоговом окне настоящее состояние расчета:

  • Станция: как раз вычисляемая станция,

  • Пункт: как раз определяемый пункт,

  • Метод: метод, которым пункт определяется (полярный, свободная станция, обратная засечка), или другая акция, которая как раз выполняется (ориентация горизонтальных направлений).

Общее состояние расчета

В этой части окна программа подает информацию о том, сколько станций и пикетов уже было вычислено, и сколько неиспользованых позиций в журнале измеренных величин еще остается. После окончания расчета здесь же получите информацию о том, сколько измеренных величин по каким-либо причинам не могло быть использовано.

При групповом вычислении программа вычисляет полярный метод, свободную станцию (и обратную засечку) и угловую засечку. Все эти задачи, в т.ч. с высотой, программа вычисляет только в том случае, если имеет для этого все необходимые данные (высота станции, высота прибора, превышение или зенитное расстояние и высота цели). При расчете угловой засечки по направлениям вычислит дважды высоту (по обеим станциям), запишет в каталог координат среднее значение, а в ведомость вычислений - обе величины, их разность и среднее.

Вычисление групповое позволяет обрабатывать журнале измерений несколькими приближениями. Этот способ обработки позволяет вести расчет и в том случае, если данные в файле сгруппированы не в такой последовательности, чтобы можно было вести их обработку одним приближением. Эта ситуация возникает напр.,если пункты измерены на станции, которая еще не определена. Если станцию определить дополнительно со следующей станции полярным методом, то в этом случае программа при первом приближении неопределенную станцию не включит в расчет, со следующего пункта определит ее координаты, а при очередном приближении ее досчитает. Максимальное количество приближений 5, однако, программа сама окончит расчет в случае, если при последнем приближении ни один пункт не вычислен.

После вычисления имеется ведомость со всеми данными о расчете. Если нет необходимости сохранять в ведомости все вычисленные пикеты, то можно их сохранение отключить в Файл->Установка->Расчеты.

Пред. | Начало | След.
Ортогональный метод | Уровень выше | Свободная станция


Свободная станция
Пред. Глава 11. Расчетные задачи След.

Свободная станция

Эта задача служит для расчета координат станции, на которой были измерены направления или направления и длины на известные пункты. Если измерены только направления, то координаты станции вычисляются обратной засечкой с уравниванием по методу наименьших квадратов, если измерены и длины, то программа вычислит координаты с помощью трансформации Гельмерта. В этом случае можно после нажатия кнопки (Ключ) просмотреть результирующий ключ трансформации.

После расчета программа покажет в перечне направлений поправки направлений, иногда также расстояния на ориентирные направления.

Важно

Если на некоторые пункты измерены направления и длины, а на некоторые только направления, то отсутствущие длины программа расчитает по измеренным величинам и использует их для расчета свободной станции. В случае, если не желаете, чтобы программа довычислила отсутствущие длины, то можно это свойство отключить в Файл->Установка->Расчеты.

С математической точки зрения самым корректным способом расчета такой свободной станции является способ уравнивания неравноценных измерений на основе средних квадратических ошибок направлений и длин. Эту возможность предоставляет демонстрационная версия модуля для уравнивания плановых сетей, которая обычно поставляется с системой GROMA. Эта демонстрационная версия позволяет производить строгое уравнивание свободной станции с любым количеством ориентаций. Чтобы расчет был выполнен, все ориентации должны иметь предварительно установленные характеристики Опорный пункт a определяемый пункт - характеристику Свободный (демонстрационная версия позволяет определять только две неизвестные).

Диалоговое окно позволяет вычислять свободную станцию, где измеряется направление и длина на один ориентирный пункт, а на другой только направление. Однако, при определенной конфигурации этих пунктов может дойти к неоднозначности расчета, т.е. у конфигурации будут два решения. После этого программа выберет одно из возможных решений. Верное решение можно выбрать и на основе контрольного чертежа.

Пред. | Начало | След.
Полярный метод групповой | Уровень выше | Линейная засечка


Линейная засечка
Пред. Глава 11. Расчетные задачи След.

Линейная засечка

В этом диалоговом окне можно расчитать координаты пунктов с помощью линейной засечки. Введение исходных данных похоже как и у других задач.

Расчет координат с помощью линейной засечки неоднозначен (имеет два решения, симметричные к базису). При введении данных неодходимо соблюдать конвенцию, данную описанием диалогового окна (левая станция – правая станция при взгляде по направлению к определяемому пункту). Положение расчитанного пункта можно проконтролировать с помощью контрольного чертежа.

Если заданные данные не отвечают допускам для линий треугольников, то программа известит об ошибке объявлением Нерешаемая конфигурация.

Если в выбранных допусках предусмотрен минимальный угол пересечения при засечке, то программа сравнит его с действительным углом, а в случае необходимости известит о его несоответствии допуску.

Пред. | Начало | След.
Свободная станция | Уровень выше | Угловая засечка (по направлениям)


Угловая засечка (по направлениям)
Пред. Глава 11. Расчетные задачи След.

Угловая засечка (по направлениям)

Угловая засечка (по направлениям)

Задача служит для расчета координат с помощью угловой засечки (по направлениям).

Перед расчетом необходимо сориентировать на обеих станциях горизонтальные направления способом, который подробно описан выше (см. полярный метод). В диалоговом окне всегда показаны данные только для одной станции. Перейти к другой можно кнопкой (Станция A/B). Если оба направления сориентированы, то можно вычислять отдельные определяемые пункты перетягиванием измеренных направлений из журнала измерений и нажатием кнопки (Расчет).

Если в выбранных допусках установлен минимальный угол пересечения при засечке, то программа сравнит его с действительным углом и, в случае необходимости известит о его несоответствии допуску.

Пред. | Начало | След.
Линейная засечка | Уровень выше | Многократная угловая засечка (по ориентированным направлениям)


Многократная угловая засечка (по ориентированным направлениям)
Пред. Глава 11. Расчетные задачи След.

Многократная угловая засечка (по ориентированным направлениям)

Многократная угловая засечка (по ориентированным направлениям)

Задача служит для вычисления координат многократной угловой засечкой (по ориентированным направлениям) дозой.

Последовательность вычислений похож, как и у задачи Угловая засечка (по ориентированным направлениям). Отличие только в том, что в этой задаче вместе с пунктами ориентации можно задавать и измеренные пункты (в этом случае нет необходимости у всех задаваемых направлений заполнять координаты пунктов ориентации). Задаются снова ориентации отдельно для пункта А и для B. Переходить от одной станции к другой можно с помощью кнопки (Станция A/B).

В этой задаче можно опять с выгодой использовать автоматическое задание направлений при ориентации горизонтальных направлений. Если из расчетного окна перетянем мышью из журнала измерений станцию (строку с красным номером станции) в область для ориентации горизонтальных направлений), то программа автоматически начтет в ведомость все измеренные направления. В случае, если она разыщет в каталогах соответствующие им координаты ориентирных пунктов, то будет их считать ориентирными направлениями, координаты которых не разысканы, а пункты будет считать определяемыми.

В перечне ориентаций можно просто отличить ориентации от определяемых пунктов по тому, что возле ориентации изображено стандартное зачеркиваемое окошко для их включения и выключения. Если ориентация направлений вычислена, то у ориентаций изображены также угловые невязки.

Зададите-ли этим способом ориентацию и определяемые пункты для обеих станций, можно с помощью кнопки (Расчет) включить расчет координат определяемых пунктов. Программа постепенно пройдет оба перечня определяемых пунктов в поиске одинакового номера. Если такая пара не будет разыскана, то вычислит координаты пункта прямой засечкой по сориентированным направлениям. Если заданы и зенитные расстояния или превышения, то программа автоматически определит также высоту пункта. В случае, если зенитные расстояния или превышения измерены на обеих станциях, то высота будет определена дважды. В этом случае в ведомости вычислений будут записаны обе высоты, их разность и средняя высота.

Определяемые пункты могут быть в обеих перечнях записаны в любой последовательности, поэтому единым условием для расчета является то, чтобы соответствовали номера пунктов, измеренные с обеих станций. Если на одной станции заданы пункты, которые на другой станци не заданы, то программа их при расчете будет игнорировать.

Полученные координаты перетяните мышью в каталог координат тем же способом, как и других задач. При перетягивании укажите мышью на результирующую часть окна (но ни в коем случае не на площадь собственно каталога координат пунктов).

Перед расчетом необходимо сориентировать на обеих станциях горизонтальные направления способом, который подробно описан выше (см. полярный метод). В диалоговом окне всегда показаны данные только для одной станции. Перейти к другой можно кнопкой (Станция A/B). Если оба направления сориентированы, то можно вычислять отдельные определяемые пункты перетягиванием измеренных направлений из журнала измерений и нажатием кнопки (Расчет).

Если в выбранных допусках установлен минимальный угол пересечения при засечке, то программа сравнит его с действительным углом и, в случае необходимости известит о его несоответствии допуску.

Пред. | Начало | След.
Угловая засечка (по направлениям) | Уровень выше | Пересечение прямых


Пересечение прямых
Пред. Глава 11. Расчетные задачи След.

Пересечение прямых

После задания четырех пунктов программа расчитает координаты точки пересечения и запишет информацию о ее плановом положении (в случае, если лежит на одном из пересекающихся отрезков или на обоих).

Если в выбранных допусках установлен минимальный угол пересечения при засечке, то программа сравнит его с действительным углом и, в случае необходимости известит о его несоответствии допуску.

Пред. | Начало | След.
Многократная угловая засечка (по ориентированным направлениям) | Уровень выше | Пересечение прямой и окружности


Пересечение прямой и окружности
Пред. Глава 11. Расчетные задачи След.

Пересечение прямой и окружности

Пересечение прямой и окружности

Эта задача служит для вычисления координат точки пересечения прямой и окружности. Прямая задается двумя конечными пунктами, окружность – тремя пунктами.

Окружность задаете тремя пунктами (клавиатурой или перетягиванием мышью) v рамку диалогового окна Окружность. После задания каждого пункта нажмите кнопку для следующего пункта.

После этого задайте оба конечные пункты прямой в область Прямая.

Зададите-ли номер вычисленного пункта и нажмете-ли кнопку (Расчет), программа вычислит кординаты точки пересечения. В зависимости от конфигурации могут существовать две точки пересечения, одна или ни одна (имеется ввиду прямая, но ни в коем случае не отрезок). На контрольном чертеже изобразятся расчитанные точки пересечения. Активный, т.е. тот, который в расчетном окне выбран, на контрольном чертеже изображен красным цветом. Второе решение, если оно существует, изображено зеленым цветом.

Полученные координаты можно перетянуть с помощью мыши в каталог координат.

Пред. | Начало | След.
Пересечение прямых | Уровень выше | Полигонометрический ход


Полигонометрический ход
Пред. Глава 11. Расчетные задачи След.

Полигонометрический ход

Диалоговое окно Полигонометрический ход позволяет выполнить расчет полигонометрического хода любого вида, а также его сохранение на диске или начтение с диска.

Диалоговое окно состоит из пяти частей, выбираемых с помощью закладок.

Начальный и конечный пункты

Эта часть содержит координаты пунктов привязки и измеренные горизонтальные направления на них. Задавание происходит так же, как и у остальных расчетных задач.

Если на начальном и конечном пунктах производились измерения, задайте всю ориентацию горизонтальных направлений (подробно описана в полярном методе). Если на пункте не производились измерения (вставленный ход без ориентации, односторонне ориентированный ход), задайте только его координаты. Идентично поступаем и с конечным пунктом.

Согласно заданных данных для привязки записывается также для контроля тип хода.

Измеренные данные

После задания ориентации постепенно задавайте измеренные величины. Добавляете или удаляете их из журналов с помощью кнопок (Добавить) и (Отстранить).

Важно

Чтобы задавание данных было однообразным, у всех типов ходов заносятся в журнал измеренных величин начальный и конечный пункты хода, даже в том случае, если на них не производились измерения (напр. у вставленного полигонометричского хода без ориентации).

У пунктов, на которых производились измерения, задаются измеренные направления и длина вперед и номер станции. Если длины измерены в прямом и обратном направлениях, программа расчитает средние значения, а в ведомость вычислений внесет линейнюю невязку. Если длины измерены только в одном направлении, то не имеет значения как зададите длину, или с одного пункта вперед, или со следующего пункта назад.

На начальном пункте, если на нем измерялось, задаете только направление вперед. Ориентацию горизонтальных направлений (т.е. дирекционный угол начального направления) программа определит с помощью самостоятельной ориентации горизонтальных направлений на начальном пункте (см. выше).

Аналогично задаете на конечном пункте, если на нем измерялось только назад.

Результаты

В этой части окна после расчета хода находятся результирующие величины. Здесь находятся каталог координат результирующих пунктов и информация о достигнутых отклонениях. Эта часть окна содержит и выбор типа уравнивания, а также кнопку для включения расчета высот.

Программа позволяет уравнивать двумя способами:

  • Классический

  • Транформация

Замкнутый ход

Программа позволяет выполнить расчет замкнутого хода, и в том случае, когда этот тип хода для уравнивания не подходит. Замкнутый ход задается также, как и ход вставленый, на обеих концах сориентированный. Начальный и конечный пункты идентичны, ориентацию горизонтальных направлений необходимо задать на начальном и конечном пункте. Если замкнутый ход задан верно, то программа это констатирует изображением типа хода Замкнутый. Этот тип хода нельзя уравнять трансформацией, так как конечные пункты идентичны.

Если вычисленные координаты нас удовлетворяют, то их можно перетянуть в любое окно с каталогом координат. Таким же методом полигонометрический ход перетягиваем в окно с проектом К проекту можно добавить только ход, который уже имеет название файла, т.е. ход сохраненный как файл или начтенный из файла.

Важно

При перетягивании необходимо указать куда-либо в части Результаты, но мимо площади каталога координат.

Входы / Выходы

Эта часть окна содержит входную строку для названия хода и кнопки для начтения и сохранения хода.

Начтение хода из файла измерений

Кроме ручного задавания, программа также предлагает возможность начтения измеренных данных для полигонометрического хода из журнала измерений. Если целесообразно использовать эту возможность, то поступайте следующим образом:

  1. Откройте журнал измерений, в которой имеются результаты измерений полигонометрического хода. В случае, если измерения сохранены в большем количестве файлов, то соедините их командой Измерения->Добавь файл или копированием через ячейку. Откройте каталог (каталоги) координат с конечными пунктами.

  2. Активизируйте журнал измерений (напр. указав мышью на любую позицию).

  3. В диалоговом окне для расчета полигонометрического хода нажмите кнопку (Начесть ход из журнала ).

  4. Появится диалоговое окно с перечнем всех станций из журнала измерений.

    Если на начальном пункте измерялось (свободный ход, сориентирован на начальном или на начальном и конечном пунктах), то он будет приведен в этом каталоге. Обозначьте его мышью и нажмите кнопку (Добавить).

    Если на начальном пункте не измерялось (вставленный ход), запишите его номер в эдитационное окно для номера пункта и нажмите кнопку (Добавить).

    Если на некоторой из станций измерялось несколько раз, то в каталоге его номер приведен также несколько раз. Отдельные установки прибора иденфицируются с помощью порядкового номера, приведенного в конце номера пункта за точкой (напр. 5001.1, 5001.2 и т.п.).

  5. Программа добавит пункт в каталог пунктов и предложит Вам перечень других установок прибора, через которые ход может пройти. Как другие установки программа предложит все установки, измеренные с предыдущего пункта хода, и с которых этот пункт измерен как ориентирный.

    Если таким условиям подходит только один пункт, то программа его автоматически добавит в каталог пунктов хода. Если таким условиям подходит больше пунктов, то программа предложит их список к выбору.

  6. В такой последовательности задайте весь полигонометрический ход. Если на конечном пункте хода не измерялось (ход односторонне ориентированный или без ориентации), то задайте номер конечного пункта в эдитационном окне и добавте его в каталог кнопкой (Добавить).

  7. Если задан весь полигонометрический ход, нажмите кнопку (OK). Программа дополнит все данные из журнала измерений и каталога координат в диалоговое окно для вычисления полигонометрического хода. Перед расчетом убедитесь, что все введенные данные верны.

Если заданы все входные величины, можно запустить расчет с помощью кнопки (Рачет). Программа расчитает координаты пунктов полигонометрического, запишет их в каталог Результаты, и сообщит Вам о достигнутых отклонениях. Если уравнивание хода было выполнено с помощью трансформации, то его параметры можно просмотреть нажав кнопку (Ключ).

Сохранение и начтение хода

Заданный полигонометрический ход можно сохранить как файл, нажав кнопку (Сохранить ход как файл). Ранее сохраненный ход можно начесть из файла после нажатия кнопки (Начесть ход из файла).

Пред. | Начало | След.
Пересечение прямой и окружности | Уровень выше | Высотный ход


Высотный ход
Пред. Глава 11. Расчетные задачи След.

Высотный ход

Диалоговое окно служит для расчета высотного хода. Вид окна и задавание аналогичные как и у полигонометрического хода, однако задаюся только данные необходимые для расчета высотного хода. Расчет планового положения не выполняется.

Пред. | Начало | След.
Полигонометрический ход | Уровень выше | Трансформация координат


Трансформация координат
Пред. Глава 11. Расчетные задачи След.

Трансформация координат

Это окно позволяет трансформировать координаты пунктов из каталога координат. Можно трансформировать весь каталог или только обозначенные пункты. Методы трансформации описаны в главе Трансформация координат

Идентические пункты

Перед началом трансформации координат необходимо сначало определить ключ трансформации. Тем же способом, что и у других задач, добавим в каталог все идентические пункты с координатами в обеих системах. Программа автоматически перевычисляет ключ трансформации и показывает поправки координат отдельных пунктов. Идентические пункты можно добавлять в каталог или удалять из каталога произвольно.

Количество идентических пунктов не ограничено.

Замечание

Ключ трансформации вычисляется методом наименьших квадратов повторениями. Если между координатами в обеих системах слишком большое различие, то может возникнуть ситуация, когда процесс приближения не будет конвергировать к конечной уравненной величине. В этом случае будет изображено предупреждающее объявление. Это относится и ко всем остальным задачам, которые решены с помощью трансформации координат.

Автоматическое начтение идентических пунктов

Если имеются идентические пункты в двух файлах и если пара пунктов имеет одинаковые номера, то можно дать возможность программе автоматически отыскать соответствующую пару пунктов. Задайте файлы с идентическими пунктами в окна Вход и Выход, и нажмите кнопку (Начти пункты). Программа разыщет пару идентических пунктов и автоматически их добавит в каталог.

Замена координат идентических пунктов

После нажатия кнопки (XY <-> x'y') программа заменит координаты идентических пунктов в обеих системах. Эту возможность можно использовать напр. в случае, когда при задавании идентических пунктов были изменены системы координат. С помощью этой функции координаты будут заменены без нового задавания идентических пунктов.

Статистический тест

Если необходимо выполнить статистический тест избыточных ошибок на идентических пунктах, то включите выбор Статистический тест. Программа выполнит анализ избыточных ошибок, а результаты сохранит в ведомости. Подробное описание статистического теста приведен в задаче Сравнение каталогов координат.

Инверсионная трансформация

После зачеркивания этого переключателя программа начнет вычислять инверсионную (обратную) трансформацию. Этот выбор нельзя использовать для используемой трансформации.

Тип трансформации

Программа позволяет вычислять три типа трансформации:

  • Трансформация идентификации

    Линейная трансформация координат, которая сохраняет масштаб (масштабный коэффициент равен единице). Эта трансформация имеет три параметра (две трансляции и ротацию), но для определения ключа трансформации необходимо хотя бы два идентических пункта.

  • Трансформация подобия

    Ключ трансформации будет иметь в направлении осей Х и Y одинаковые масштабные коэффициенты (трансформация изменяет размеры объектов во всех направлениях одинаково, т.е. сохраняет подобие их фигур). Для этой трансформации достаточно два идентических пункта.

  • Афинная трансформация (5 параметров)

    Ключ трансформации будет иметь разные масштабные коэффициенты для осей Х и Y. При этой трансформации изменяются размеры в зависимости от направления, т.е. подобие фигур в общем не сохраняется. Для этого типа трансформации требуется хотя бы два идентических пункта.

  • Афинная трансформация (5 параметров)

    Будет вычислена непосредственно матрица трансформации. Ее элементы уже не имеют геометрических связей, как это имеет место у пятипараметровой афинной трансформации. Ключ трансформации будет иметь разные масштабные коэффициенты для осей Х и Y. При этой трансформации изменяются размеры в зависимости от направления, т.е. подобие фигур в общем не сохраняется. Для этого типа трансформации требуется хотя бы три идентических пункта.

  • Потребительская трансформация

    Если выберете этот тип трансформации, то нет необходимости задавать идентические пункты, но можно непосредственно задавать результирующие трансформационные связи. После нажатия кнопки (...) изобразится диалоговое окно, куда можно задавать уравнение трансформации для вычисления отдельных координат. В функциональных связях можно использовать математические операции, численные константы и переменные X, Y и Z. Функциональные связи могут выглядеть напр. таким образом:

        X:	X*0.99877354220+Y*0.04951172994+254.339
    Y:	X*0.04951172994-Y*0.99877354220-365.471
    Z:	Z

Если определен ключ трансформации, то для дальнейшего использования его можно сохранить в файле с помощью кнопки (Сохранить ключ).

Трансформация пунктов

Трансформация пунктов выполняется всегда из одного файла в другой. Входной и выходной файлы задайте в части Каталоги координат. Если во входном файле некоторые пункты обозначены, то программа трансформирует только их. Если в нем не обозначена ни одна позиция, то программа трансформирует весь каталог координат.

Пред. | Начало | След.
Высотный ход | Уровень выше | Дирекционный угол и длина


Дирекционный угол и длина
Пред. Глава 11. Расчетные задачи След.

Дирекционный угол и длина

Дирекционный угол и длина

Диалоговвое окно служит для вычисления дирекционного угла и длины по координатам пунктов. Работа с окном идентична работе при решении других задач.

С помощью этой задачи можно, кроме дирекционного угла и длины, определить также пространственное расстояние, уклон в градусах и уклон в процентах. Для получения этих данных необходимо задать оба конечные пункты с высотами.

Пред. | Начало | След.
Трансформация координат | Уровень выше | Контрольные длины


Контрольные длины
Пред. Глава 11. Расчетные задачи След.

Контрольные длины

Диалоговое окно служит для расчета контрольных длин, полученным по координатам, и для их сравнения с измеренными величинами. Работа с окном идентична работе при решении других задач.

В диалоговом окне постепенно задаем координаты пунктов и расстояния от предыдущего пункта. Программа покажет и сохранит в ведомости каталог координат, измеренные длины, вычисленные длины (по координатам) и их различия.

Подсказка

Нажмем-ли клавишу <Enter> на входной строке с длиной, то программа придаст заданные величины в каталог автоматически, а для следущего входа выделит строку с номером пункта.
Подсказка

Если окно с измеренной длиной останется не заполненным или на место длины будет задана величина 0, то вычисленная длина не будет проконтролирована, а в ведомости появится текст "Нельзя измерять".

После задания пункта программа вычислит значение длины по координатам и покажет ее в эдитационном окне.

Если необходимо проконтролировать весь файл контрольных длин, то после расчета нажмите кнопку (Добавить в файл). Изображенные контрольные длины будут добавлены в каталог контрольных длин как в ниже описанной задаче Каталог контрольных длин (если это задача не открыта, то программа автоматически ее откроет).

Пред. | Начало | След.
Дирекционный угол и длина | Уровень выше | Файл контрольных длин


Файл контрольных длин
Пред. Глава 11. Расчетные задачи След.

Файл контрольных длин

Файл контрольных длин

Диалоговое окно служит для тестирования всего файла контрольных длин одновременно. Отдельные длины добавляются в окно из решения задачи <Контрольные длины> кнопкой (Добавить в файл). Отдельные контрольные длины можно исключать кнопкой (Отстранить). После нажатия кнопки (Расчет) программа обработает весь файл контрольных длин. Результат обработки (фактические и допустимые расхождения, общая оценка точности) сохранит в ведомости. Весь файл можно сохранить на диске, нажав кнопку (Сохранить), а позже начесть с диска с помощью кнопки (Начесть).

Пред. | Начало | След.
Контрольные длины | Уровень выше | Конструкционные контрольные длины


Конструкционные контрольные длины
Пред. Глава 11. Расчетные задачи След.

Конструкционные контрольные длины

Конструкционные контрольные длины

С помощью этой задачи можно определять координаты пунктов, определенных с помощью конструкционных контрольных длин.

В каталог в верхней части диалогового окна постепенно задаем измеренные пункты, перпендикуляры к ним и, при наличии, их координаты. Перпендикуляры вправо от предыдущей соединяющей имеют знак плюс, перпендикуляры влево - знак минус. Перпендикуляр на первом пункте программа игнорирует (неявно предлагает нулевое значение). При добавлении пунктов программа мгновенно довычислит их координаты.

Если необходимо в каталог придать новый пункт (напр. пункт, который был при задавании ошибочно пропущен), то обозначте курсором позицию, перед которой этот пункт будет вложен, и добавте его обычным способом.

Между измеренными пунктами долны быть хотя бы два пункта с известными координатами. Эти пункты могут быть в любом месте между измеренными пунктами, т.е. не объязательно должны быть вначале или в конце хода. Максимальное количество идентических пунктов не ограничено.

Координаты пунктов определены с помощью трансформации подобиятрансформация.

Важно

При избыточном количестве идентических пунктов (три и более) трансформация обе системы по идентическим пунктам не отождествит, из чего выплывает, что расчет изменит координаты идентических пунктов. На этот факт необходимо обратить внимание при сохранении вычисленных пунктов (сохраняете-ли их в каталоге, в котором использованные идентические пункты уже находятся) – программа Вас предупредит, что такие пункты в каталоге уже имеются и изобразит расхождения между исходными и новыми координатамы.

Вычисленные координаты вложите в любой каталог перетягиванием мишью из ведомости вычисленных величин (при этом курсором мыши укажите куда-либо в область с результатами, но мимо ведомость вычисленных величин).

Подсказка

Нажав клавишу <Enter> на входной строке с длиной, программа автоматически добавит заданные данные в каталог, а для следующего входа установит строку с номером пункта как активную.

Пред. | Начало | След.
Файл контрольных длин | Уровень выше | Вычисление элементов проекции на прямую


Вычисление элементов проекции на прямую
Пред. Глава 11. Расчетные задачи След.

Вычисление элементов проекции на прямую

Вычисление элементов проекции на прямую

С помощью этой задачи можно определять координаты прямоугольной проекции пункта на прямую (основы перпендикуляра опущенного из заданного пункта на прямую).

В расчетное окно задаем координаты начального и конечного пункта, длины и координаты уравненного пункта. Программа опустит с уравненного пункта нормаль на данную прямую, расчитает координиты точки их пересечения (основы перпендикуляра) и расстояние от проектируемого пункта до точки пересечения.

Вычисленную основу перпендикуляра можно обычным способом перенести в каталог координат.

Пред. | Начало | След.
Конструкционные контрольные длины | Уровень выше | Расчет площадей


Расчет площадей
Пред. Глава 11. Расчетные задачи След.

Расчет площадей

Это диалоговое окно позволяет расчитать площади по координатам пунктов. Пункты добавляются в каталог способом, принятым у остальных задач. Если координаты пунктов перетянуты мишью, то программа их автоматически добавит в каталог без нажатия кнопки (Добавить). Если имеются пункты поворота, обозначенные в каталоге координат (и если они в соответстувующей последовательности), то всех их можно перетянуть мишью сразу как блок (с помощью средней кнопки мыши).

В нижней части диалогового окна можно суммировать или вычитать площади с помощью кнопок (+) и (-). Регистр расчетов можно сбросить кнопкой (Отстранить).

Для контроля конфигурации площади можно использовать модуль для контрольных чертежей.

Подсказка

После нажатия клавиши <Enter> на входной строке, программа автоматически разыщет его координаты и добавит их в каталог.

Конфигурацию площади можно сохранить в файле после нажатия кнопки (Сохранить). Начесть из файла его можно с помощью кнопки (Начесть). Если конфигурацию площади начитывают из файла, то она начитывается вместе с заданными координатами. Если перед этим координаты были изменены, то с помощью кнопки (Актуализировать координаты) можно заменить исходные координаты координатами актуальными. Для использования этой функции необходимо создать условия, при которых программа сможет найти координаты пункта (необходимо открыть соответствующий каталог координат и установить такой режим поиска пунктов, чтобы программа нашла необходимые координаты).

Пред. | Начало | След.
Вычисление элементов проекции на прямую | Уровень выше | Полярные разбивочные элементы


Полярные разбивочные элементы
Пред. Глава 11. Расчетные задачи След.

Полярные разбивочные элементы

Полярные разбивочные элементы

Полярные разбивочные элементы могут расчитываться для отдельных пунктов или для групп пунктов. В обеих случаях необходимо задать сначала координаты станции и ориентацию.

Внимание

Расчитанные длины автоматически приводятся к одному масштабу и тем самым дают представление о фактических длинах на местности, а не о искаженных длинах в плоскости изображения. Поэтому перед расчетом устанавливают необходимый для данной территории масштабный коэффициент.

Перед расчетом необходими выбрать тип разбивочных элементов:

  • Ориентация + направления

    Программа расчитает горизонтальные направления от ориентирного (исходного) направления. В ведомости будут сохранены разбивочные элементы (направление и длина) со станции, те же разбивочные элементы с ориентирного пункта и дирекционный угол линии, соединяющей станцию и выносимый пункт.

  • Оринтация + дирекционные углы

    Программа расчитает длины и дирекционные углы линий станция - выносимый пункт и оринтирный пункт - выносимый пункт.

  • Дирекционные углы

    Программа не требует задания станции и вычисляет только дирекционные углы и длины линии станция – выносимый пункт.

Ориентирное направление

Если необходимо, чтобы на ориентирном пункте было не нулевое направление, то необходимо задать требуемое значение в окошко Горизонтальное направление ориентирное.

Расчет разбивочных элементов отдельных пунктов

При расчете отдельных пунктов перетягиваем в область Выносимый пункт отдельные пункты из каталога координат. Программа мгновенно после перетягивания расчитает соответствующие разбивочные элементы.

Расчет разбивочных элементов дозой (групповой расчет)

При расчете дозой поступаем аналогично, но вместо отдельных пунктов перетягиваем целый блок обозначенных пунктов. В диалоговом окне изобразятся разбивочные элементы только последнего пункта, но в ведомости сохранены все.

Расчет разбивочных элементов для полевого журнала

Если необходимо выполнить групповой расчет всего каталога координат для полевого журнала, то задайте название входного каталога координат в окошко Вход, результирующих каталога измерений в окошко Выход, тогда программа расчитает разбивочные элементы всех пунктов в файле и создаст из разбивочных элементов новый каталог измерений.

Пред. | Начало | След.
Расчет площадей | Уровень выше | Ортогональные разбывочные элементы


Ортогональные разбывочные элементы
Пред. Глава 11. Расчетные задачи След.

Ортогональные разбывочные элементы

Ортогональные разбывочные элементы

Это диалоговое окно служит для расчета ортогональных разбывочных элементов отдельных пунктов. Если необходимо вычислить больше пунктов, то можно использовать трансформацию координат.

Входные величины задаются аналогично, как и при решении остальных расчетных задач. Сначала задаются конечные пункты прямой, потом – отдельные выносимые пункты. Можно перетягивать из каталога координат отдельные пункты и целые группы обозначенных пунктов. Если перетянута целая группа пунктов, то в диалоговом окне останутся разбивочные элементы только последнего пункта, но в каталоге сохранены все.

В протоколе всегда сохранены сначала разбивочные элементы идентических пунктов, а потом отдельных выносимых пунктов. Кроме перпендикуляра и пикетажа расчитан также домер, т.е. расстояние до конечного пункта прямой.

Внимание

Расчитанные координаты и пикетаж всегда автоматически приводятся к одному масштабу и тем самым дают представление о фактических длинах на местности, а не о искаженных длинах в плоскости изображения. Поэтому перед расчетом устанавливают необходимый для данной территории масштабный коэффициент.

Пред. | Начало | След.
Полярные разбивочные элементы | Уровень выше | Расчет трассы


Расчет трассы
Пред. Глава 11. Расчетные задачи След.

Расчет трассы

С помощью этой задачи можно вычислить элементы трассы в соответствии с последовательности линии. Задача вычислит длины сегментов, дирекционные углыЮ углы и превышения между пунктами.

При задании расстояния от разбивочных пунктов до оси трассы вычисляются также координаты этих пунктов.

Входные величины задаются так же, как и у остальных задач. Постепенно задаются отдельные пункты трассы и с помощью кнопки (Добавить) добавляются в каталог. Из каталога координат можно перетянуть отдельные пункты и целые группы обозначенных пунктов.

После задания всей трассы и нажатия кнопки (Расчет), программа вычислит элементы трассы. Если при этом включен контрольный чертеж, то трасса также изобразится. Вычисленные элементы трассы будут записаны в протокол.

Если задано и расстояние от разбивочных пунктов до оси трассы, то можно выбрать и способ нумерации вычисленных пунктов. Можно оставить разбивочным пунктам исходные номера, а дополнить только другие предномера, или присвоить пунктам новые номера, при чем, постоянно (сначало пунктам влево по ходу, а потом вправо по ходу) или попеременно. После расчета можно сохранить пункты перетягиванием мышью в каталог координат (при этом курсор размещаете где-либо в области с результатами, но вне эдитационного окна).

Пред. | Начало | След.
Ортогональные разбывочные элементы | Уровень выше | Кубатуры


Кубатуры
Пред. Глава 11. Расчетные задачи След.

Кубатуры

Это диалоговое окно служит для расчета кубатур методом треугольников. В диалоговом окне постепенно задаются пункты отдельных треугольников. Если задан целый треугольник, нажмите кнопку (Добавить) и заданнный треугольник будет добавлен в каталог треугольников. Перед расчетом необходимо задать высоту отсчетной плоскости, от которой кубатура должна быть вычислена, и описание кубатуры (для сохранения в каталоге). После нажатия кнопки (Расчет) программа расчитает кубатуру и,если включен контрольный чертеж, то покажет на нем сеть треугольников.

Пред. | Начало | След.
Расчет трассы | Уровень выше | Расчет высоты станции


Расчет высоты станции
Пред. Глава 11. Расчетные задачи След.

Расчет высоты станции

Расчет высоты станции

Это диалоговое окно служит для самостоятельного расчета высоты станции. Работа с окном идентична работе с окном для свободной станции, однако задаются в окне только данные для высотных расчетов (координаты станции и высота прибора, координаты и высоты ориентаций (пунктов наведения), высоты целей на пунктах и превышения или зенитные расстояния).

Диалоговое окно позволяет задавать зенитные расстояния (Z) и превышения (dH), но для каждого пункта наведения задайте только те данные, которые имеются к диспозиции.

Пред. | Начало | След.
Кубатуры | Уровень выше | Расчет высот


Расчет высот
Пред. Глава 11. Расчетные задачи След.

Расчет высот

Эта задача работает также, как и групповой полярный метод, но у измеренных пунктов с известными координатами только довычисляет высоты. Работа с ней идентична работе при групповом полярном методе.

Пред. | Начало | След.
Расчет высоты станции | Уровень выше | Внесение изменения на КП-Ц на существующем пункте


Внесение изменения на КП-Ц на существующем пункте
Пред. Глава 11. Расчетные задачи След.

Внесение изменения на КП-Ц на существующем пункте

Внесение изменения на КП-Ц на существующем пункте

Задача служит для внесения изменения на КП-Ц на существующем пункте.

В диалоговом окне задаются координаты существующего пункта в обеих системах, координаты нового пункта и измеренную длину между двумя пунктами. После нажатия кнопки (Добавить), программа добавит пункт в каталог координат, расчитает все необходимые отклонения и создаст ведомость о присоединении изменения согласно предписания.

Пред. | Начало | След.
Расчет высот | Уровень выше | Внесение изменения на КП-Ц на новом пункте


Внесение изменения на КП-Ц на новом пункте
Пред. Глава 11. Расчетные задачи След.

Внесение изменения на КП-Ц на новом пункте

Внесение изменения на КП-Ц на новом пункте

Задача служит для внесения на КП-Ц на новом пункте.

В диалоговом окне задаются координаты существующего пункта в обеих системах, координаты нового пункта и измеренную длину между двумя пунктами. После нажатия кнопки (Добавить), программа добавит пункт в каталог координат, расчитает все необходимые отклонения и создаст ведомость о присоединении изменения согласно предписания.

Пред. | Начало | След.
Внесение изменения на КП-Ц на существующем пункте | Уровень выше | Групповой расчет файла MAPA2


Групповой расчет файла MAPA2
Пред. Глава 11. Расчетные задачи След.

Групповой расчет файла MAPA2

Эта задача позволяет выполнить групповой расчет текстового файла в формате MAPA2.

Система может решить две задачи:

  • Тип 0:Ортогональный метод

  • Тип 1:Полярный метод

Последовательность расчета:

  1. Откройте текстовый файл с заданием расчета в формате MAPA2 командой Файл->Открой.

  2. С активизированным текстовым окном вызовите команду Расчёты->Массив расчёта файлов MAPA2.

Программа расчитает открытый файл, сохранит полученные координаты и составит вычислительную ведомость.

Входной файл может содержать любое количество отдельных задач. Задачи решаются постепенно в такой последовательности, в какой заданы в файле.

В отличие от расчета полярным методом группой, данный расчет выполнен только одной операцией с файлом. Предполагается, что все данные пункты, которые используются при решении задач, в момент, когда они нужны для расчета, известны (из предыдущих вычислений или из входного каталога координат).

Образцовый файл для вычисления полярным методом

512
360607101
660205
1
3
0
0

1  6600004059
6600004055 68.32 0.
6600000548 93.39 201.433
0924222160 0. 105.01
6600004064 82.33 325.943
6600004065 30.15 215.670
-1
6600004066 18.25 231.754
6600004067 48.22 320.479
1 13.74 275.01
2 19.52 244.74
3 16.77 287.41
4 21.68 290.175
5 28.67 291.44
6 24.29 290.17 : 0. -0.15
7 27.55 305.12
8 22.23 229.19
9 29.28 228.40
10 8.10 260.83
11 7.16 282.34
12 8.71 306.23
13 12.71 314.10
14 9.82 300.33
15 27.95 312.26 : 1.05 -0.35
16 37.01 318.25
/
1 6600004066
6600004059 18.26 0.
-1
19 10.93 215.35
20 15.48 233.25
21 20.10 234.07
22 13.40 249.67 : 1.62 0.
9 11.08 191.09
2 4.01 286.33
23 13.27 258.11
24 17.32 258.07
/
-2

Образцовый файл для вычисления методом перпендикуляров (ортогоналным методом)

512
360600102
430114
1
3
0
0

0 4300000517 0. 0.
4300005001 63.72 0.
4300000518 125.57 0.
-1
1 0.52 3.10
2 10.73 2.03
3 22.86 -8.90
4 32.42 -7.27
5 43.86 -7.18
6 45.62 2.86
7 52.77 -10.46
8 53.72 -6.77
9 57.13 -6.73
10 58.91 -10.22
/

0 4300005012 0. 0.
4300000517 101.89 0.
-1
44 35.73 9.70
45 45.52 10.91
46 54.83 5.11
47 57.23 3.12
48 61.20 -2.19
49 61.20 -4.40
50 98.55 10.37
51 37.85 -5.26
52 38.32 -11.30
/
-2

Пред. | Начало | След.
Внесение изменения на КП-Ц на новом пункте | Уровень выше | Глава 12. Экспорт – Импорт файлов


Глава 12. Экспорт – Импорт файлов
Пред. Часть I. Руководство для потребителя След.

Глава 12. Экспорт – Импорт файлов

Программа GROMA позволяет работать с разными форматами файлов данных. Некоторые типы файлов можно читать и записывать прямо, некоторые можно экспортировать и импортировать с помощью свободно определенного текстового формата.

При импорте файлов в диалоговом окне для выбора файлов можно обозначить больше файлов данного типа. Программа постепенно импортирует все выбранные файлы. В ведомости для импорта файлов будет постепенно приведена информация о всех импортируемых файлах.

Каталоги координат можно импортировать прямо в уже открытые файлы с помощью команды Координаты->Присоедини файл. Пункты импортированного файла будут приданы в исходный файл.

Каталоги координат

Текстовые каталоги координат

Программа GROMA позволяет непосредственно читать и записывать каталоги координат в текстовом виде. Для экспорта и импорта этих файлов имеются к диспозиции три фильтра: Координаты XYZ, Координаты YXZ и Координаты-Потребительский формат. Для обычных файлов можно использовать первые два фильтра, а для файлов нестандартного вида – потребительский формат. Потребительский формат подробно описан в приложениях, здесь же будем рассматривать первые два формата.

Учитывая, что текстовые файлы могут содержать различные данные, необходимо учитывать определенные правила, чтобы программа могла распознать какие это данные.

Первые данные на строке всегда интерпретируются как номер пункта. Далее следуют координаты Х и У (согласно принятой последовательности). Другие данные уже не объязательны, но их тип определяется конкретным требованиями. При этом программа руководствуется следующими правилами:

  • Если данное значение координаты содержит точку или запятую (т.е. десятичные части), а другие координаты их не содержат, то программа его интерпретирует как координату Z.

  • Если данное значение имеет только одну цифру, то будет интерпретировано как код качества.

  • Во всех остальных случаях данное значение будет интерпретировано как код пункта. В этом случае в код включается весь остаток входной строки, что позволяет использовать коды с пропусками.

У численных значений для отделения десятинной части от целой может использоваться точка или запятая.

Файлы в формате XML

Каталоги координат и измерений можно экспортировать и импортировать в формате XML (eXtensible Markup Language). Речь идет о обозначающий язык типа SGML, который позволяет производить обмен файлов, формальный контроль верности их структуры и автоматическую конверсию в другие форматы (html, txt, rtf).

Файлы XML имеют четкую структуру, которая определена при помощи декларации типа документ (Document Style Definition, DTD). Сравнением файлов с этим определением можно легко проверить их формальную верность. Определения структуры для файлов, используемых в системе GROMA, являются составной частью инсталяции (сохранены в папке dtd) или их можна стянуть с http://www.groma.cz.

Вместе с файлами DTD являются составной частью дистрибуции и инструкции для перевода XML файлов в HTML. Если имеется интернетовый броусер, поддерживающий формат XML и трансформации с помощью стиля XSL, то можно прямо в нем изобразить каталоги в формате XML. Перевод в HTML выполнит броусер автоматически (обычно совместно с контролем структуры документа и с учетом определения)и изобразит результирующие документы в формате HTML.

Для работы с файлами в формате XML имеется к диспозиции большое количество разных средств (эдиторы, переводные программы, валидаторы и т.п.). Большинство этих программных средств имеются в диспозиции бесплатно на Интернете. Подробное описание языка XML с другими ссылками и online службами можно разыскать на http://www.w3.org.

Программа GROMA позволяет сохранять файлы в формате XML двумя вариантами:

  • Атрибуты

    Информация о позициях приведена в заглавиях элементов с помощью атрибутов. Этот формат несколько нагляднее, при просматривании неформатованых XML файлов, и кроме того, экономнее.

  • Тела элементов

    Информация о позициях приведена в телах элементов. Этот формат плохо читается и объемнее, но для некоторых средств удобен для обработки.

Тип файла определяется при экспорте каталога. При импорте программа сама определит какой это тип файла и корректно его начтет.

Файлы типа GEUS

Файлы программы GEUS (координатные файлы с припоной .DAT) можно прямо читать и записывать. Программа GROMA использует только собственный координатный файл (.DAT), а с индексированным файлом (.IDX) не работает. После перевода каталога координат в формат GEUS необходимо сначала каталог программой GEUS индексировать.

Координатные файлы программы GEUS содержат подобные информации как и файлы программы GROMA, поэтому при импорте вся информация используется (включая коды пунктов). Программа GROMA умеет импортировать файлы данных всех версий системы GEUS, т.е. и файлы с описаниями длиннее чем три знака. Однако при экспорте создаются стандартные файлы с описаниями длиной три знака. Если необходимо создавать файлы с описаниями длиннее чем три знака, то необходимо в конфигурационный файл GROMA.INI в раздел [Formats] добавить позицию GeusInfoSize=x, где x - число в пределах от 3 до 20. Эту позицию нельзя изменять прямо в среде системы GROMA.

Файлы типа dBASE III

Программа GROMA позволяет записать каталог координат в файл в формате dBASE III. Структура этого файла установлена строго и ее нельзя менять.

Таблица 12.1. Структура координатного файла dBASE III

Позиция | Тип | Количество знаков | Количество десят. знаков | Описание
PORCIS | NUMERIC | 3 | 0 | Порядковый номер пункта
ZBP | NUMERIC | 1 | 0 | Государственная геодезическая сеть
ZPMZ | NUMERIC | 4 | 0 | Запись измерения изменений
CISLO | NUMERIC | 4 | 0 | Номер пункта
Y | NUMERIC | 9 | 2 | Ордината Y
X | NUMERIC | 10 | 2 | Абсцисса X
Z | NUMERIC | 6 | 2 | Аппликата Z
TRIDA | NUMERIC | 1 |  | Класс точности
CHKRESBA | CHARACTER | 4 |  | Неиспользовано
STAV | NUMERIC | 1 |  | Неиспользовано
DATUM | DATE | 8 |  | Неиспользовано
YMER | NUMERIC | 9 | 2 | 2 координаты Y
XMER | NUMERIC | 10 | 2 | 2 координаты X

Программа GROMA создает только файл данных. Некоторые аппликации, работающие с файлами баз данных, требуют также индексированный файл. В этом случае необходимо файл данных индексировать (с помощью dBASE III, dBASE IV, RUNTIME, и т.п.).

Файлы типа KOKES

Каталог координат можно сохранить в формате текстового каталога координат для графической системы KOKES (файл .stx). Программа автоматически создаст и необходимое заглавие с координатами по порядку, точностью изображения, редукциями и т.п.

В программа KOKES ограничен объем изображаемой территории. Если этот объем превзойден, то программа GROMA сообщит Вам об этом предупреждающим извещением.

Если в системе GROMA установлено количество десятичных долей 3 и более, то в заглавии результирующего файла установлена точность в миллиметрах, в ином случае установлена в сантиметрах.

Файлы типа Geodimeter

С помощью этого фильтра можно создавать файлы в формате Area для переноса в прибоp Geodimeter. Параметры результирующего файла можно установить в Установка->Вход/Выход->Экспорт в журнал.

Файлы типа Leica

С помощью этого фильтра можно создавать файлы в формате GSI для переноса в прибоp Leica. Можно выбрать между один из двух форматов: Leica/8 (старший формат с восьмизначными записями) и Leica/16 (новый формат с шестизначными записями, позволяющими работать с нередуцированными координатами). Если теперь, в связи с длиной, необходимо при экспорте некоторые записи обрезать, то программа изобразит предупреждающее извещение. Параметры результирующего файла можно установить в Установка->Вход/Выход->Экспорт в журнал.

Файлы типа Sokkia

С помощью этого фильтра можно создавать файлы в формате SDR для переноса в прибоp Sokkia. Можно выбирать между форматами SDR20 и SDR33. Параметры результирующего файла можно установить в Установка->Вход/Выход->Экспорт в журнал.

Файлы типа Topcon

С помощью этого фильтра можно создавать файлы для переноса в прибор Topcon. Параметры результирующего файла можно установить в Установка->Вход/Выход->Экспорт в журнал.

Файлы GROMA версия 2-5

С помощью этого фильтра можно создавать файлы в формате старших версий системы GROMA (версия 2-5). При этом экспорте будут утрачены некоторые данные из нового формата (дата и время создания и последняя модификация пункта, потребительской информации и т.п.).

Пред. | Начало | След.
Групповой расчет файла MAPA2 | Уровень выше | Записи измерений


Записи измерений
Пред. Глава 12. Экспорт – Импорт файлов След.

Записи измерений

Измеренные данные - Текст

Этим фильтром можно экспортировать записи измерений в читаемом текстовом формате. Этот файл можно дальше обрабатывать любым текстовым эдитором.

Измеренные данные - MAPA2

Этим фильтром можно экспортировать записи измерений в стандартном текстовом формате MAPA2. Этот формат поддерживается большинством расчетных программ.

Измеренные данные GROMA версия 2-5

С помощью этого фильтра можно создавать файлы в формате старших версий системы GROMA (версия 2-5). При этом экспорте будут утрачены некоторые данные в новом формате (дата и время и последняя модификация пункта и т.п.).

Пред. | Начало | След.
Глава 12. Экспорт – Импорт файлов | Уровень выше | Чертеж


Чертеж
Пред. Глава 12. Экспорт – Импорт файлов След.

Чертеж

Файлы типа DXF

Если необходимо перенести графику из программы GROMA в иную графическую программу, то можно использовать стандартный заменимый формат DXF (Data Exchange Format). Рисунки в этом формате может импортировать большинство графических систем (в т.ч. системы MicroStation, AutoCAD и т.п.). Перед экспортом графики в этот формат сначала необходимо установить параметры в диалоговом окне Файл->Установка->DXF. Здесь необходимо определиться, если в файл записать и заглавие (некоторым программам, напр. MicroStation, она нужна для правильного расположения элементов в слоях), или, если необходимо заменить координаты X и Y и т.п. Подробнее установка параметров описана в руководстве по применению.

В файлах DXF элементы сохранены в тех слоях, которые виглядят как установленные. Слои, которые по виду выпячены не будут сохранены даже в формате DXF. Поэтому в DXF файле будут только те элементы, которые видимы в активном окне. Исключение составляют только кресты координатной сетки, которые в DXF файлах не сохраняюся.

Пред. | Начало | След.
Записи измерений | Уровень выше | Глава 13. Определение теодолита


Глава 13. Определение теодолита
Пред. Часть I. Руководство для потребителя След.

Глава 13. Определение теодолита

Определение теодолита

Для vyvolani вызова команды Файл->Установка->Теодолит можно определить любое количество теодолитов, которые используются при измерениях, с их свойствами и инструментальными ошибками.

Таким образом определенные теодолиты можно использовать при обработке записей измерений (см. гл. Обработка журнала).

В диалоговом окне задается сначала название теодолита, а потом постепенно все его свойства (инструментальные ошибки и допуски). Если же инструментальные ошибки неизвестны, то установите их сначала как нулевые, а по нескольких первых расчетах исправьте их согласно результатов, полученных при обработке журнала.

Установленные допуски и приборные ошибки программа использует при групповом обработке (дозой) журнала по команде Измерения->Обработка журнала.

Программа поставляется с предварительно установленным теодолитом под названием "Неизвестный теодолит", в определении которого установлены неявные допуски для тестирования подозрительных и ошибочных измерений.

Установка теодолита подробно описана в руководстве по применению.

Пред. | Начало | След.
Чертеж | Уровень выше | Глава 14. Ведомости


Глава 14. Ведомости
Пред. Часть I. Руководство для потребителя След.

Глава 14. Ведомости

При расчетах программа, кроме результирующих величин, создает и текстовые ведомости расчетов, в которых можно найти много полезной информации о ходе расчета, достигнутых невязках и т.п. Эти ведомости могут быть сохранены в файле или напечатаны и переданы как ведомости вычислений.

Открытие ведомости

При открытии ведомости поступают так же, как и при открытии какого-либо иного файла данных. Единственным отличием от остальных типов файлов является то, что может быть открыта всегда только одна ведомость.

Перед открытием ведомости можно в диалоговом окне Файл->Установка->Среда выбрать эдитор, который будет использоваться для эдитации (внутренний эдитор программы GROMA или внешний эдитор).

Внутренний эдитор

Внутренний эдитор имеет вид окна данных, изображенного в главном окне программы GROMA. Это окно можно увеличить, уменьшить, пересунуть или превратить в икону.

Внешний эдитор

Выберете-ли для эдитации ведомости внешний эдитор, то после открытия ведомости в главном окне изобразится только икона ведомости. С ней можно нормально работать, сохранять в ней ведомости при помощи кнопки на планке средств, пересовывать икону и т.п. Если необходимо выполнить эдитацию всей ведомости, то выберите на иконе возобновление окна (дважды щелкнув на икону или при помощи меню) и программа GROMA автоматически запустит выбранный внешний эдитор.

Замечание

Внешний эдитор может быть в данный момент запущен всегда только один раз. После его запуска можно конечно переключиться на программу GROMA, но при новом запуске эдитора появится предупреждающее объявление, что эдитор, открытый при предыдущем запуске необходимо сначала закрыть.

После открытия ведомости появится эдитирующее окно, пустое, если создается новая ведомость, или с результаты предыдущих расчетов. Текст можно эдитировать обычными эдитирующими клавишами, пересовывать или копировать блоки текста в другие аппликации и т.п.

Пред. | Начало | След.
Глава 13. Определение теодолита | Уровень выше | Принцип работы с ведомостью


Принцип работы с ведомостью
Пред. Глава 14. Ведомости След.

Принцип работы с ведомостью

Программа работает с ведомостями на двух уровнях. На одном уровне находится локальная ведомость, которая всегда содержит результаты решения последней задачи, а на другом уровне находится главная ведомость, где отдельные локальные ведомости сохраняюся.

Этот порядок сохранения ведомости выбран потому, что часто выгодно иметь к диспозиции данные о результатах расчета, чем сохранять их автоматически в результирующей ведомости. Если же результаты расчета сохраняются в ведомости автоматически, то она обычно содержит большое количество ненужных или ошибочных данных (из неудачных или пробных расчетов и т.п.), которые необходимо дополнительно удалять.

Пред. | Начало | След.
Глава 14. Ведомости | Уровень выше | Локальная ведомость


Локальная ведомость
Пред. Глава 14. Ведомости След.

Локальная ведомость

Локальная ведомость возникает при каждом отдельном расчете. Ее можно просмотреть после нажания кнопки (Ведомость) в каком-либо расчетном диалоговом окне. Программа откроет диалоговое окно с локальной ведомостью. Это окно не модальное, поэтому его можно оставить открытым и менять его местонахождение и размеры. Если же окно не останется открытым, то в нем при расчетах будут автоматически изображаться все изменения локальной ведомости. Если их необходимо отстранить, то нажимают кнопку(Отстранить). Если же содержание ведомости Вас устраивает, то сохраните его в главной ведомости кнопкой (Сохранить) или с помощью кнопки на планке средств. Если же главная ведомость еще не открыта, то программа сначала изобразит диалоговое окно для ее открытия. Если же теперь главную ведомость не открываетеЮ то программа локальную ведомость не сохранит.

Локальная ведомость имеется только одна и всегда содержит только результаты решения последней задачи. Если Вы ее не сохраните в главной ведомости, то она при следующем расчете она будет переписана.

Пред. | Начало | След.
Принцип работы с ведомостью | Уровень выше | Запись каталога координат в ведомость


Запись каталога координат в ведомость
Пред. Глава 14. Ведомости След.

Запись каталога координат в ведомость

Хотите-ли записать каталог координат (или его часть) в ведомость, то поступают одним из следующих способов:

  • Выберите командуКоординаты->В ведомость. Если в каталоге не обозначена ни одна позиция, то в ведомость будет записан весь каталог координат. Если в каталоге обозначено несколько позиций, то в ведомость будет записана только обозначенная часть.

  • Перетяните мишью пункт или обозначенные пункты на площадь диалогового окна с локальной ведомостью. Перетянете-ли группу обозначенных пунктов, то программа создаст в начале каталога координат заглавие. Перетянете-ли только один пункт, то программа заглавие не создаст.

  • Скопируйте пункт или обозначенные пункты в ячейку памяти с помощью команды Эдитация->Скопируй и с помощью команды Эдитация->Вложи вложите их в окно с целой ведомостью. При этих действиях использовано потребительское предписание формата с установки.

В обеих случаях каталог координат будет создан в локальной ведомости, а в главной ведомости будет сохранен тем же способом, как и расчетные ведомости.

Пред. | Начало | След.
Локальная ведомость | Уровень выше | Запись каталога координат в ведомость


Запись каталога координат в ведомость
Пред. Глава 14. Ведомости След.

Запись каталога координат в ведомость

Если необходимо записать записи измерений (или их часть) в ведомость, поступаем также, как и при записи каталога координат. Seznam mereni будет в ведомости записан в предусмотренном текстовом виде: вначале файла будут приведены данные с заглавия файла (название файла, описание, масштаб и т.п.). Далее будет приведена запись измерений. Станции отделены чертой, номера станций обозначены звездочкой, ориентации - тире.

Также как при записи каталога координат, запись измерений будет создана в локальной ведомости. В главной ведомости ее сохраняют обычным способом, как и расчетные ведомости.

Пред. | Начало | След.
Запись каталога координат в ведомость | Уровень выше | Кодирование чешского языка


Кодирование чешского языка
Пред. Глава 14. Ведомости След.

Кодирование чешского языка

Program v protokolech pouziva pro cestinu kodovou stranku 1250 Latin-2, specifickou pro MS Windows. Chcete-li zpracovavat protokoly jinym zpusobem, nez programem GROMA, muze se stat, ze budete potrebovat jine kodovani cestiny. Program proto umoznuje nastavit jinou kodovou stranku pro ukladani do souboru. Pri cteni protokolu je kodovani prevedeno zpet do kodove stranky Windows 1250 Latin-2, v diskovem souboru je vsak text ulozen ve zvolenem kodovani. Program umoznuje nastavit tyto kodove stranky:

  • 437 DOS Standard IBM,

  • 850 DOS Kamenicky (KEYBCS2),

  • 852 DOS Latin-2,

  • 1250 Windows Latin-2

Внимание

Prekodovani do kodove stranky 437 je nevratne, protoze jsou pri zapisu vsechny ceske znaky prevedeny na ekvivalenty bez diakritickych znamenek. Po pristim otevreni soubor s protokolem obsahuje pouze standardni ASCII znaky.

Пред. | Начало | След.
Запись каталога координат в ведомость | Уровень выше | Параметры ведомости


Параметры ведомости
Пред. Глава 14. Ведомости След.

Параметры ведомости

В диалоговом окне Файл->Установка->Ведомость можно установить разные параметры, которые влияют на работу с ведомостями (сохранение координат исходных пунктов, кодирование языка при записи на диск, фонты для печати и для экрана и т.п.). Подробное описание приведено в руководстве по применению.

Пред. | Начало | След.
Кодирование чешского языка | Уровень выше | Глава 15. Графика


Глава 15. Графика
Пред. Часть I. Руководство для потребителя След.

Глава 15. Графика

Программа GROMA позволяет работать с простой графикой. Для черчения необходимо открыть отдельное окно, в котором можно выполнять основные графические операции с каталогом координат. Для сохранения графических элементов имеются к диспозиции 64 слоя. Эти слои можно в отдельных взглядах как угодно включать и выключать.

Принцип сохранения графики

Графические файлы (.pic), в которых графика сохраняется, содержат только предписание чертежа (информация о графических элементах и номера их конечных пунктов). Такое ведение графических файлов имеет определенные преимущества и невыгоды.

  • Преимущества:

    • графические файлы используют стандартные каталоги координат, а изменения координат пунктов мгновенно передаются и на графику (можно выполнить и трансформацию координат, после которой чертеж не будет нарушен, но приспособится новым координатам),

    • ведение единого каталога координат ведет к заметной экономии места на диске и в памяти (в графическом файле сохраняются только соединяющие пунктов, а графический файл со всеми пунктами остается собственно пустым).

  • Невыгоды:

    • чертеж утерян при изменении номеров пунктов,

    • графические элементы можно размещать только на уже существующие пункты.

Пред. | Начало | След.
Параметры ведомости | Уровень выше | Открытие графического окна


Открытие графического окна
Пред. Глава 15. Графика След.

Открытие графического окна

Если необходимо впервые открыть каталог координат как графику, выберите в меню позицию Координаты->Изобрази графически. Программа попытается в соответствующей директории найти графический файл к выбранному каталогу координат (файл .pic). Если этот файл не существует, то программа его создаст.

При следующем открытии его уже можно выбрать в каталоге по предварительной установке типа файла в "Графика".

Пред. | Начало | След.
Глава 15. Графика | Уровень выше | Работа с графическим окном


Работа с графическим окном
Пред. Глава 15. Графика След.

Работа с графическим окном

После первого открытия графического окна все пункты изобразятся так, чтобы наилучшим образом заполнить площадь окна. Для манипуляции со взглядом служат команды в меню План и кнопки на планке средств. Взгляд можно передвигать с помощью планок в правой и нижней части окна.

Пред. | Начало | След.
Открытие графического окна | Уровень выше | Зацепка за пункты


Зацепка за пункты
Пред. Глава 15. Графика След.

Зацепка за пункты

Программа учитывает способ работы с графикой и поэтому позволяет размещать графические элементы только на уже существующие пункты. За пункты можно зацепиться посредством левой или средней кнопки мыши. При этом программа ищет в окрестностях курсора ближайший пункт, а при его обнаружении передвинет курсор точно не него и окрасит его красным цветом. Одновременно в строке cостояния запишет его номер и координаты. Если в окрестности нет никакого пункта, то известит об этом звуковым сигналом.

Пред. | Начало | След.
Работа с графическим окном | Уровень выше | Рефереционные чертежи


Рефереционные чертежи
Пред. Глава 15. Графика След.

Рефереционные чертежи

К открытому графическому окну можно командой План->Референц. чертежи для контроля присоединить и другие каталоги координат, т.н. рефереционные чертежи. Эти каталоги изображаюся в графическом окне также, как и главный файл. Для различия пункты из референционного файла изображены красным цветом.

Пред. | Начало | След.
Зацепка за пункты | Уровень выше | Кодирование четежа


Кодирование четежа
Пред. Глава 15. Графика След.

Кодирование четежа

Система GROMA позволяет автоматически создавать линейные чертежи на основе кодов и пунктов.

Алгоритм кодирования жестко предписан, но конкретные коды для отдельных линий и функции можно менять в конфигурации программы (команда Файл->Установка->Кодирование: Установка кодирования чертежа).

Алгоритм создания чертежа

Для создания кодированного чертежа необходимо, чтобы на отдельных пунктах были сохранены альфанумерические коды, которые определяют предписание чертежа. Кодов на пункте может быть больше и отделяются они пропусками.

Каждый код состоит из кода элемента и необъязательного управляющего кода.

Коды элементов

Код элемента – это альфанумерическое однознаковое или многознаковое обозначение элемента, под которым элемент определен в таблице элементов. Название целесообразно выбрать покороче из-за кодирования на местности (обычно достаточно однознаковое название). Название не может совпадать с названиями управляющих кодов.

Управляющие коды

Управляющие коды определяют акцию, которая имеет отношение к соответствующему элементу, определенному кодом элемента. Определены три акции:

  • Старт элемента: старт нового элемента (начало новой линии)

  • Окончание элемента: окончание элемента (конец линии)

  • Замыкание элемента: окончание элемента и замыкание на первый пункт

Управляющие коды присоединяются непосредственно к кодам элементов без пропусков. Они определены как альфанумерические однознаковые или многознаковые идентификаторы. Название целесообразно выбрать покороче из-за кодирования на местности (обычно достаточно однознаковое название). Название не может совпадать с названиями управляющих кодов.

Определяете-ли в таблице элементов напр. линию с обозначением A, а управляющий код для начала линии напр. как S, то код AS обозначает начало линии A, а сам код A без управляющего кода обозначает продолжение линии A.

Коды элементов обозначают тип элемента согласно определяющей таблицы, но, ни в коем случае, не конкретное название элемента. Одновременно можно работать напр. с несколькими линиями типа A. Если же программа наталкивается на код, требующий подключение пункта на линии A, то подключит его к последней определенной линии типа A. К остальным линиям того же типа она постепенно возвращается после окончания работы с последней линией.

Определяете-ли всю установку кодов напр. так:

Таблица 15.1. Управляющие коды

Тип кода | Определение
Начало линии | S
Конец линии | K
Замыкание линии | U

Таблица 15.2. Потребительские элементы

Тип элемента | Название | Слой
Линия | A | 10
Линия | B | 11

Таблица 15.3. Образцовые коды

Пункт | Код | Описание
1 | AS | Старт линии типа A
2 | A | Продолжение линии типа A из пункта 1
3 | A BS | Продолжение линии типа A из пункта 2, старт линии типа B
4 | B BS | Продолжение линии типа B из пункта 3, старт очередной линии типа B
5 | BK A | Конец линии типа B из пункта 4 и продолжение линии типа A из пункта 3
6 | B | Продолжение предыдущей линии типа B из пункта 4
7 | AU | Закрытие и конец линии типа A из пункта 5
8 | BK | Конец линии типа B из пункта 6

Пред. | Начало | След.
Рефереционные чертежи | Уровень выше | Глава 16. Дигитализация растровых данных


Глава 16. Дигитализация растровых данных
Пред. Часть I. Руководство для потребителя След.

Глава 16. Дигитализация растровых данных

Программа GROMA позволяет получать координаты пунктов из обработки растровых данных. Файлы с растровыми данными можно получить сканированием картографической основы.

Современная версия программы позволяет обрабатывать растровые данные в формате байтовой карты (файлы .bmp или .dib).

Начтение растровых данных в программу

Если необходимо обрабатывать растровые данные, то сначала необходимо открыть окно с соответствующим файлом. Окно с растровыми данными открывается также, как и любое другое окно данных. Для открытия файла в диалоговом окне необходимо выбрать позицию Битовые карты из каталога Файлы типа. Программа Вам предложит все файлы с припоной .bmp, которые найдете в актуальной директории.

Если выберете некоторый файл, то программа сначала попытается найти файл с таким же названием в соответствующей директории, но с припоной .rnf. Этот файл содержит информацию о растровых данных (идентические пункты, ключ трансформации и т.п.). Если же файл .rnf не найден, то создаст новый. В этом файле автоматически во время задавания сохраняюся идентические пункты для трансформации, а в случае окончания и повторного включения программы (напр. после его аварии) можно дигитализацию продолжать без необходимости нового определения ключа трансформации.

Ключ трансформации относится к соответствующему файлу, а не к окну, т.е. можно одновременно открыть большее количество окон с одной битовой картой, в которых будет действовать все тот же один ключ трансформации (т.е. его достаточно определить только в каком-либо одном окне).

Так же, как это напр. есть у координатных файлов, можно одновременно открыть больше файлов с растровыми данными. При дигитализации программа автоматически использует к каждому файлу соответствующий ключ трансформации. Если открыто диалоговое окно для определения ключа трансформации (см. далее), то программа в нем изобразит данные, относящиеся к тому окну, в котором теперь находится курсор мыши. Если Вы теперь пересунете курсор из окна с растровыми данными в другое, то программа мгновенно изобразит идентические пункты второго файла.

Пред. | Начало | След.
Кодирование четежа | Уровень выше | Графические координаты


Графические координаты
Пред. Глава 16. Дигитализация растровых данных След.

Графические координаты

Единицей графических координат является один картинный элемент (Picture Element - Pixel). Пиксель - это наименьший элемент изображенный на байтовой карте. Действительный физический размер этого пикселя зависит от использованой разрешающей способности скенера. Если сканирование картографической основы производилось с разрешающей способностью 400dpi (т.е. 400 пунктов на палец), то один пиксель отвечает площади размерами примерно 0.064 мм.

Это значит, что точность результирующих цифровых координат существенно зависит от разрешающей способности. От разрешающей способности зависит также объем растровых данных (при двойном увеличении разрешающей способности величина битовой карты увеличится в четыре раза). Это значит, что необходимо найти компромисс между требуемой точностью и удовлетворяющей величиной битовой карты.

Пред. | Начало | След.
Глава 16. Дигитализация растровых данных | Уровень выше | Трансформация координат


Трансформация координат
Пред. Глава 16. Дигитализация растровых данных След.

Трансформация координат

Перед началом дигитализации необходимо определить отношение между картиной карты и действительностью, т.е. определить ключ трансформации, с помощью которого координаты дигитализированных пунктов будут переводиться в целевую систему координат.

Программа использует т.н. афинную трансформацию координат. При этой трансформации использованы два разные масштабные коэффициенты для направлений по осям X и Y. В этом случае трансформация лучше учитывает неравномерную деформацию картографической основы в продольном и поперечном направлениях. Параметры трансформации определяются на основе метода наименьших квадратов (при условии минимализации сумм квадратов невязок координат на идентических пунктах).

Минимальное количество идентических пунктов зависит от типа использованной трасформации и может достигать числа три (трансформация имеет пять параметров: два сдвига, два масштабные коэффициенты и ротацию).

Максимальное количество идентических пунктов ограничено только объемом операционной памяти.

Пред. | Начало | След.
Графические координаты | Уровень выше | Манипуляция с лупой


Манипуляция с лупой
Пред. Глава 16. Дигитализация растровых данных След.

Манипуляция с лупой

Диалоговые окна для дигитализации растровых данных содержат лупу, т.е. вырез, в котором изображен увеличенный образ битовой карты. В центре лупы изображен пункт, на котором теперь размещен курсор. Двигаете-ли курсором по битовой карте, то программа автоматически изобразит соответствующий вырез.

Увеличение лупы можно наставить в пределах 1-8. Для изменения увеличения служат кнопки <+> и <->, изображенные под лупой.

Если лупу необходимо использовать для точного отсчитывания графических координат, нажмите на клавиатуре клавишу <Ctrl>, тогда курсор автоматически передвинется с битовой карты на соответствующее место на лупе (передвинуть курсор с битовой карты на лупу конечно нельзя, потому-что при передвижении курсора по битовой карте автоматически передвигается и вырез, изображаемый лупой). После отпуска клавиши <Ctrl> курсор возвратится обратно на битовую карту (на место, на котором был размещен на лупе), а окно с битовой картой опять станет активным.

Важно

Если необходимо использовать лупу с помощью клавиши <Ctrl>, то окно с битовой картой должно быть активным (т.е. заглавие должно изменить цвет), иначе не будет на клавишу <Ctrl> реагировать.

Если окно не активизировано, то его можно активизировать поместив курсор мыши куда-либо на его плоскость и нажав левую или правую кнопку мыши или с помощью меню Окно.

Пред. | Начало | След.
Трансформация координат | Уровень выше | Определение


Определение
Пред. Глава 16. Дигитализация растровых данных След.

Определение

Для определения ключа трансформации служит диалоговое окно, которое открывают с помощью команды Битовая карта->Ключ трансформации.

Диалоговое окно содержит входные строчки для задания графических графических и действительных координат идентических пунктов. Эти координаты задают или перетягивают мышью из каталога координат. Графические координаты задает программа после нажатия левой кнопки в плоскости окна с битовой картой или на лупе.

Если координаты пункта заданы в обеих координатных системах, то его можно добавить в каталог идентических пунктов с помощью кнопки (Добавить). Программа автоматически актуализирует ключ трансформации, а добавленный пункт сохранит на диске. Любой пункт можно исключить из каталога с помощью кнопки (Отстранить).

В каталоге идентических пунктов изображаюся и достигнутые невязки координат.

Если ключ трансформации Вас удовлетворяет (его можно изобразить с помощью кнопки (Ключ)), то это диалоговое окно можно закрыть и приступить к собственно дигитализации. Если позже его необходимо будет проконтролировать или исправить, то во вновь открытом диалоговом окне опять будет изображен весь каталог идентических пунктов. После расчета трансформационных зависимостей будет создана ведомость, в которой будет информация о трансформации (трансформационные параметры, невязки на идентических пунктах и т.п.).

Пред. | Начало | След.
Манипуляция с лупой | Уровень выше | Дигитализация


Дигитализация
Пред. Глава 16. Дигитализация растровых данных След.

Дигитализация

Для дигитализации пикетов служит диалоговое окно, которое можно открыть с помощью команды Битовые карты->Дигитализация.

Порядок действий при собственно дигитализации такой же, как и при определении ключа трансформации. После нажатия левой кнопки мыши в плоскости окна с битовой картой или с лупой в диалоговом окне изобразятся результирующие трансформированные координаты.

Если пункт необходимо сохранить, необходимо задать его предномер и номер. Если предномер не задан, то программа использует неявный предномер, имеющийся в Файл->Установка->Редукция. Если задан номер пункта, то после вычитания координат программа его автоматически увеличит на единицу.

Если установлен активный каталог координат, то программа в нем автоматически сохранит указанный пункт. Если не желаете пункты автоматически сохранять, то установите активный каталог координат как [Никакой].

Пред. | Начало | След.
Определение | Уровень выше | Глава 17. Графическое определение пунктов


Глава 17. Графическое определение пунктов
Пред. Часть I. Руководство для потребителя След.

Глава 17. Графическое определение пунктов

Принцип графического определения пунктов

Если в некотором диалоговом окне возле входного окна изображена кнопка со стрелкой, то это значит, что этот пункт может быть показан мышью в графическом окне программы или в системе MicroStation (если GROMA наконфигурирована и запущена как аппликация системы MicroStation – см. Приложения).

Пред. | Начало | След.
Дигитализация | Уровень выше | Порядок действия при графическом определении пунктов


Порядок действия при графическом определении пунктов
Пред. Глава 17. Графическое определение пунктов След.

Порядок действия при графическом определении пунктов

  • Нажмите в диалоговом окне кнопку со стрелкой, которая изображена возле определяемого графически пункта. Кнопка останется нажатой с измененным цветом. Если перед этим была нажата другая кнопка, то теперь она автоматически отключится (во всей системе GROMA может быть нажата всегда только одна кнопка).

  • Покажите соответствующий пункт в графическом окне. Если выбрана команда для черчения линии, удаления элементов, изменения масштаба и т.п., то выберите сначала команду План->Выбор элементов. После указания на пункт, его координаты будут перенесены в диалоговое окно. Если в этом окне имеется больше кнопок для вычитания координатЮ то программа автоматически нажмет следующую кнопку.

Пред. | Начало | След.
Глава 17. Графическое определение пунктов | Уровень выше | Глава 18. Печатные выходы


Глава 18. Печатные выходы
Пред. Часть I. Руководство для потребителя След.

Глава 18. Печатные выходы

Графические и текстовые данные в программе GROMA можно без проблем печатать на каком-либо устройстве, для которому в MS Windows наисталирован соответствующий драйвер.

Драйвер

Для каждого устройства, которое будет использоваться в MS Windows, необходимо иметь соответствующую управляющую программу (драйвер).

Большое количество драйверов поставляется непосредственно с MS Windows на инсталяционных дикетах. Дискеты содержат драйверы почти для всех доступных печатающих устройств (принтеров). Более того, производители аппаратных средств поставляют совместно с ними дискеты с новейшими версиями драйверов.

Драйверы можно наисталировать напр. при помощи Управляющей панели (см. документацию к MS Windows).

Пред. | Начало | След.
Порядок действия при графическом определении пунктов | Уровень выше | Выбор выходного устройства


Выбор выходного устройства
Пред. Глава 18. Печатные выходы След.

Выбор выходного устройства

Перед печатью данных в программе GROMA необходимо сначала выпонить установку выходного устройства. Программа позволяет установить устройство для работы на двух разных входных приспособлениях - отдельно для печати текста и отдельно для печати графики. Можно установить напр. печать текста на матричном принтере, а графики – на HPGL плоттере.

Оба выходные устройства выбираются в диалоговом окне Файл->Установка принтера.

Диалоговое окно содержит два списка, в которых записаны все выходные устройства, наинсталированные в настоящее время в Windows (т.е. для них наинсталированны драйверы). Если же требуемое устройство в списках отсутствует, то необходимо сначала наинсталировать соответствующий драйвер.

Если требуемое выходное устройство в списках приведено обозначне его курсором и нажмите кнопку (Выбрать). С этого момента все выходы на печать направляются на выбранное устройство.

Если драйвер позволяет изменять некоторые параметры (размеры бумаги, ориентацию, разрешающую способность и т.п.), то их можно установить после нажатия кнопки (Установка).

Пред. | Начало | След.
Глава 18. Печатные выходы | Уровень выше | Просмотр перед печатью


Просмотр перед печатью
Пред. Глава 18. Печатные выходы След.

Просмотр перед печатью

Перед собственно печатью документов можно просмотреть как они будут выглядеть после печати. После нажатия кнопки (Просмотр) программа откроет окно, в котором изображен вид печатаемого документа. С помощью кнопок на панели средств изображение можно увеличить, уменьшить и переместить между отдельными страницами документа.

Пред. | Начало | След.
Выбор выходного устройства | Уровень выше | Печать каталогов


Печать каталогов
Пред. Глава 18. Печатные выходы След.

Печать каталогов

Каталоги координат и списки измеренных величин – это текстовые данные, которые печатают на устройстве, выбранном как Текстовый выход (см. выше).

Каталоги печатают с помощью диалогового окна, открытого командой Файл->Печать.

В диалоговом окне изображено название файла (перед включением команды команды на печать должно быть одно из окон этого файла выбрано как активное), актуальная установка полей и предполагаемое количество страниц.

Установка полей

Перед печатью можно установить поля на бумаге (в миллиметрах).

Важно

При установке слишком больших полей выход может не поместиться на бумаге и в этом случае при просмотре может иметь неожиданный вид (перекрытые тексты и т.п.).

Выбор заглавий

Можно выбрать, которые позиции из информации о файле будут приведены в заглавии документа.

Выбор позиций

Программа позволяет отпечатать весь каталог или только выбранные позиции.

  • Если необходимо отпечатать весь каталог, то включите выбор Все позиции и программа отпечатает весь каталог.

  • Если необходимо отпечатать только некоторые позиции, то сначала их в каталоге обозначьте, а потом включите выбор Обозначенные позиции и программа отпечатает только обозначенные позиции.

Выбор количества страниц и количества копий

В диалоговом окне для печати изображено общее количество страниц документа, а количество копий предварительно установлено так, чтобы был отпечатан весь документ. Номер начальной и конечной страницы для печати можно как угодно менять.

Здесь же можно предварительно установить также требуемое количество копий.

Выбор фонта

Для печати можно предварительно установить фонт, независимый от фонта, которым выписываюся каталоги на экран. Фонт устанавливают с помощью кнопки (Фонт). Выбранный фонт используется для печати каталога координат и журнала измеренных величин.

Пред. | Начало | След.
Просмотр перед печатью | Уровень выше | Глава 19. Менеджер конфигурации


Глава 19. Менеджер конфигурации
Пред. Часть I. Руководство для потребителя След.

Глава 19. Менеджер конфигурации

Менеджер конфигурации – это средство, облегчающее работу с большим количеством конфигурационных файлов. Когда-либо при работе с системой GROMA можно отключить активную конфигурацию, чем мгновенно изменится установка всех параметров программы.

Менеджер конфигурации можно включить с помощью кнопки (...), которая находится на панели установки за каталогом конфигураций, или выбрав Файл->Менеджер конфигурации. Подробнее менеджер описан в Руководстве по применению.

Пред. | Начало | След.
Печать каталогов | Уровень выше | Глава 20. Сотрудничество с CAD системами


Глава 20. Сотрудничество с CAD системами
Пред. Часть I. Руководство для потребителя След.

Глава 20. Сотрудничество с CAD системами

Система GROMA способна с помощью OLE Automation сотрудничать с независимыми CAD системами. В настоящее время поддерживаются системы IntelliCAD и DesignCAD.

Если система GROMA запущена при поддержке соответствующей CAD системы, то присоединится к нему как подчиненная аппликация и позволит прямой перенос пунктов на чертеж простым перетягиванием мышью.

Кроме выше приведенных систем можно программу GROMA использовать также в соединении с графической ситемой MicroStation. Система MicroStation, в отличии от выше приведенных систем, позволяет коммуникацию в обеих направлениях, т.е. пункты можно переносить как с Gromа на чертеж, так и с чертежа в Gromа. Порядок действий и использование подробно описаны в приложениях.

Запуск с поддержкой CAD системы

Если необходимо запустить систему GROMA так, чтобы она поддерживала соответствующую CAD систему, то необходимо запустить программу GROMA с параметром -parent=название на командной строке.

Для системы IntelliCAD следовательно неообходимо использовать параметр -parent=IntelliCAD, а для системы DesignCAD – параметр -parent=DesignCAD.

Пред. | Начало | След.
Глава 19. Менеджер конфигурации | Уровень выше | Атрибуты для переноса пунктов


Атрибуты для переноса пунктов
Пред. Глава 20. Сотрудничество с CAD системами След.

Атрибуты для переноса пунктов

Атрибуты, которые будут использованы для переноса пунктов на чертеж, можно установить в диалоговом окне Файл->CAD установка. Подробнее эта установка описана в Руководстве по применению .

Пред. | Начало | След.
Глава 20. Сотрудничество с CAD системами | Уровень выше | Часть II. Руководство по применению


Часть II. Руководство по применению
Пред. След.

Руководство по применению

Содержание

21. Работа с Руководством по применению
22. Главное меню
23. Меню Файл
Новый
Открой
Сохрани
Сохрани как
Закрой все
Компрессия файла
Индексирование файла
Информация о файле
Активный каталог координат
Установка
Менеджер конфигурации
CAD установка
Печать
Установка принтера
Изобрази ведомость расчета
Сохрани ведомость расчета
Конец
24. Диалоговое окно Установка
Среда
Расчеты
Редукция
Журнал
Теодолит
Кодирование пунктов
Ведомость
Вход/Выход
Входной / выходной формат координат
Входной / выходной формат измерений
DXF
25. Меню Расчеты
26. Меню Окно
Закрой
Мозаика горизонтально – вертикально
Каскад
Выравнивание икон
Параметры изображения
27. Меню Эдитация
Шаг назад
Перенеси
Скопируй
Вложи
Смазать
28. Меню Проект
Добавь файл
Отбери файл
Открой файл
Установка
29. Меню Координаты / Измерения
Добавь позицию
Отстрани позицию
Эдитируй позицию
Найди позицию
Обозначь
Массовые изменения
Перенумерация каталога
Перекодирование согласно таблицы
Восстановление смазанных позиций
В ведомость
30. Меню Координаты
Изобрази графически
Группировка согласно листов карты (плана)/
Сравнение каталогов координат
Контроль номеров-дубликатов
Контроль нумерации пунктов
Отстранение идентических пунктов
Округление координат
Координаты в двух системах
Параметры изображения
31. Меню Измерения
Обработка журнала
Соединение станций
Обозначь ориентации
Группирование
Присоедини файл
Параметры изображения
32. Меню План
Параметры изображения
Изображение
Увеличить
Уменьшить
Перечерти
Вырез
Выбор элементов
Отстранение элементов
Соединение пунктов
Ограждение
Вычитание координат
33. Меню Битовая карта
Ключ трансформации
Дигитализация
Пред. | Начало | След.
Атрибуты для переноса пунктов | Уровень выше | Глава 21. Работа с Руководством по применению


Глава 21. Работа с Руководством по применению
Пред. Часть II. Руководство по применению След.

Глава 21. Работа с Руководством по применению

Руководство по применению содержит перечень всех доступных команд в меню программы GROMA. Функции всех команд также коротко описаны. Подробное описание можно отыскать в соответствующей главе Руководства по применению.

Некоторые команды можно запустить сокращенно с помощью кнопок на Панели средств, размещенной в главном меню. У этих команд в левом столбце (под их названием в меню) будет изображена соответствующая кнопка панели средств.

Пред. | Начало | След.
Часть II. Руководство по применению | Уровень выше | Глава 22. Главное меню


Глава 22. Главное меню
Пред. Часть II. Руководство по применению След.

Глава 22. Главное меню

В верхней части главного окна программы изображено главное меню. Изображенные позиции этого меню зависять от типа активного окна данных. Перед открытием первого окна меню содержит только позиции Файл, Расчеты, Средства и Справка, в которых имеются предложения по конфигурации программы и по открытию файла данных.

После открытия первого файла изобразится полное меню. Меню всегда содержит позиции основного меню. Остальные позиции меню зависят от типа активного окна и постоянно меняются.

Таблица 22.1. Позиции меню

Тип активного окна | Позиция активного окна
Каталог координат | Эдитация, Измерение, Окно
Журнал измеренных величин | Эдитация, Координаты, Окно
Графика | План, Окно
Растровые данные | Битовая карта, Окно
Ведомость | Эдитация, Окно
Текст | Эдитация, Окно
Проект | Проект, Окно
Пред. | Начало | След.
Глава 21. Работа с Руководством по применению | Уровень выше | Глава 23. Меню Файл


Глава 23. Меню Файл
Пред. Часть II. Руководство по применению След.

Глава 23. Меню Файл

Команды меню Файл служит для манипуляции с файлами, для печати и для окончания программы.

Новый

С помощью этой команды можно заложить новый файл. После включения команды появится диалоговое окно, в котором можно выбрать тип файла, который желаете заложить (каталог координат, журнал измерений, ведомость, текстовый файл или проект). После подтверждения выбора изобразится пустое окно данных соответствующего. Окно обозначено названием Неназванный и порядковым номером временного файла. Если необходимо файл сберечь, то сохраните его с помощью команды Файл->Сохрани как, в противном случае он будет после окончания автоматически отстранен (при закрытии файла программа об этом факте сообщит).

Пред. | Начало | След.
Глава 22. Главное меню | Уровень выше | Открой


Открой
Пред. Глава 23. Меню Файл След.

Открой

Этот приказ служит для открытия нового файла или для открытия нового окна файла, которое уже открыто. После его открытия появится диалоговое окно для выбора файла.

Перед выбором названия файла необходимо сначала установить тип файла (в левой нижней части окна). Файлы во внутреннем формате программы GROMA (.crd, .mes, .pic, .bmp, .prj) непосредственно открыты, остальные файлы программа сначала импортирует во внутренний формат и только потом возникший файл откроет. Из этого выплывает, что любые изменения в файле сохраняются во внутреннем формате, а исходный файл остается без изменения. В каталоге, в случае файлов во внутреннем формате системы GROMA, можно обозначить больше файлов с помощью клавиш <Shift> и <Ctrl>.

Если импортируете журнал измерений или каталог координат из формата журнала, то необходимо сначала установить в диалоговом окне Файл->Установка->Журнал тип журнала и формата с которыми работаете. Перечень типов файлов в диалоговом окне для открытия файла содержит позиции для импорта измерений, которые изменяются согласно только что установленного типа журнала.

С помощью этого общего диалогового окна можно также открывать сохраненные расчеты (полигонометрические хода, площади, контрольные промеры, ключ трансформации) и файлы из разширяющих модулей (уравнивание сети, трасса коммуникации, топографический план).

Пред. | Начало | След.
Глава 23. Меню Файл | Уровень выше | Сохрани


Сохрани
Пред. Глава 23. Меню Файл След.

Сохрани

Команда служит для сохранения текстового файла, ведомости или проекта на диске. С остальными типами файлов эта команда не работает, потому-что эти файлы записываются на диск автоматически после каждого изменения.

Пред. | Начало | След.
Открой | Уровень выше | Сохрани как


Сохрани как
Пред. Глава 23. Меню Файл След.

Сохрани как

Команда служит для сохранения файла под другим именем или же в ином формате. Ее можно использовать только для каталогов, т.е. для координатного файла и файла с измеренными данными, ведомостей и текстовых файлов.

Если в файл необходимо записать только выбранные данные, то выберите позицию Сохранить пункты: Обозначенные После этого, программа запишет в результирующий файл только те позиции, которые в актуальном файле обозначены.

Пред. | Начало | След.
Сохрани | Уровень выше | Закрой все


Закрой все
Пред. Глава 23. Меню Файл След.

Закрой все

Этой командой можно закрыть одновременно все открытые файлы (и все открытые окна).

Пред. | Начало | След.
Сохрани как | Уровень выше | Компрессия файла


Компрессия файла
Пред. Глава 23. Меню Файл След.

Компрессия файла

Программа выполнить компрессию файла данных. При компрессии в файле выпускаются все отстраненные позиции, а остальные позиции сохраняются сгруппированными, что может заметно ускорить возможное будущее индексирование. Исходный файл сохраняется как запасной (координатный с припоной .~cr, файл с измеренными данными с припоной .~me).

Пред. | Начало | След.
Закрой все | Уровень выше | Индексирование файла


Индексирование файла
Пред. Глава 23. Меню Файл След.

Индексирование файла

Программа создаст для файла данных новый индексированный файл. В нормальных условиях создавать таким способом индексированный файл нет необходимостиЮ так как программа о его актуализацию постарается сама. Эту команду используйте только тогда, когда у Вас есть причина предполагать, что информация, которую Вы видите на экране, не соответствует фактическим данным файла данных.

Пред. | Начало | След.
Компрессия файла | Уровень выше | Информация о файле


Информация о файле
Пред. Глава 23. Меню Файл След.

Информация о файле

Эту команду вызовет диалоговое окно, которое содержит информацию о актуальном файле (количество позиций, дата создания и т.п.). Здесь можно определить аж 32знаковое описание файла, который изображается в диалоговом окне при открытии файла.

Информацию можно установить для каталогов координат и для журнала измеренных величин.

Пред. | Начало | След.
Индексирование файла | Уровень выше | Активный каталог координат


Активный каталог координат
Пред. Глава 23. Меню Файл След.

Активный каталог координат

При работе с большим количеством каталогов координат одновременно, целесообразно, чтобы один из них был обозначен как активный. Если выбор для поиска пунктов во всех открытых файлах не установлен (Файл->Установка->Среда), то пункты ищутся только в активном каталоге координат. Некоторые расчетные задачи (напр. полярный метод) сохраняют в активном каталоге координат все вычисленные пункты.

Пред. | Начало | След.
Информация о файле | Уровень выше | Установка


Установка
Пред. Глава 23. Меню Файл След.

Установка

После этой команды появляется диалоговое окно с закладками, с помощью которого можна выполнить конфигурацию системы GROMA. Отдельные позиции этой установки описаны далее (диалоговое окно Установка).

Пред. | Начало | След.
Активный каталог координат | Уровень выше | Менеджер конфигурации


Менеджер конфигурации
Пред. Глава 23. Меню Файл След.

Менеджер конфигурации

После этой команды появляется диалоговое окно для манипуляции с конфигурациями. С его помощью можно создавать и отстранять файлы с конфигурациями и выбирать активную конфигурацию.

Конфигурация:

В рамке приведен перечень всех доступных конфигураций. Программа предлагает все конфигурации, которые найдете в директории для конфигурационных файлов. На размещение конфигурационных файлов можно повлиять с помощью параметров при запуске или посредством файла network.ini.

Размещение

Здесь показана дорога, на которой система GROMA ищет конфигурационные файлы. Этот параметр нельзя изменять прямо, но с помощью параметров при запуске или файла network.ini (см. приложение Конфигурационный файл).

Название конфигурации

Здесь можно каждому конфигурационному файлу присвоить название. Если он не получил название, то это значит, что в перечнях конфигураций он идентифицирован с помощью названия файла. Если его всеже нужно назвать, то здесь же задайте его название и нажмите кнопку (Сохранить).

Создать копию

После нажатия этой кнопки будет создана копия конфигурации, которая выбрана в перечне конфигураций.

Создать новую

После нажатия этой кнопки будет создана копия основной конфигурации, которая сохранена в файле groma.ini в инсталяционной директории системы GROMA.

Отстранение

После нажатия этой кнопки будет отстранен выбранный конфигурационный файл.

Пред. | Начало | След.
Установка | Уровень выше | CAD установка


CAD установка
Пред. Глава 23. Меню Файл След.

CAD установка

После этой команды появляется диалоговое окно, которое служит для установки атрибутов изображения пунктов при соединении с некоторой CAD системой (DesignCAD, IntelliCAD).

Окно содержит перечень конфигураций, из которого можно выбирать простым указанием на требуемую позицию. Если необходимо придать в перечень следующую конфигурацию, то заполните в диалоговом окне все атрибуты для отдельной составляющей файла (пункт, предномер, номер, высота, код). Зачеркните те позиции, которые должны быть, при перенесении пункта, записаны на чертеже. У численных данных можно также установить количество целых знаков, количество десятичных долей и т.д. После задания названия конфигурации и нажатия кнопки (Добавить), конфигурация будет придана в перечень.

Пред. | Начало | След.
Менеджер конфигурации | Уровень выше | Печать


Печать
Пред. Глава 23. Меню Файл След.

Печать

Позволяет отпечатать каталог координат или вычертить чертеж на плоттере. Перед началом печати необходимо сначала выбрать соответствующее выходное устройство.

После включения этой команды появится диалоговое окно, вид которого зависит от типа окна, которое необходимо отпечатать.

Пред. | Начало | След.
CAD установка | Уровень выше | Установка принтера


Установка принтера
Пред. Глава 23. Меню Файл След.

Установка принтера

Перед печатью (черчением) необходимо сначала установить выходное устройство. В программе устанавливают отдельно устройство для выхода текста, на котором будут печататься каталоги (обычно принтер), и устройство для выхода графики, на котором будет вычерчиваться графика (обычно плоттер).

Эта команда изобразит диалоговое окно для выбора обоих устройств и установки их конфигурации (если это соответствующие драйверы позволяют).

Пред. | Начало | След.
Печать | Уровень выше | Изобрази ведомость расчета


Изобрази ведомость расчета
Пред. Глава 23. Меню Файл След.

Изобрази ведомость расчета

Эта команда изобразит диалоговое окно с локальным протоколом последнего расччета. Команда является эквивалентной нажатию кнопки (Ведомость) в любом расчетном окне.

Диалоговое окно с локальным протоколом немодальное, т.е. может быть постоянно открытым. Если оно во время выполения расчета открыто, то изменения в локальной ведомости изобразятся в нем мгновенно.

Если необходимо сохранить локальную ведомость в общей ведомости, то нажмите кнопку (Сохранить).

Пред. | Начало | След.
Установка принтера | Уровень выше | Сохрани ведомость расчета


Сохрани ведомость расчета
Пред. Глава 23. Меню Файл След.

Сохрани ведомость расчета

С помощью этой команды можно сохранить локальную ведомость даже без открытия диалогового окна локальной ведомости. Этот способ сохранения несколько быстрее. Его можно с пользой использовать и в случае, когда локальная ведомость больше, чем можно изобразить в стандартном эдитационном окне (ограничение Windows 95 – в этом случае диалоговое окно с локальной ведомостью не может быть изображено).

Пред. | Начало | След.
Изобрази ведомость расчета | Уровень выше | Конец


Конец
Пред. Глава 23. Меню Файл След.

Конец

Эта команда заканчивает работу с программой GROMA. Перед окончанием записываются все индексированные файлы, а в конфигурационном файле сохраняется информация об открытых окнах, поэтому при следующем запуске программы все окна автоматически открываются и размещаются на экране так, как они размещались при окончании программы.

Пред. | Начало | След.
Сохрани ведомость расчета | Уровень выше | Глава 24. Диалоговое окно Установка


Глава 24. Диалоговое окно Установка
Пред. Часть II. Руководство по применению След.

Глава 24. Диалоговое окно Установка

Это диалоговое окно включается командой Файл->Установка. В нем устанавливаются все параметры программы GROMA (параметры среды, входные/выходные форматы, допуски и т.п.)

Среда

После включения этой закладки можно установить разные параметры для работы программы. Данные сосредоточены в логистические группы.

Последовательность нумерации координат:

Можно выбрать последовательность, согласно которой должны изображаться и задаваться координаты X и Y в каталогах и в диалоговых окнах. Этот выбор не имеет влияния на сохранение каталога координат в текстовых файлах, где последовательность предусмотрена предписанием формата.

Важно

Изменение последовательности координат проявится только после окончания программы и ее повторном включении.

Группирование:

Здесь можно установить, каким способом должны быть размещены позиции в каталоге координат.

  • Не группировать

    В этом случае пункты в каталоге координат не сгруппированы, но приведены в такой последовательности, в какой были в файл добавлены. Эта последовательность однако нарушится напр. при компрессии файла, правда, когда в момент компрессии установлен иной способ группирования (при компрессии файла создан новый файл, в который все пункты записаны в такой последовательности, в какой, в момент компрессии, изображены).

  • Предномер

    Пункты в каталоге сгруппированы, во-первых, согласно предномера и, во-вторых, согласно номера пункта. Следовательно, в файле пункты размещаются за собой с одинаковым предномером и разным номером. Это наиболее применяемый способ группирования.

  • Номер

    Пункты сгруппированы первоначально согласно номера пункта, а вторично согласно предномера. Следовательно, в файле пункты размещаются за собой с одинаковым номером и разным предномером.

Текстовый эдитор:

Здесь можно установить, чтобы программа использовала внутренний или внешний эдиторы. Для внешнего эдитора можно выбрать команду для запуска (и с полным адресом, если это необходимо). Включите-ли внешний эдитор, то программа изобразит окно с ведомостью только как икону, а при попытке увеличить (обновить) окно автоматически включится внешний эдитор. Если же величина ведомости в Windows 95 превысит значение предельной величины для эдитации внутренним эдитором (прим. 30 KB), то система GROMA автоматически переключится на внешний эдитор. Windows NT это ограничение не касается

Seznamy:

  • Обозначение позиций в каталогах согласно Windows

    Если этот выбор включен, то система GROMA работает при обозначении позиций в каталогах так же, как остальные каталоги в Windows (укажете-ли мышью в каталог, то обозначение позиций отменится). Если этот выбор выключен, то обозначение позиций работает как у предыдущих версий.

  • Быстрое замыкание/отмыкание пунктов мышью

    Если этот выбор включен, то можно отдельные пункты закрывать и открывать щелкнув мышью у левого края каталога (перед номером пункта).

Поиск пунктов:

  • искать по предномеру

    При этом выборе пункты ищутся по номеру и предномеру, т.е. чтобы пункт был найден в каталоге, он должен иметь тот же номер и предномер. Если этот выбор не выбран, то при поиске будут найдены все пункты с данным номером, без учета предномера.

    Эта установка может иметь, в частности, у больших каталогов координат, значительное влияние на скорость поиска. Обычно считается, что поиск по номеру и предномеру быстрее, чем поиск только по номеру.

  • Искать во всех открытых файлах

    Если этот выбор включен, то программа ищет пункты не только в активном каталоге, но и во всех открытых каталогах. Если найдено больше пунктов, отвечающих критериям, то программа изобразит их перечень в диалоговом окне и позволит Вам в них выбирать.

  • Звуковой сигнал при обнаружении

    Если пункт не найден, то программа Вас об этом известит звуковым сигналом.

Другие выборы:

  • Автоматически открыть контрольный чертеж

    Если этот выбор включен, то после первого расчета или другой задаче, которая включает контрольный чертеж, окно с контрольным чертежем будет автоматически открыто.

Исходные файлы

Если необходимо, чтобы вновь заложенные файлы имели некоторые специфические качества (установлены определенные координатные и высотные ситемы, определены использованные столбцы), то можно заложить пустой каталог координат или измерение, установить для него все требуемые качества и определить его как образцовый. Все вновь заложенные каталоги эту установку заимствуют.

  • Выбор файла (...)

    После нажатия этой кнопки можно выбрать файл, который должен быть использован как образцовый.

  • Открыть

    После нажатия этой кнопки исходный файл откроется и в него можно кносить изменения.

  • Отсоединить

    Этой командой закончим использование установленного исходного файла.

Фонты для каталогов

После нажатия этой кнопки можно установит фонт, которым написаны каталоги координат и журналы измерений на экране.

Международный :

После нажатия этой кнопки изобразится диалоговое окно с перечнем доступных модулей языков. Стандартная потребительская версия содержит только чешский модуль с кодированием 1250 Windows Latin-2.

Пред. | Начало | След.
Конец | Уровень выше | Расчеты


Расчеты
Пред. Глава 24. Диалоговое окно Установка След.

Расчеты

Здесь сосредоточены все указания, касающиеся расчетов.

Расчет порцией:

  • Использовать только обозначенные величины

    Если не желаете в расчетах порциями вычислять весь файл с измеренными данными одновременно, то обозначьте только ту часть, которую желаете расчитать и включите этот выбор. Тогда программа будет не обозначенные данные игнорировать.

  • Эдитация ориентации

    При начале расчета каждой станции программа вычисляет ориентации горизонтальных направлений, используя для этого все измеренные навправления, у которых обнаружит координаты ориентации. Если необходимо знать, которые направления программа использовала, или еще их эдитировать (пропустить и т.д.), включите этот выбор и программа Вам всегда предложит ориентации для контроля и эдитации.

    Если этот выбор выключен, то программа Вам предложит ориентации только в том случае, когда у какой-то из них превзойдена предельная поправка ориентации, установленная в Установка->Допуск.

  • Расчитать полярный метод

  • Расчитать свободные станции

  • Расчитать обратную угловую засечку

    С помощью этих переключателей можно выбрать, которые методы использовать для расчета порциями.

  • Не вычислять высоты пунктов с кодом

    Если не желаете у пунктов с определенным кодом вычислять высоты, то установите здесь соответствующий код. Если этот код является только частью всего описания пункта, то тогда еще необходимо верно установить разделитель кодов в диалоговом окне Файл->Установка->Кодирование.

Свободная станция

  • Довычислить неизвестные длины

    С помощью этого переключателя можно выбрать, если неизвестные (не измеренные) длины на свободной станции расчитать по треугольникам. Подробную информацию см. Свободная станция.

Предлагать как ориентацию:

  • Все пункты с известными координатами

    При ориентации горизонтальных направлений программа предложит как ориентации все направления, конечные пункты которых имеются в каталогах координат. При поиске программа использует параметры, установленные в Файл->Установка->Среда.

  • Пункты с атрибутом Ориентация

    При этом выборе программа предлагает как ориентации только пункты, которые имеют в журналах измерений установленный атрибут Ориентация (если были найдены в каталогах координат).

Веса направлений при их ориентации

Здесь можно выбрать, какие веса должны быть присвоены измеряемым направлениям при расчете ориентации направлений. Можно выбрать из трех предлагаемых вариантов или можем задать какое-либо отношение для расчета веса. Подробное описание см. Ориентация горизонтальных направлений.

Допуск

Здесь можно определить различные наборы допусков, которые используются в расчетах. При превышении соответствующего допуска появится диалоговое окно с достигнутой величиной, допуском и предложением выбора о том, если программа должна продолжать расчет или его прекратить. Одновременно здесь можно выбрать : с каким набором допусков программа должна далее работать.

Оставите-ли входную строку для некоторого допуска незаполненной, то это значит, что при этом расчете программа не должна превышение допуска тестировать. После инсталяции программа содержит между прочим и предопределенный набор, названный Не тестировать, в котором ни один допуск не заполнен. Если выберете как активный этот набор, то программа нигде не будет тестировать превышение допуска.

Пред. | Начало | След.
Глава 24. Диалоговое окно Установка | Уровень выше | Редукция


Редукция
Пред. Глава 24. Диалоговое окно Установка След.

Редукция

После включения этой закладки можно определить неявный предномер и редукции координат.

Редукция:

В эдитационных строчках можно задать неявный предномер и редукции координат. Если после этого не зададите предномер, напр. в расчетных диалоговых окнах, то используется неявный предномер. Редукции координат используются согласно установленного режима.

Характеристики пунктов

Здесь можно задать стандартную установку описательных данных о пунктах, которыми программа автоматически дополняет все пункты, сохраняемые в каталогах координат. Обе характеристики – это однознаковые альфанумерические данные. Их можно использовать для дальнейшего различия пунктов, для громадных обозначений и т.п.

Прибавление редукции:

Здесь можно выбрать режим работы с редукциями:

  • Интеллигентный

    Программа автоматически определяет, согласно соответствующей координаты и установленной редукции, если это координата редуцирована или нет.

  • Всегда

    Программа всегда редукцию к заданой координате.

    Важно

    Этот выбор действителен только для добавления пунктов в каталог координат.

  • Никогда

    Программа не прибавит заданную редукцию.

Пред. | Начало | След.
Расчеты | Уровень выше | Журнал


Журнал
Пред. Глава 24. Диалоговое окно Установка След.

Журнал

В этом диалоговом окне необходимо установить тип использованного журнала и другие данные.

Журнал:

  • Тип

    В зависимости от типа установленного журнала проводится конверсия измеренных данных при импорте из текстового файла. Перед импортом следует установить : откуда данные происходят.

  • Формат

    Некоторые типы журналов позволяют фиксировать данные в разных форматах Для того, чтобы программа правильно обработала данные, необходимо также установить использованный формат.

  • Пропустить строку в заглавии

    Некоторые форматы содержат заглавие, которое не должно всегда иметь одинаковое количество строк. Действительное количество строк заглавия в использованном формате должно быть установлено во входной строке.

Измеренные данные:

  • Тип длин

    Здесь необходимо установить, если длины находятся в файле, откуда будут импортированы измеренные данные, горизотальные или наклонные. Если же формат журнала позволяет автоматически распознать тип длин, то этот выбор не доступен.

  • Угловые единицы

    Здесь можно наставить, в каких угловых единицах записаны угловые данные в файлах данных, перенесенных с прибора. Угловые единицы прибора могут не соответствовать не угловым единицам, с которыми работает система GROMA.

Координаты:

  • Коэффициент X/Y/Z

    Если из журнала импортированы координаты пунктов, то при импорте программа их умножит на эти коэффициенты.

  • Заменить координаты X и Y

    При импорте программа заменит координаты X и Y.

Выбор:

  • Нулевые высоты цели

    Этот выбор включите тогда, когда необходимо, чтобы, после импорта измеренных данных, у пунктов, у которых была зарегистрирована нулевая высота цели, осталась высота цели 0.00 м. Если нулевая высота цели свидетельствует, что соответствующий пункт без высоты, то выбор следует выключить, тогда пункт после импорта будет без высоты цели, а его высота при расчетах не будет учитываться.

  • Стандартная высота цели

    Если необходимо, чтобы у каждого измерения, которое не имеет высоты цели, была явна приведена стандартная величина, то задайте эту величину высоты цели здесь.

Кодирование файла:

Если при регистрации кодов в приборе используются знаки с диакритикой в ином кодировании, чем Windows 1250, то выберите тот тип кодирования, который бы система GROMA могла правильно перевести.

Пред. | Начало | След.
Редукция | Уровень выше | Теодолит


Теодолит
Пред. Глава 24. Диалоговое окно Установка След.

Теодолит

Эта команда служит для выбора теодолита, его приборных ошибок и допусков.

Название теодилита:

Во входном окне задайте название, под которым теодолит должен появиться в перечне теодолитов. В перечне не могут быть два теодолита с одинаковым названием.

Средние квадратические ошибки:

Здесь задайте оценку ср. кв. ошибки измеренного направления при одном положении круга и оценку ср. кв. ошибки измеренной длины.

Важно

Априорные ср. кв. ошибки, которые гарантирует производитель приборов, могут относиться к некоторым специальным ситуациям, а для обычных измерений они слишко оптимистичны. Перед заданием необходимо по возможности убедиться о их реальности.

Коллимационная ошибка:

Здесь установите действительную коллимационную ошибку теодолита и допуск при ее поверке. При обработке журнала программа может обнаружить измерения при двух положениях круга, определить по ним значение коллимационной ошибки и сравнить его с установленной величиной. Если разность установленной и вычисленной ошибки превысит установленную как Ошибочная, то в ведомости измерение обозначится как ошибочное и расчет уравненного измерения не произойдет. Если разность превысит установленную величину как Подозрительная, то расчет произойдет, но направления будут обозначены в ведомости как подозрительные.

Программа сравнивает с допусками разность установленной и вычисленной коллимационной ошибки, но не всю вычисленную ошибку. Фактическая коллимационная ошибка может иметь любое значение и не надо устанавливать допуски с учетом ее значения.

Важно

Установленное значение коллимационной ошибки не используется для исправления измерений, а только для контроля допусков. При расчете журнала фактическая коллимационная ошибка устраняется использованием измерений при левом и правом кругах.

Ошибка места нуля:

Здесь установим фактическую ошибку места нуля теодолита и допуск для ее контроля. При обработке журнала программа может обнаружить измерения при двух положениях круга, определить по ним значение места нуля и сравнить его с установленной величиной. Если разность установленной и вычисленной ошибки превысит установленную величину как Ошибочная, то в ведомости измерение обозначится как ошибочное и расчет уравненного измерения не произойдет. Если разность превысит установленную величину как Подозрительная, то расчет произойдет, но измерения будут обозначены в ведомости как подозрительные.

Программа сравнивает с допусками разность установленного и вычисленного места нуля, но не всю вычисленную ошибку. Фактическое место нуля может иметь любое значение и нет необходимости устанавливать допуск в зависимости от его величины.

Важно

Установленная величина места нуля используется только при исправлении места нуля. При расчете уравненных измерений из результатов измерений при левом и правом круге фактическое место нуля устраняется, а установленное значение места нуля используется только для контроля допусков.

Пред. | Начало | След.
Журнал | Уровень выше | Кодирование пунктов


Кодирование пунктов
Пред. Глава 24. Диалоговое окно Установка След.

Кодирование пунктов

В этом диалоговом окне устанавливают параметры, которые касаются кодирование пунктов.

Кодирующая таблица:

Программа позволяет использовать т.н. кодирующую таблицу, которая служит для перевода зарегистрированных пунктов на описания.

  • Присоединить

    Этой кнопкой можно выбрать необходимую кодирующую таблицу (файлы типа .cod) и присоединить ее. От момента присоединения программа трансформирует все коды в каталогах согласно таблицы.

  • Эдитировать

    Эдитировать можно присоединенной кодирующей таблицей.

  • Отсоединить

    Если присоединенная кодирующая таблица уже не нужна, то ее можно этой кнопкой отключить.

  • Использовать кодирующую таблицу

    С помощью этого переключателя можно удобно включать и переключать перекодирование пунктов согласно таблицы, без необходимости ее присоединять и отсоединять.

    Эта функция доступна непосредственно с панели средств.

Установка:

  • Разделить коды на части

    С помощью этой установки можно разделить код пункта на части после задания количества знаков. Напр. код 23014512 при включении этого выбора и установке разделения по два знака будет разделен на 23 01 45 12. Частичные коды будут отделены первым знаком, который приведен в Отделителях кодов (см. далее).

  • Перекодировать при импорте

    В импортированных файлах программа переводит описания на коды после присоединения кодирующей таблицы. Если описание в кодирующей таблице не найдено, то изобразится ошибочное объявление.

  • Акцептировать пункты без кодов

    Если этот выбор включен, то программа позволяет импорт пунктов без кодов или описания, если выключен, то программа изобразит ошибочное объявление.

  • Отделители кодов

    Если у пунктов зарегистрировано больше кодов, то они должны быть отделены разделительным знаком (напр. "X"). Разделительный знак должен быть установлен в этой входной строке.

  • Код ориентации

    Если ориентации обозначаются кодом, то здесь этот код можно задать, а программа при импорте автоматически обозначит как ориентации все измерения, имеющие этот код. Если для обозначения ориентации используется больше кодов, то здесь их можно задать все, разделив знаком, установленным как Отделитель кодов.

Пред. | Начало | След.
Теодолит | Уровень выше | Ведомость


Ведомость
Пред. Глава 24. Диалоговое окно Установка След.

Ведомость

После включения этой закладки можно установить некоторые параметры для работы с ведомостями.

Кодовая страница:

Программа GROMA работает с ведомостью не только с кодированием Windows Latin-2 (кодовая страница 1250), но также с кодированием Windows CZ. В текстовом файле ведомость можно сохранять и с другим кодированием, что может быть выгодно для дальнейшей обработки ведомости, напр. текстовым эдитором. При чтении протокол автоматически переводится опять на кодирование Windows Latin-2. Программа предлагает следующие кодовые страницы:

  • 437 DOS Standard IBM,

  • 850 DOS Kamenicky (KEYBCS2),

  • 852 DOS Latin-2,

  • 1250 Windows Latin-2

Внимание

Перекодирование на кодовую страницу 437 невозвратимо, потому-что при записи все чешские буквы переводятся на эквиваленты без диакритических знаков. При следующем открытии файл с ведомостью содержит только стандартные ASCII знаки.

Выбор:

  • Создать ведомость

    Этим переключателем можно включить или выключить создание локальной ведомости. Ведомость сохраняется в памяти, а при некоторых массовых расчетах (напр. при расчете группами большого файла измерений) может достичь значительной величины. Более того, ее создание несколько замедляется. В некоторых случаях было бы целесообразно ведомость временно выключить.

  • Автоматическая запись ведомости

    Если этот выбор включен, то программа автоматически запишет ведомость на диск всегда, когда в нее придана локальная ведомость. Более того, она автоматически сохранит ведомость на диске после окончания программы. Если этот выбор не включен, то перед окончанием программы появится предупреждающее объявление с вопросом, если ведомость следует сохранить.

  • Сохранить координаты исходных пунктов

    Если этот выбор включен, то в ведомость записываются координаты исходных пунктов.

  • Записать пункты вычисленные группами

    Если этот выбор включен, то при расчете порциями программа сохранит в ведомости информацию о всех вычисленных пунктах. Если этот выбор выключен, то в ведомости сохранены только информации о ориентации горизонтальных направлений, о расчете свободных станций и о обратной угловой засечке.

Фонт для экрана / для печати

После нажатия этих кнопок можно установить фонт, с помощью которого ведомость изобразится на экране, и фонт, с помощью которого ведомость будет отпечатана на принтере.

Пред. | Начало | След.
Кодирование пунктов | Уровень выше | Вход/Выход


Вход/Выход
Пред. Глава 24. Диалоговое окно Установка След.

Вход/Выход

После включения этой закладки задаются параметры для входа и выхода величин (единицы, количество десятичных долей и т.п.).

Количество десятичных долей:

В этих входных строках задается требуемое количество десятичных долей для выхода координат, углов, длин, высот и площадей.

Угловые единицы:

Единицы, которыми задаются и записываюся угловые данные. Вне зависимости на установку угол всегда записывается как число с десятичными долями. При установке на градусы, первые две цифры за точкой – десятки минут и минуты, потом следуют десятки секунд и секунды и т.п.

Единицы длины:

Можно выбирать между метрами и стопами.

Номера пунктов

Здесь можно определить, каким способом в каталогах должны изображаться номера пунктов:

  • Количество цифр

    Максимальное количество цифр полного номера пункта.

  • Номера дополнить нулями

    Если включен этот выбор, то номера пунктов будут дополнены слева нулями на полное количество цифр, установленных в окне Количество цифр.

  • Полные номера в каталогах

    После включения этого выбора программа будет изображать в каталогах целые полные номера пунктов вместо разделения их на номера и предномера.

Масштабный коэффициент для перевода длин на плоскость изображения:

На этот коэффициент перемножены все длины, участвующие в программе, причем сразу после импорта измеренных данных или при задавании длин. Наоборот все выписываемые длины (напр. при расчете разбивочных элементов) на этот коэффициент разделены.

Сохранение пунктов в каталогах координат

  • Автоматически переносить пункты в управляющую аппликацию

    После включения этого выбора система GROMA, если запущена в рамках какой-либо управляющей аппликации (напр. MicroStation), будет автоматически посылать в управляющую аппликацию все пункты, сохраняемые в каталоге координат. Эти пункты будут автоматически создаваться на чертеже управляющей аппликации.

  • Округление координат согласно заданного количества десятичных долей

    Если этот выбор включен, то координаты всех пунктов, сохраняемых в каталоге координат, будут автоматически округляться согласно установленного количества десятичных долей.

Пред. | Начало | След.
Ведомость | Уровень выше | Входной / выходной формат координат


Входной / выходной формат координат
Пред. Глава 24. Диалоговое окно Установка След.

Входной / выходной формат координат

После включения этой закладки можно определить или эдитировать входной/выходной форматы координат для записи и чтения из текстового файла. Последовательность действий при определении входного/выходного форматов подробно описана в приложении.

Пред. | Начало | След.
Вход/Выход | Уровень выше | Входной / выходной формат измерений


Входной / выходной формат измерений
Пред. Глава 24. Диалоговое окно Установка След.

Входной / выходной формат измерений

Аналогично, как и у координат, здесь также можно определить или эдитировать входной/выходной форматы измеренных величин для записи и чтения из текстового файла. Последовательность действий при определении входного/выходного форматов подробно описана в приложении.

Пред. | Начало | След.
Входной / выходной формат координат | Уровень выше | DXF


DXF
Пред. Глава 24. Диалоговое окно Установка След.

DXF

Здесь можно установить параметры для записи графического файла в файл в формате DXF. В файл DXF записываются элементы в зависимости от установленных параметров изображения. Элементы, которые сохранены в выключенных слоях (т.е. элементы, которые в активном окне не видны), не будут в файле DXF сохранены.

Головка:

Этой кнопкой можно включить сохранение головки в DXF файле. В головке сохраняются информации о слоях, которые для некоторых программ необходимы (напр. для MicroStation, который, если головку не найдет, разместит все элементы в слой 1).

Заменить координаты X и Y:

Включите-ли этот выбор, то программа GROMA при экспорте заменит координаты X и Y (для некоторых систем это объязательно для верного размещения координатных осей).

3D:

Этой кнопкой можно включить экспорт пунктов с тремя координатами для обработки трехразмерной графической системой. Если этот выбор выключен, то высота экспортируется как текстовое описание.

Редуцировать:

Если включите этот выбор, то координаты при экспорте редуцыруются на рудукцию, установленную в Файл->Установка->Редукция.

Коэффициент X/Y/Z:

Здесь можно установить коэффициенты, на которые при выходе умножаются соответчтвующие кординаты. Для координатной системы, с которой работает большинство CAD систем, необходимо, для верного размещения координатных осей, установить коэффициенты для X и Y на величину –1.

Высота текста:

Здесь можно установить требуемую высоту текста. Высота задается действительной величиной в метрах (напр. для изображения знаков высотой 2 мм в масштабе 1:1000 необходимо установить 2 м).

Фонт для номеров пунктов/ для высот:

Если необходимо, чтобы файл DXF содержал у текстовых элементов название фонта, то можно его здесь задать. Если эти входные строки оставите пустыми, то позиция с названием фонта не будет в файле DXF занята.

Пред. | Начало | След.
Входной / выходной формат измерений | Уровень выше | Глава 25. Меню Расчеты


Глава 25. Меню Расчеты
Пред. Часть II. Руководство по применению След.

Глава 25. Меню Расчеты

Это меню содержит предложения по всех расчетных функциях, которые программа GROMA предоставляет.

Все расчетные функции можно вызвать с помощью панели средств, которая изображена в верхней части главного окна программы.

Расчетные функции подробно описаны в самостоятельной главе Руководства по применению.

Пред. | Начало | След.
DXF | Уровень выше | Глава 26. Меню Окно


Глава 26. Меню Окно
Пред. Часть II. Руководство по применению След.

Глава 26. Меню Окно

Позиции этого меню служат для манипуляции с открытыми окнами.

Закрой

Этой командой можно закрыть актуальное окно. Разговор идет о каталоге координат или о журнале измеренных величин и, если это окно является последним открытым окном соответствующего каталога, то программа автоматически запишет на диск и актуализированный индексовый файл.

Пред. | Начало | След.
Глава 25. Меню Расчеты | Уровень выше | Мозаика горизонтально – вертикально


Мозаика горизонтально – вертикально
Пред. Глава 26. Меню Окно След.

Мозаика горизонтально – вертикально

Окна будут расположены на экране так, чтобы не перекрывались, т.е. будут расположены горизонтально или вертикально возле себя.

Пред. | Начало | След.
Глава 26. Меню Окно | Уровень выше | Каскад


Каскад
Пред. Глава 26. Меню Окно След.

Каскад

Окна будут перекрываться так, чтобы у каждого окна был виден хотя бы один угол.

Пред. | Начало | След.
Мозаика горизонтально – вертикально | Уровень выше | Выравнивание икон


Выравнивание икон
Пред. Глава 26. Меню Окно След.

Выравнивание икон

Если некоторые окна минимализированы, т.е. изображены как иконы на рабочей площади экрана, то этой командой их можно выравнять по нижнему краю иконы.

Чтобы эта команда работала, необходимо, чтобы одна из икон была выбрана как активное окно.

Пред. | Начало | След.
Каскад | Уровень выше | Параметры изображения


Параметры изображения
Пред. Глава 26. Меню Окно След.

Параметры изображения

В этом диалоговом окне можно установить разные параметры для изображения данных. Возможности установки зависят от типа окна:

  • Каталог координат

  • Журнал измерений

  • Чертеж

Пред. | Начало | След.
Выравнивание икон | Уровень выше | Глава 27. Меню Эдитация


Глава 27. Меню Эдитация
Пред. Часть II. Руководство по применению След.

Глава 27. Меню Эдитация

Это меню содержит команды для эдитации каталогов. При копировании и переносе в ячейку программа использует формат, определенный в Файл->Установка->Входной/выходной формат координат или в Файл->Установка->Входной/выходной формат измерения . Если никакой формат не определен, то программа создаст стандартный формат.

Шаг назад

С помощью этой команды можно возвратить назад последнюю операцию в каталоге координат или журналы измерений.

Пред. | Начало | След.
Параметры изображения | Уровень выше | Перенеси


Перенеси
Пред. Глава 27. Меню Эдитация След.

Перенеси

Команда служит для перенесения данных из каталога в ячейку памяти данные в каталоге смазаны). Если в каталоге ничего не обозначено, то программа выполнит перенос актуальной позиции (позиции, на которой в данный момент находится курсор). Если некоторые позиции обозначены, то программа перенесет их.

Пред. | Начало | След.
Глава 27. Меню Эдитация | Уровень выше | Скопируй


Скопируй
Пред. Глава 27. Меню Эдитация След.

Скопируй

Эта команда работает аналогично, как команда Перенеси, но лишь с той разницей, что все данные только скопированы (в каталоге остаются).

Пред. | Начало | След.
Перенеси | Уровень выше | Вложи


Вложи
Пред. Глава 27. Меню Эдитация След.

Вложи

С помощью этой команды можно вложит в каталог данные с ячейки. В каталоге координат пункты расположены согласно номеров. В журнале измерений они вложены перед позицией, обозначенной курсором.

Пред. | Начало | След.
Скопируй | Уровень выше | Смазать


Смазать
Пред. Глава 27. Меню Эдитация След.

Смазать

Эта команда служит для отстранения выбранной позиции или обозначенных позиций из каталога.

Пред. | Начало | След.
Вложи | Уровень выше | Глава 28. Меню Проект


Глава 28. Меню Проект
Пред. Часть II. Руководство по применению След.

Глава 28. Меню Проект

Это меню содержит команды для работы с проектами.

Добавь файл

Этой командой можно добавить файлы в активный проект. После включения команды изобразится диалоговое окно, в котором изображены названия всех открытых файлов, которые не включены в проект. В нем можно обозначить один или более файлов, которые после нажатия кнопки (OK) будут добавлены в проект.

Каталоги координат и журналы измерений можно добавить в проект и обычным перетягиванием мышью.

Пред. | Начало | След.
Смазать | Уровень выше | Отбери файл


Отбери файл
Пред. Глава 28. Меню Проект След.

Отбери файл

Этой командой можно отобрать файл из активного проекта. Сначала его необходимо обозначить в окне с проектом.

Файл будет только выпущен из проекта, но на диске останется без изменений.

Пред. | Начало | След.
Глава 28. Меню Проект | Уровень выше | Открой файл


Открой файл
Пред. Глава 28. Меню Проект След.

Открой файл

Этой командой можно открыть файл в активном проекте. Сначала его необходимо обозначить в окне с проектом.

Файл можно открыть также двойным щелчком по его названию в окне с проектом.

Пред. | Начало | След.
Отбери файл | Уровень выше | Установка


Установка
Пред. Глава 28. Меню Проект След.

Установка

В этом диалоговом окне можно установить первую строку головки печати для каталогов координат и журналов измерений.

Пред. | Начало | След.
Открой файл | Уровень выше | Глава 29. Меню Координаты / Измерения


Глава 29. Меню Координаты / Измерения
Пред. Часть II. Руководство по применению След.

Глава 29. Меню Координаты / Измерения

Добавь позицию

Этой командой можно добавить позицию в каталоги координат и журналы измеренных величин. После его включения программа изобразит соотвветствующее эдитационное окно, в котором можно определить необходимые величины.

Пред. | Начало | След.
Установка | Уровень выше | Отстрани позицию


Отстрани позицию
Пред. Глава 29. Меню Координаты / Измерения След.

Отстрани позицию

Этой командой можно отстранить позицию из каталога. Если в каталоге некоторые позиции обозначены, то программа их отстранит. Если ни одна позиция не обозначена, то программа смажет ту позицию, на которой размещен курсор.

Пред. | Начало | След.
Глава 29. Меню Координаты / Измерения | Уровень выше | Эдитируй позицию


Эдитируй позицию
Пред. Глава 29. Меню Координаты / Измерения След.

Эдитируй позицию

После включения этой команды изобразится диалоговое окно для эдитации позиции, на которой находится курсор. Эдитацию можно включить также двойным щелчком мышью по любой позиции каталога.

Пред. | Начало | След.
Отстрани позицию | Уровень выше | Найди позицию


Найди позицию
Пред. Глава 29. Меню Координаты / Измерения След.

Найди позицию

После включения этой команды в левом нижнем углу экрана появится небольшое для поиска позиции диалоговое окно. Записываете-ли в нем номер пункта или эдитируем, программа автоматически разместит курсор на первом обнаруженном пункте с данным номером. Если необходимо найти следующий пункт с данным номером, то нажмите клавишу <Стрелка Вниз>.

Пред. | Начало | След.
Эдитируй позицию | Уровень выше | Обозначь


Обозначь
Пред. Глава 29. Меню Координаты / Измерения След.

Обозначь

После включения этого выбора, программа изобразит диалоговое окно , которое служит для обозначения позиций в каталоге согласно заданных критерий.

Можно выбрать, чтобы позиции, которые отвечают критериям, были добавлены к ранее обозначенным или отобраны от них, либо, чтобы это было новое обозначение.

Способ обозначения подробно описан в Руководстве по применению.

Пред. | Начало | След.
Найди позицию | Уровень выше | Массовые изменения


Массовые изменения
Пред. Глава 29. Меню Координаты / Измерения След.

Массовые изменения

После включения этой команды изобразится диалоговое окно, которое позволит выполнять массовые изменения в каталогах координат и журналах измерений. С помощью этого окна можно изменять предномер пунктов, устанавливать код пунктов, добавлять и отнимать константы от отдельных данных, умножать или делить отдельные данные на константы и т.п.

Массовые изменения подробно описаны в Руководстве по применению.

Пред. | Начало | След.
Обозначь | Уровень выше | Перенумерация каталога


Перенумерация каталога
Пред. Глава 29. Меню Координаты / Измерения След.

Перенумерация каталога

Этой командой открывается немодальное диалоговое окно, с помощью которого можно выполнить перенумерацию каталога координат или журнала измерений. Для этого задайте входной файл, а при перенумерации координат и выходной файл (координаты можно перенумеровать только в новом файле), предномер и начальный номер. Для журнала измерений можно также выбрать перенумерацию ориентаций или станций. После нажатия кнопки (Перенумеровать) пункты будут перенумерованы и изобразится ведомость о перенумерации.

Последовательность действий при перенумерации подробно описана в Руководстве по применению.

Пред. | Начало | След.
Массовые изменения | Уровень выше | Перекодирование согласно таблицы


Перекодирование согласно таблицы
Пред. Глава 29. Меню Координаты / Измерения След.

Перекодирование согласно таблицы

С помощью этой команды в файл данных можно перенести на место кодов описания согласно установленной кодирующей таблицы (описания, которые изображены на экране). При сохранении описания будут обрезаны на максимальную длину 20 знаков.

Пред. | Начало | След.
Перенумерация каталога | Уровень выше | Восстановление смазанных позиций


Восстановление смазанных позиций
Пред. Глава 29. Меню Координаты / Измерения След.

Восстановление смазанных позиций

При отстранении программа изобразит отдельные позиции в файле данных как смазанные, но физически данные в файле остаются. Отстраняются они аж при компрессии файла. В случае, если некоторые позиции были смазаны, но позже их необходимо опять восстановить, но при этом нельзя использовать функцию Шаг назад (файл был тем временем закрыт, индексирован и т.д.), то используют эту функцию. Позиции восстановлены всегда в новый файл, который автоматически создан (при восстановлении обычно возникают неконсистентные данные – пункты-дубликаты, измеренные пункты без головки станции и т.п.). Из этого файла можно скопировать необходимые данные в какой-либо другой файл.

Пред. | Начало | След.
Перекодирование согласно таблицы | Уровень выше | В ведомость


В ведомость
Пред. Глава 29. Меню Координаты / Измерения След.

В ведомость

Этой командой каталог координат записывается в ведомость. Если в каталоге обозначены некоторые позиции, то только они и записываются в ведомость, во всех других случаях записывается весь каталог координат. Координаты можно также записать в ведомость с помощью ячейки (в главное окно с ведомостью) или перетягиванием мышью (в диалоговое окно с локальной ведомостью).

Пред. | Начало | След.
Восстановление смазанных позиций | Уровень выше | Глава 30. Меню Координаты


Глава 30. Меню Координаты
Пред. Часть II. Руководство по применению След.

Глава 30. Меню Координаты

Изобрази графически

После включения этой команды изобразится окно с графической репрезентацией соответствующего файла координат. Если графический файл .pic существует, то автоматически открывается. Если этот файл не существует, то программа Вас об этом известит.

Пред. | Начало | След.
В ведомость | Уровень выше | Группировка согласно листов карты (плана)/


Группировка согласно листов карты (плана)/
Пред. Глава 30. Меню Координаты След.

Группировка согласно листов карты (плана)/

Этой командой открывается диалоговое окно, которое служит к группированию активного каталога координат на файлы согласно листов карты. Здесь можно задать масштаб листов карты и выбрать какими должны быть генерированы названия файлов, длинными или классическими, состоящими из восьми знаков. Можно также выбрать, чтобы созданные файлы автоматически открывались или, чтобы существующие старые файлы переписывались без предупреждения. После нажатия кнопки (Использовать) актуализируется перечень использованных листов карты, а после нажатия кнопки (Сгруппировать) файлы с координатами запишутся на диск.

Пред. | Начало | След.
Глава 30. Меню Координаты | Уровень выше | Сравнение каталогов координат


Сравнение каталогов координат
Пред. Глава 30. Меню Координаты След.

Сравнение каталогов координат

После включения этой функции изобразится диалоговое окно, которое служит для статистического сравнения двух каталогов координат. Тест выполняется согласно отношений, описанных в Положении № 190/1996 Sb. Прежде всего вычисляются невязки по осям координат

dx = xm - xk, dy = ym - yk,

где xm, ym - координаты из тестируемого файла, a xk, yk - координаты из контрольного исходного файла.

По этим невязкам вычисляется абсолютная линейная невязка

dp = (dx2 + dy2)1/2

и дирекционный угол этой невязки.

Далее вычисляется средняя плановая невязка по формуле

up = [0.5 (dx2 + dy2)]1/2

Для всего обрабатываемого файла вычислены ср. кв. ошибки координат

sx = [suma(dx2/(k . N))]1/2, sy = [suma(dy2/(k . N))]1/2,

где коэффициент k может иметь значения

  • k=1, если точность контрольного файла значительно выше, чем точность тестированного файла, или

  • k=2, если точность обеих файлов сопоставима.

Cр. кв. ошибка группы выбранных координат

Sxy = (0.5 (sx2 + sy2))1/2

В конечной статистике также записано, сколько процентов пунктов имеет uxy меньше, чем требуемое Uxy, (должно быть хотя бы 60%) у скольких процентов пунктов uxy было в интервале (Uxy, 2Uxy и у скольких процентов пунктов 2Uxy превышена.

Пред. | Начало | След.
Группировка согласно листов карты (плана)/ | Уровень выше | Контроль номеров-дубликатов


Контроль номеров-дубликатов
Пред. Глава 30. Меню Координаты След.

Контроль номеров-дубликатов

После включения этой команды будет сконтролирован актуальный каталог координат, если не содержит номера-дубликаты. Результат теста с возможным списком номеров-дубликатов будет записан в ведомость. Этот тест выполняется автоматически и при индексировании файла.

Пред. | Начало | След.
Сравнение каталогов координат | Уровень выше | Контроль нумерации пунктов


Контроль нумерации пунктов
Пред. Глава 30. Меню Координаты След.

Контроль нумерации пунктов

После включения этой команды будет проконтролирована последовательность нумерации пунктов каталога. В ведомость будет записан перечень зависимых блоков номеров.

Пред. | Начало | След.
Контроль номеров-дубликатов | Уровень выше | Отстранение идентических пунктов


Отстранение идентических пунктов
Пред. Глава 30. Меню Координаты След.

Отстранение идентических пунктов

С включением этой команды изобразится диалоговое окно, которое служит для поиска или для отстранения идентических пунктов, которые имеют разные номера, но идентические или близкие координаты.

В окне задается название тестированного файла и допуск (предельная разность в координате), который определяет, когда пункты должны считаться идентическими.

Если включите выбор Только в ведомость, то программа запишет перечень идентических пунктов в ведомость, но тестированный файл оставит без изменений. Если этот выбор выключен, то программа, в соответствии с установкой, один из идентических пунктов из перечня отстранит. Можно выбрать, чтобы в перечне остался пункт с меньшим номером или с меньшим предномером.

Если включите команду Игнорировать высоту, то программа будет контролировать идентичность только по координатам X и Y, а аппликата Z будет при тестировании игнорирована.

Пред. | Начало | След.
Контроль нумерации пунктов | Уровень выше | Округление координат


Округление координат
Пред. Глава 30. Меню Координаты След.

Округление координат

Эта команда служит для массового округления координат в выбранном каталоге. Можно выбрать, которые координаты округлить и на сколько десятинных знаков. Округлить можно весь каталог или только обозначенные позиции.

Пред. | Начало | След.
Отстранение идентических пунктов | Уровень выше | Координаты в двух системах


Координаты в двух системах
Пред. Глава 30. Меню Координаты След.

Координаты в двух системах

Это диалоговое окно служит для работы с координатами в двух системах в каталогах.

В области Файлы необходимо задать координатный файл, а для некоторых функций также дополнительный файл. Файлы выбирают перетягиванием мышью в соответствующее окно или после нажатия кнопки (...).

Импорт из дополнительного файла

Эта функция служит для дополнения второй пары координат из дополнительного файла. После включения этой функции программа попытается подобрать для всех пунктов основного файла координаты в дополнительном файле. Если найдет, то дополнит их в основной файл как вторые.

Заменить главные и вспомогательные координаты

После нажатия этой кнопки программа заменит в основном каталоге координат главные и вспомогательные координаты. Если необходимо в расчетах вместо главных координат использовать вспомогательные, то необходимо сначала координаты с помощью этой команды заменить.

Экспортировать вспомогательные координаты в новый файл

После нажатия этой кнопки программа заложит новый каталог координат без названия и скопирует в него все вспомогательные координаты из основного каталога. Во вновь созданном каталоге имеются координаты, сохраненные как главные.

Отстранить вспомогательные координаты

После нажатия этой кнопки программа отстранит из основного каталога координат все вспомогательные координаты.

Отстранить нулевые вспомогательные координаты

После нажатия этой кнопки программа отстранит из основного каталога координат те вспомогательные координаты, оба значения которых равны нулю.

Пред. | Начало | След.
Округление координат | Уровень выше | Параметры изображения


Параметры изображения
Пред. Глава 30. Меню Координаты След.

Параметры изображения

Если некоторые данные, показанные в каталогах, не используются (напр. тип пункта, высота и т.п.), то можно с помощью этой команды соответствующие столбики выключить. Эту команду можно также включить щелкнув правой кнопкой мыши по заглавию каталога (но не на цветное заглавие с названием файла, а на первую строку с головками столбцов). Установка показанных данных респектируется и при печати.

Пред. | Начало | След.
Координаты в двух системах | Уровень выше | Глава 31. Меню Измерения


Глава 31. Меню Измерения
Пред. Часть II. Руководство по применению След.

Глава 31. Меню Измерения

Обработка журнала

С помощью этой команды можно выполнить комплексную обработку журнала, включая обработку измерений при двух положениях круга, обработку повторных измерений, редукцию направлений, обработку двухсторонних измерений линий, вычисления поправок за ошибки приборов и за рефракцию, вычисления превышений. Включите-ли команду Только в ведомость, то создастся только ведомость, а изменения в журналах измерений не производятся.

Подробно обработка журнала описана в Руководстве по применению.

Пред. | Начало | След.
Параметры изображения | Уровень выше | Соединение станций


Соединение станций
Пред. Глава 31. Меню Измерения След.

Соединение станций

После включения этой команды изобразится диалоговое окно, которое позволяет соединить повторные измерения на одной станции. Измерения можно соединить только в том случае, если они содержать хотя-бы одно общее направление, через которое и можно соединить оба исходных направления.

Сначала программа сгруппирует весь файл согласно станций. Потом ищет в нем повторяющиеся сстанции. Если такие станции найдет, то изобразит каталог общих горизонтальных направлений с поправками. Отдельные направления из этого каталога можно выпустить с помощью кнопки (Отстранить). После нажатия кнопки (OK), программа выполнит расчет сдвига обеих исходных направлений, соединит их и исправит все измеренные направления на величину сдвига.

Важно

Если при обеих измерениях приведена высота прибора, то исходные направления можно соединить только тогда, если высоты одинаковы. Если они различаются, то можно для их отождествления при обработке журнала использовать команду Редуцировать превышения на соединяющую закрепленные знаки.

Пред. | Начало | След.
Глава 31. Меню Измерения | Уровень выше | Обозначь ориентации


Обозначь ориентации
Пред. Глава 31. Меню Измерения След.

Обозначь ориентации

С помощью этого диалогового окна можно массово обозначить ориентации. В диалоговом окне можно установить критерии, с помощью которых ориентации идентифицируются.

Подробно обозначение ориентаций описано в руковостве по применению.

Пред. | Начало | След.
Соединение станций | Уровень выше | Группирование


Группирование
Пред. Глава 31. Меню Измерения След.

Группирование

С помощью этой команды можно сгруппировать журнал измерений.

  • Сгруппировать станции

    Программа сгруппирует файл по нарастающей согласно станций.

  • Сгруппировать согласно номеров

    Программа сгруппирует измеренные пункты на станциях согласно их номеров.

  • Orientace na zacatek

    Программа передвинет ориентации на начало станций, перед пикетами и не будет учитывать их номера.

Пред. | Начало | След.
Обозначь ориентации | Уровень выше | Присоедини файл


Присоедини файл
Пред. Глава 31. Меню Измерения След.

Присоедини файл

С помощью этой команды можно к открытому журналу измерений присоединить другой журнал измерений.

Файл измерений будет вложен на ту позицию, на которой находится курсор.

Пред. | Начало | След.
Группирование | Уровень выше | Параметры изображения


Параметры изображения
Пред. Глава 31. Меню Измерения След.

Параметры изображения

Если некоторые данные, которые имеются в журналах измерений, не используются (напр. зенитное расстояние, высота сигнала и т.п.), то с помощью этой команды можно соответствующик столбики выключить. Команду можно также включить щелкнув правой кнопкой мыши по заглавию журнала (но не на цветное заглавие с названием файла, а на первую строку с головками столбцов). Установка показанных данных респектируется и при печати.

В этом окне можно также выбрать деталь изображения измерений:

  • Все

    Будут показаны все измерения в файле.

  • Станции + ориентации

    Будут показаны только заглавия станций и измерения, обозначенные как ориентации.

  • Станции

    Будут изображены только заглавия станций.

Этим способом изменится тип изображения для всего файла. Для отдельных станций можно изменять тип изображения щелкнув мышью на икону, которая находится в левой части записей на строке с головкой станции.

Пред. | Начало | След.
Присоедини файл | Уровень выше | Глава 32. Меню План


Глава 32. Меню План
Пред. Часть II. Руководство по применению След.

Глава 32. Меню План

Команды этого меню служат для манипуляции с графическим окном.

Параметры изображения

В этом диалоговом окне устанавливаются атрибуты чертежа (включенныые слои, фонты и т.п.).

Слои:

  • Активный слой

    Во входной строке или с помощью следующего диалогового окна установите номер слоя, в который будете вкладывать вычерченные элементы.

  • Включенные слои

    В диалоговом окне выберите слои, которые должны быть включены при актуальном взгляде (т.е. видимы).

Пункты:

  • Поместить в слой

    Выберите, в который слой хотите постистить условные знаки пунктов (вычерчивание пунктов потом включаете/выключаете с помощью соответствующего слоя).

  • Изображать только обозначенные

    Если каталог координат большой, а Вы работаете только с его частью, то можно соответствующие пункты обозначить и установить, чтобы показывались только обозначенные пункты. Перечерчивание графического окна может этим значительно ускориться.

  • Условный знак

    Выберите условный знак, которым будут обозначены пункты. Знаки для всех пунктов одинаковы.

Номера пунктов:

  • Поместить в слой

    Выберите номер слоя, в который хотите поместить номера пунктов. Если не хотите их показывать, то можно соответствующий слой выключить.

  • Фонт

    Выберите фонт, с помощью которого будут показаны номера пунктов.

  • Только номера

    Программа будет показывать только собственный номер пункта без предномера.

  • Номера и предномера

    Программа будет показывать полные номера пунктов.

Высоты пунктов:

  • Поместить в слой

    Выберите номер слоя, в который желаете поместить высоты пунктов. Если не хотите их показывать, то можно соответствующий слой выключить.

  • Фонт

    Выберите фонт, с помощью которого должны показываться высоты пунктов.

Координатная сетка:

  • Расстояние между крестами сетки

    В эдитационном окне можно установить расстояние между крестами координатной сетки в метрах.

  • Размеры крестов

    Здесь можно определить величину крестов на плане (в миллиметрах).

  • Поместить в слой

    Выберите число слоя, в который хотите поместить кресты координатной сетки. Если не желаете их изображать, то необходимо соответствующий слой выключить.

Пред. | Начало | След.
Параметры изображения | Уровень выше | Изображение


Изображение
Пред. Глава 32. Меню План След.

Изображение

Масштаб изображения подбирается так, чтобы план был выден в окне весь сразу.

Пред. | Начало | След.
Глава 32. Меню План | Уровень выше | Увеличить


Увеличить
Пред. Глава 32. Меню План След.

Увеличить

Масштаб изображения в 1.5x увеличен.

Пред. | Начало | След.
Изображение | Уровень выше | Уменьшить


Уменьшить
Пред. Глава 32. Меню План След.

Уменьшить

Масштаб изображения в 1.5x уменьшен.

Пред. | Начало | След.
Увеличить | Уровень выше | Перечерти


Перечерти
Пред. Глава 32. Меню План След.

Перечерти

Актуальное окно будет перечерчено.

Пред. | Начало | След.
Уменьшить | Уровень выше | Вырез


Вырез
Пред. Глава 32. Меню План След.

Вырез

Содержание ограничения увеличивается на всю площадь окна. Если ограничение еще не создано, то можно после включения этой команды ее создать. Поместите курсор на один угол требуемого выреза, нажмите левую кнопку мыши и не отпуская ее переместите курсор на другой угол. Там левую кнопку мыши отпустите.

Пред. | Начало | След.
Перечерти | Уровень выше | Выбор элементов


Выбор элементов
Пред. Глава 32. Меню План След.

Выбор элементов

Этой командой отменим предыдущий режим (черчение, отстранение элементов и т.п.). Режим выбора элементов пригоден для показа пунктов в расчетных диалоговых окнах.

Пред. | Начало | След.
Вырез | Уровень выше | Отстранение элементов


Отстранение элементов
Пред. Глава 32. Меню План След.

Отстранение элементов

После включения этой команды (если не обозначен ни один элемент) изобразится курсор с вопросительным знаком. Когда с помощью левой или средней кнопки мыши обозначите элемент, который необходимо отстранить, то курсор мыши изменится. Если элемент действительно необходимо отстранить, то нажмите левую кнопку, а если нет, то - правую.

Пред. | Начало | След.
Выбор элементов | Уровень выше | Соединение пунктов


Соединение пунктов
Пред. Глава 32. Меню План След.

Соединение пунктов

Соединять можно только существующие пункты, так как конец линии нельзя поместить мимо пункт. Не нужно беспокоиться о верной "зацепке за пункт", так как программа иное размещение линий не позволяет. После зацепки за пункт программа начнет чертить линию от пункта к мгновенной позиции курсора. При передвижении курсора линия автоматически изменяется. После зацепки линии за конечный пункт, окончите черчение нажатием правой кнопки мыши.

Пред. | Начало | След.
Отстранение элементов | Уровень выше | Ограждение


Ограждение
Пред. Глава 32. Меню План След.

Ограждение

Команда служит для размещения "ограждения" (прямоугольной рамки), которое служит для выхода на плоттер.

Пред. | Начало | След.
Соединение пунктов | Уровень выше | Вычитание координат


Вычитание координат
Пред. Глава 32. Меню План След.

Вычитание координат

Если включите вычитание координат, то при движении курсора мыши над планом программа автоматически показывает его координаты .

Пред. | Начало | След.
Ограждение | Уровень выше | Глава 33. Меню Битовая карта


Глава 33. Меню Битовая карта
Пред. Часть II. Руководство по применению След.

Глава 33. Меню Битовая карта

Это меню содержит команды для работы с растровыми данными.

Ключ трансформации

После включения этой команды программа изобразит диалоговое окно, в котором можно определить ключ трансформации для перевода графических координат в выбранную систему.

Управление диалоговым окном производится тем же способом, что и расчетные окна. Подробное описание определения ключа трансформации описано в Руководстве по применению.

Пред. | Начало | След.
Вычитание координат | Уровень выше | Дигитализация


Дигитализация
Пред. Глава 33. Меню Битовая карта След.

Дигитализация

После включения этой команды программа изобразит диалоговое окно, в котором можно вычитать координаты пунктов в выбранной системе координат. Перед началом дигитализации необходимо сначала определить ключ трансформации.

Управление диалоговым окном производится тем же способом, что и расчетные окна. Подробное описание дигитализации описано в Руководстве по применению.

Пред. | Начало | След.
Глава 33. Меню Битовая карта | Уровень выше | Часть III. Приложения


Часть III. Приложения
Пред. След.

Приложения

Содержание

34. Параметры при запуске
35. Инсталяция в сети
Инсталяция в сети
Конфигурационный файл
36. Типы файлов данных
37. Коммуникация с системой MicroStation
Конфигурация системы MicroStation
Конфигурационные файлы MDL модулей
Запуск системы GROMA из MicroStation
Коммуникация GROMA - MicroStation
Информация о пунктах
Кодирование пунктов
Конфигурация коммуникационного модуля
Дальнейшие функции модулей
38. Форматы входных файлов с измеренными величинами
39. Входной / выходной текстовый формат
Альфанумерические знаки
Символы позиций данных
Ширина форматированных данных
Количество десятичных долей
Другие установки
Примеры выходного формата
Особенности входного формата
Начитывание с помощью фиксированного формата
Начитывание с помощью свободного формата
Пред. | Начало | След.
Дигитализация | Уровень выше | Глава 34. Параметры при запуске


Глава 34. Параметры при запуске
Пред. Часть III. Приложения След.

Глава 34. Параметры при запуске

После запуска программы GROMA можно специфицировать на командной строке разные параметры. Параметры отделяются пропуском и обозначаются знаком - или /.

Таблица 34.1. Параметры при запуске

Параметр | Значение
-u | Название конфигурационного файла с полным адресом. Пример: -u=h:\cfg\groma.ini
-s | Не покажет при запуске рисунок.
-parent | Запустит систему GROMA как аппликацию специфической системы. Пример: -parent=MicroStation
-demo | Запустит систему в демонстрационном режиме.
-net | Запустит Gromu как сетевую (будет призводиться поиск сетевого аппаратного ключа).

Все параметры командной строки, которые не обозначены знаками - или /, считаются названиями файлов, которые должны быть открыты.

Пред. | Начало | След.
Часть III. Приложения | Уровень выше | Глава 35. Инсталяция в сети


Глава 35. Инсталяция в сети
Пред. Часть III. Приложения След.

Глава 35. Инсталяция в сети

Система GROMA предложена для непосредственной инсталяции и работу в сети компютерных сетей. Программу можно наисталировать на указанный диск с любой страницы или сервера в сети и запускать с любой станции.

Инсталяция в сети

Систему GROMA можно наисталировать на любой указанный диск с любой сетевой станции или сервера в сети и запускать с любой станции. Инсталяционная программа не сохраняет никакую информацию ни в регистрах, ни в системе Windows. Единственная исправление производится на станции, с которой GROMA наисталирована, это создание позиции в меню Start.

При инсталяции можно использовать стандартное обозначение адреса с помощью присоединенного сетевого диска, обозначенного буквой устройства, так же, как стандартного UNC адреса (определение с помощью названия сетевого сервера, напр. \\server\c\Groma7).

Учитывая, что GROMA не сохраняет никакую информацию ни в регистрах, ни в системе Windows, отстранить инсталяцию можно простым отстранением директории с программой GROMA.

Систему GROMA можно запускать с любой станции сети, с которой доступна указанная директория, в которой система GROMA наинстиллирована. При запуске можно использовать стандартное обозначение адреса с помощью присоединенного сетевого диска, обозначенного буквой устройства (напр. x:\Groma7\groma.exe), stejne как стандартного UNC адреса (определение с помощью названия сетевого сервера, напр. \\server\c\Groma7\groma.exe).

Единственная исправление, которую целесообразно выполнить на станциях, с которых должна быть запущена система GROMA, это создание иконы в меню Start.

Пред. | Начало | След.
Глава 34. Параметры при запуске | Уровень выше | Конфигурационный файл


Конфигурационный файл
Пред. Глава 35. Инсталяция в сети След.

Конфигурационный файл

Система GROMA сохраняет все установки в текстовом конфигурационном файле. Этот файл находится на стандартном месте, которое предусмотрено типом операционной системы или его место можно определить явно.

Стандартное размещение конфигурационного файла

Система GROMA сохраняет все установки в текстовом конфигурационном файле. Если место размещения файла явно не определено, то он будет помещен на стандартное место, которое предусмотрено типом операционной системы:

  • Windows NT, 2000 a XP: В этих операционных системах для размещения конфигурационного файла используется системная переменная %USERPROFILE%. Эта переменная показывает на частную директорию зарегистрированного потребителя, т.е. гарантировано, что каждый потребитель системы имеет собственную конфигурацию.

  • Windows 95, 98 a ME: В этих операционных системах системная переменная %USERPROFILE% не установлена, поэтому конфигурационный файл будет размещен непосредственно в системе Windows.

Вынужденное размещение конфигурационного файла

В случае, если по какой-то причине стандартное размещение конфигурационного файла Вам не подходит, то можно явно установить иное размещение. Причиной может быть напр. необходимость размещения конфигурационного файла на сетевом диске домашней директории потребителя, чтобы он имел ту же конфигурацию и после приглашения с любой станции сети. Размещение конфигурационного файла можно преднаставить двумя способами:

Определение конфигурационного файла с помощью параметров при запуске

Размещение файла можно установить с помощью параметра -u=nazevsouboruscestou. Этот параметр необходимо задать в определении командной строки иконы или записи в меню Start. Параметры отделяются хотя-бы одним пропуском от названия программы.

Если адрес к конфигурационному файлу содержит пропуски, то необходимо его (или целый параметр) поместить в кавычки (напр. -u="название файла с адресом и пропусками" или "-u= название файла с адресом и пропусками")

При определении адреса можно использовать системные переменные или позиции с регистрами. Названия переменных закрываются знаками %%, а позиции регистра – ломанными скобками < и >. Эти названия будут заменены соответствующими величинами.

Замечание

Позиции регистра берутся из HKEY_CURRENT_USER.

Примеры:

c:\Groma7\Groma.exe -u=h:\Konfigurace\groma.ini

c:\Groma7\Groma.exe -u=%USERPREFS%\groma.ini

c:\Groma7\Groma.exe -u="<Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders\Local Settings>\groma.ini"

Вынужденное размещение конфигурационного файла в файле network.ini

Вместо параметров при запуске, размещение конфигурационного файла можно определить в файле network.ini, который находится в директории системы GROMA. Преимущество этого способа установки состоит в том, что нет необходимости подправлять все иконы на всех комьютерах в сети (файл network.ini общий для целой инсталяции). Другим премуществом этого способа является то, что установка относсится и ко всем расширяяющим модулям системы GROMA.

Учитывая то, что эта установка относится и ко всем модулям системы GROMA, которые используют собственные конфигурационные файлы, то этим способом можно определить только адрес к конфигурационному файлу, но не его название (которое для каждой компоненты системы другое).

Размещение фала определяется с помощью переменной ConfigFilePath файла network.ini. В этой переменной задается адрес, куда конфигурационный файл должен быть помещен. И безразлично, если адрес окончен обратной косой чертой или нет. К этому адресу система дополнит конкретное название конфигурационного файла для соответствующей компоненты.

Основы использования системных переменных и позиций с регистрами похожи, как при определении на командной строке.

Контроль размещения конфигурационного фала

Если необходимо определить актуальное размещение конфигурационного фала, то поступайте следующим способом:

  1. В меню системы GROMA выберите команду Справка – О программа.

  2. В изображенном диалоговом окне нажмите кнопку (Дальше). Если в окне эта кнопка отсутствует, то нажмите комбинацию клавишь <Shift-Ctrl> и дважды щелкните по рисунку.

    В следующем изображенном диалоговом окне найдете название конфигурационного файла на позиции Преференция File. Если название с адресом будет длиннее, полностью не изобразится. Потом необходимо показать на окошко мыши и передвигать курсор так, чтобы можно было весь адрес прочесть.

Образцовый конфигурационный файл

Если система GROMA не найдет конфигурационный файл потребителя на соответствующем месте (на стандартном месте или на месте, определенном одним из приведенных выше способов), скопирует основной файл с установками. Этот файл размещен в директории с инсталяцией системы GROMA и имеет название groma.ini.

Если необходимо изменить некоторые основные установки, то образцовый конфигурационный файл можно подправить или скопировать в систему GROMA как образцовый файл одного из потребителей. Все потребители, которые еще не имеют собственный конфигурационный файл, потом получат этой основной конфигурации.

Пред. | Начало | След.
Глава 35. Инсталяция в сети | Уровень выше | Глава 36. Типы файлов данных


Глава 36. Типы файлов данных
Пред. Часть III. Приложения След.

Глава 36. Типы файлов данных

Программа GROMA использует для работы различные типы файлов данных. Некоторые из них сохранены во внутреннем формате программы, а некоторые имеют универсальный формат, который используют также другие программы.

Таблица 36.1. Припоны файлов, используемых в системе GROMA

Припона файла | Содержание файла | Формат
.crd | Координатный файл | Бинарный
.crx | Индексовый файл к координатному файлу | Бинарный
.mes | Журнал измеренных величин | Бинарный
.mex | Индексовый файл к журналу измеренных величин | Бинарный
.prj | Проект | Текстовый
.pic | Предписание чертежа для координатного файла | Бинарный
.bmp | Битовая карта для дигитализации | Бинарный
.rnf | Информация к битовой карте (ключ трансформации и т.п.) | Бинарный
.cod | Кодирующая таблица | Текстовый
.txt | Текстовый файл | Текстовый
.par | Площадь | Текстовый
.dst | Файл контрольных обмеров | Текстовый
.key | Ключ трансформации | Текстовый
.pol | Полигонометрический ход | Текстовый

В некоторых ситуациях программа GROMA автоматически создает запасную копию файлов (напр. перед компресией и т.п.). Учитывая, что обычно работаем с больщим количеством файлов одинакового названия, которые различаются только припоной, то нельзя все запасные файлы называть припоной .bak. По этой причине название запасного файла создается так, что оставляют название исходного файла, для первого знака припоны используют знак "~", a остальные знаки припоны подвинутся вправо (последний знак припоны при этом исчезнет).

Пред. | Начало | След.
Конфигурационный файл | Уровень выше | Глава 37. Коммуникация с системой MicroStation


Глава 37. Коммуникация с системой MicroStation
Пред. Часть III. Приложения След.

Глава 37. Коммуникация с системой MicroStation

Система GROMA содержит поддержку коммуникации с графической системой MicroStation или PowerDraft. Эта коммуникация происходит на основе DDE (Dynamic Data Exchange) и поэтому доступна только в версиях для MS Windows. В дальнейшем тексте обе эти графические системы будут иметь общее название MicroStation.

Конфигурация системы MicroStation

Перед началом коммуникации необходимо систему MicroStation сконфигурировать так, чтобы она могла сотрудничать с программой GROMA. Эта конфигурация состоит из трех частей:

  1. Скопируйте конфигурационный файл GROMA.CFG из директории Groma7\SUPPORT в директорию CONFIG\APPL системы MicroStation, в которой сохраняются конфигурации аппликаций. Весь адрес зависит от названия директории, в которой наинсталлирован MicroStation. Он может выглядеть напр. так:

    C:\USTATION\CONFIG\APPL\

  2. Если система GROMA наинсталлирована в иное место, чем в предлагаемую внутреннюю директорию C:\Groma7, то в конфигурационном файле GROMA.CFG исправте переменную GROMA так, чтобы она содержала адрес в эту директорию. (напр. C:/Groma7/)

    Важно

    Этот адрес всегда должен заканчиваться знаком косой черты.

    Если необходимо систему GROMA запустить с некоторым параметром на командной строке, то приведите этот параметр перед или за уже существующими параметрами на командной строке GROMA_CMDLINE, отделив его пропуском. Если припишете параметр прямо к названию файла GROMA.EXE, то это полное название будет считаться названием файла а систему GROMA невозможно будет запустить.

  3. Из директории Groma7\SUPPORT скопируйте MDL модули (файлы с припоной .MA) в директорию MDLAPPS системы MicroStation (директория, в которой сохранены аппликации).

Пред. | Начало | След.
Глава 36. Типы файлов данных | Уровень выше | Конфигурационные файлы MDL модулей


Конфигурационные файлы MDL модулей
Пред. Глава 37. Коммуникация с системой MicroStation След.

Конфигурационные файлы MDL модулей

MDL модули системы GROMA автоматически сохраняют конфигурацию на диске. Конфигурационные файлы имеют название совпадающее с названием модуля и припону .UPF. Обычно эти файлы сохраняются в директории, на которую указывает переменная системы MicroStation _USTN_USER (обычно это директория USTATION\CONFIG\USER\). Если необходимо конфигурационный файл сохранять в ином месте (напр., чтобы каждый потребитель имел при многопотребительской конфигурации свою установку), определите в системе MicroStation переменную GROMA_USERPREFS и установите в ней адрес на необходимую директорию. После этого все конфигурации будут сохраняться в этой директории.

Пред. | Начало | След.
Глава 37. Коммуникация с системой MicroStation | Уровень выше | Запуск системы GROMA из MicroStation


Запуск системы GROMA из MicroStation
Пред. Глава 37. Коммуникация с системой MicroStation След.

Запуск системы GROMA из MicroStation

Если же была неверно проведена инсталяция и конфигурация согласно предыдущего абзаца, то можно запустить систему GROMA из MicroStation командой MDL LOAD GROMA. Эту команду можно дополнить как позицию в меню или на панели системы MicroStation. После включения этой команды изображается малое диалоговое окно системы MicroStation с названием GROMA и автоматически запускается система GROMA, которая ведет себя как аппликация для MicroStation (она всегда сверху и когда работаете в системе). В случае необходимости можно главное окно программы GROMA увеличить на весь экран или минимализировать на икону.

Система PowerDraft, к сожалению, на позволяет запускать внешние аппликации, поэтому необходимо запустить систему GROMA двумя шагами:

  1. Запустите коммуникационный модуль системы GROMA, выше приведенным способом.

  2. Запустите систему GROMA с параметром /parent=PowerDraft. Можно также создать икону для запуска с этим параметром.

После запуска система GROMA автоматически навяжет коммуникацию с модулем в системе PowerDraft. Далее все иде так, как в системе MicroStation.

Пред. | Начало | След.
Конфигурационные файлы MDL модулей | Уровень выше | Коммуникация GROMA - MicroStation


Коммуникация GROMA - MicroStation
Пред. Глава 37. Коммуникация с системой MicroStation След.

Коммуникация GROMA - MicroStation

Перетягивание пунктов

Если необходимо показать пункты на чертеже, то их можно перетягивать мышью на плоскость окна MicroStation также, как они перетягиваются между окнами данных и расчетов. Можно перетягивать отдельные пункты и группы обозначенных пунктов. После перетягивания пункты мгновенно изображаюся на чертеже.

Показ пунктов на чертеже

Для расчетных задач или при сохранении пунктов в каталоге координат можно показывать пункты на чертеже мышью. Порядок действий описан следующими пунктами:

  1. Выберите требуемую задачу (расчетные функции, добавление пунктов в каталог и т.п.).

  2. У позиции, которую требуется показать на чертеже, нажмите кнопку со стрелкой. Кнопка останется нажатой и закрасится в красный цвет. В коммуникационом окне MicroStation появится извещение Вычитание координат.

  3. Покажите пункт на чертеже нажатием кнопки <Tentative> и подтвердите кнопкой <Данные>. Координаты будут автоматически перенесены в диалоговое окно системы GROMA.

Соединение согласно номеров пунктов

Если необходимо соединить пункты из каталога координат согласно номеров, то поступайте следующим образом:

  1. Откройте в системе GROMA соответствующий каталог координат.

  2. КомандойКоординаты->Соединение согласно номеров откройте диалоговое окно для соединения пунктов.

  3. В системе MicroStation выберите вычерчение элемента, которым хотите соединить пункты (обычно Line, Line String, но можно в общем что угодно – дугу, кривую или условный знак).

  4. Для соединения пунктов задавайте постепенно в диалоговом окне номера пунктов, которые хотите соединить. После нажатия клавиши <Enter> программа разыщет координаты в каталоге (каталогах) координат и отошлет их в систему MicroStation, дальнейшие действия которой зависят от выбранной функции (вычерчение линии, кривой, вычерчивание условного знака и т.п.).

Пред. | Начало | След.
Запуск системы GROMA из MicroStation | Уровень выше | Информация о пунктах


Информация о пунктах
Пред. Глава 37. Коммуникация с системой MicroStation След.

Информация о пунктах

Система GROMA позволяет сохранять информацию о пунктах непосредственно на чертеже. Эта информация сохраняется с помощью т.н. User Data Linkage в особенных элементах типа PointString. Эти информации могут использоваться и для некоторых дальнейших функций:

Динамическое изображение номеров пунктов

Номера, высоты и коды пунктов, сохраняемые в этих элементах, могут изображаться динамически на экране. Если это изображение включено, то у каждого пункта изображаются, согласно установки, номер или же высота и код. Эти информации не являют составной частью чертежа, поэтому исчезнут автоматически после отстранения пункта, а при его передвижении передвигаюся автоматически с ним. Более того, его подписи имеют постоянные размеры, которые не изменяюся при увеличении или при уменьшении.

Выписка каталога координат

На основе этих информаций можно когда-либо выгенерировать текстовый каталог координат с исходными номерами пунктов и актуальними координатами, перевзятыми с четежа. При этом сохраняются и исходные высоты пунктов, в т.ч. на 2D чертежах.

Генерирование описаний

Часто при импорте из каталога координат выгодно создать на чертеже только элементы типа PointString с информациями о пунктах. Если чертеж готов, то можно сразу для всех элементов выгенерировать подписи согласно установленнх атрибутов.

Пред. | Начало | След.
Коммуникация GROMA - MicroStation | Уровень выше | Кодирование пунктов


Кодирование пунктов
Пред. Глава 37. Коммуникация с системой MicroStation След.

Кодирование пунктов

Система GROMA позволяет при импорте координат на чертеж помещать на нем не только текстовые подписи, но и условные знаки пунктов. При присоединении к системе GROMA кодирующей таблицы, которая переводит, Вами зарегистрированные, коды на названия условных знаков (ячеек) системы MicroStation, то при импорте найденные условные знаки будет автоматически помещены на пункты. Условные знаки создаются согласно атрибутов, установленных в диалоговом окне Установка->Атрибуты. Если необходимо для каждого условного знака иметь самостоятельную установку (напр., если необходимо поместить условные знаки в разные слои), то присоедините в кодирующей таблице к названию условного знака другие атрибуты, отделенные знаком & в такой последовательности:

Название_знака&слой&цвет&толщина&стиль

Если какой-либо из знаков пропустим (знак & должен быть приведен), то соответствующий атрибут будет заимствован со стандартной установки.

Пример:

soupe&21&1&2&0

знак soupe, слой 21, цвет 1, толщина 2 и стиль 0,

soupe&21&&2&0

знак soupe, слой 21, цвет согласно установки атрибутов, толщина 2 и стиль 0.

Пред. | Начало | След.
Информация о пунктах | Уровень выше | Конфигурация коммуникационного модуля


Конфигурация коммуникационного модуля
Пред. Глава 37. Коммуникация с системой MicroStation След.

Конфигурация коммуникационного модуля

Атрибуты изображения пунктов на чертеже можно установить с помощью команды Установка->Атрибуты и Установка->Координаты.

Атрибуты изображения

В этом диалоговом окне можно определить, какими атрибутами будут изображаться пункты на чертеже. Можно включать и выключать изображение пункта, предномера, номера, высоты, кода (текстового) и условного знака на пункте (согласно кода). Для каждого этого элемента можно выбрать слой, цвет или величину, фонт и размещение.

Можно составить около 20 названных комплектов конфигурации. Если необходимо определить комплект конфигурации, то установите все атрибуты, задайте название конфигурации в окошко Название и нажмите кнопку (Сохранить). Комплект установки будет придан в каталог. Если необходимо какой-либо комплект отстранить, укажите на него в каталоге и нажмите кнопку (Отстранить). Активный комплект установки можно выберать, указав мышью на позицию в каталоге.

Замечание

Последнюю установку нельзя отстранить, так как всегда должен быть определен хотя бы один комплект.

Если выберете для предномера и номера одинаковое размещение (напр. посередине вверху), то на чертеже изобразится полный номер в форме предномер-номер (отделены тире).

Величины текстов задаются в миллиметрах на результирующем чертеже, а действительная величина на чертеже вычисляется согласно масштаба, установленного вэтом диалоговом окне.

Если включите выбор Присоединить информацию о пункте, то при импорте при каждом пункте создается особый элемент типа PointString. К этому элементу с помощью User Data Linkage присоединены информации о пункте, т.е. номер, предномер и высота. Если эти информации сохранены на чертеже, то их можно использовать для последующих работ. Могут динамически изображаться номера и высоты пунктов, может быть также дополнительно выгенерирован каталог координат, который содержит исходные номера пунктов и актуальные координаты с чертежа.

Выбор Тексты, независимые от взгляда можно с выгодой использовать при работе в 3D. Если эта команда включена, то созданные текстовые элементы независимы от используемого взгляда, т.е. всегда читаемы (в плане, в разрезе и при общем виде).

Установка координат

В этом диалоговом окне можно установить, каким способом действительные координаты должны быть переведены на координаты чертежа. Можно установить редукцию координат, т.е. коэффициенты, на которые координаты будут умножены или заменены X и Y. Неявно модуль установлен на работу с MicroStation (чтобы были правильно ориентированы оси, координаты X и Y заменены и умножены на коэффициент -1).

Пред. | Начало | След.
Кодирование пунктов | Уровень выше | Дальнейшие функции модулей


Дальнейшие функции модулей
Пред. Глава 37. Коммуникация с системой MicroStation След.

Дальнейшие функции модулей

Кроме собственно перетягивания пунктов на чертеж можно использовать и другие функции, которые предлагают коммуникационные модули. Эти функции доступны с панели Файл.

Начитка каталога координат

Кроме перетягивания пунктов из системы GROMA, можно с помощью модуля непосредственно начесть каталог координат в текстоввом виде. После включения команды Файл->Начесть изобразится диалоговое окно, в котором устанавливают тип текстового файла (последовательность координат). Поссле нажатия кнопки (Выбрать), можно выбрать файл для импорта. Если выключите кнопку Записать на чертеж, то пункты будут только изображены на экране и после перечерчивания исчезнут. Эту команду можно использовать для контроля верности установленных параметров и т.п.

Вычерчивание пункта на чертеже

Если необходимо вычертить на чертеже отдельные пункты, то выберите команду Файл->Вычертить пункт. Программа изобразит диалоговое окно, в котором можно задать номер и высоту пункта и с помощью кнопки <Данные> вычерчивать на четеже пункты. После вычерчивания пункта автоматически увеличивается номер пункта на единицу.

Эдитация пункта

С помощью этой функции можно эдитировать описательные данные (предномер, номер, высота, описание) пунктов на чертеже.

Создание описаний

Часто, при импорте из каталога координат, выгодно включить только информации о пунктах, а все остальные позиции выключить. Тогда на чертеже будут созданы только элементы типа. К ним можно присоединить динамическое изображение номеров пунктов. Тогда при манипуляции с пунктами будет достаточно двигать только одним элементом, а описания автоматически передвигаются с ним. Если чертеж готов, то этой командой можно массово выгенерировать описания к пунктам согласно установленных атрибутов.

Важно

Генерирование описаний руководствуется установленными атрибутами. Следовательно перед массовым выгенерированием необходимо установку атрибутов, которые требуют элементы (номера, высоты), включить.

Экспорт каталога координат

После включения команды Файл->Экспортировать каталог координат изобразится диалоговое окно, которое позволит выбрать тип и название результирующего текстового каталога координат. После нажатия кнопки (Запись) и подтверждения кнопкой <Данные> в соответствующем взляде создан каталог координат, в который записаны все пункты, к которым присоединена информация о пункте (см. Атрибуты изображения). Пункт останется с исходным номером и получит актуальные координаты с чертежа. Так можно создать актуализированный каталог координат, если во время создания чертежа с пунктами на чертеже выполнялась манипуляция

В файл будут записаны только те пункты, информация о которых (PointString) сохранена в слое, который в данном взгляде включен. Пункты из выключенных слоев не будут записаны в файл.

Если на чертеже расположено ограждение (Fence), то в файл будут записаны только пункты, расположенные внутри ограждения, в ином случае будет записано содержание всего чертежа.

Перенос пунктов в систему GROMA

С помощью этой функции можно массово перенести пункты с чертежа в систему GROMA. В системе GROMA выберите функцию придания пункта в каталог, нажмите кнопку для графического вычитания и в системе MicroStation включите эту функцию. Функцию подтвердите нажатием кнопки <Данные>. Если имеется ограждение, то в каталог координат будут перенесены пункты, расположенные внутри ограждения, в ином случае будет записано содержание всего чертежа.

Поиск пунктов

Этот модуль служит для поиска пунктов на чертеже с помощью их номеров. Задайте предномер и номер пункта, номер взгляда, в котором найденный пункт должен должен быть изображен, и величину грани взгляда, которая определяет увеличение. Если теперь предварительно выбрать в системе MicroStation или в этом диалоговом окне одну из функций для черчения (напр. вычерчивание линии), то тогда требуемый элемент будет автоматически вычерчен через найденные пункты.

Динамическое изображение номеров пунктов

Если на пунктах создан элемент типа PointString (если при импорте была включена команда Присоединить информацию о пункте), можно включать/выключать динамическое изображение описаний. При динамическом изображении описания изображаются только на экране и не сохранены на чертеже. Перевигаете-ли данный пункт, передвигаются с ним и описания. Отстранив пункт, исчезнут также описания. Более того, описания имеют стандартную величину несмотря на актуальный масштаб окна, т.е. не меняются при увеличении / уменьшении. Это динамическое изображение можно включать/выключать командой Установка->Изобразить пункты resp. Установка->Скрыть пункты или в командной строке командой DISP ON или DISP OFF. Параметры изображения можно установить с помощью команды Установка->Изображение пунктов. Здесь можно выбрать также величину текста и цвет. Более того, можно включить изображение квадратиков на конечных пунктах линейных элементов.

Пред. | Начало | След.
Конфигурация коммуникационного модуля | Уровень выше | Глава 38. Форматы входных файлов с измеренными величинами


Глава 38. Форматы входных файлов с измеренными величинами
Пред. Часть III. Приложения След.

Глава 38. Форматы входных файлов с измеренными величинами

Программа GROMA позволяет импортировать измеренные данные из большинства используемых журналов. Однако файлы данных должны иметь определенную структуру, чтобы программа их акцептировала.

Форматы постепенно развиваются или появляются новые форматы, поэтому в этом руководстве не описаны. При инсталяции программы инсталируются также образцовые файлы данных, у которых формат уже имеется. В случае неясности консультацию можно получить по телефону или по e-mail.

Пред. | Начало | След.
Дальнейшие функции модулей | Уровень выше | Глава 39. Входной / выходной текстовый формат


Глава 39. Входной / выходной текстовый формат
Пред. Часть III. Приложения След.

Глава 39. Входной / выходной текстовый формат

Для входа/выхода каталога координат и журнала измеренных величин используется свободно определенный текстовый формат. Предписание формата можно определить в Файл->Установка->Входной/выходной формат координат и Файл->Установка->Входной/выходной формат измерения .

Формат определяется в многострочечном эдитационном окне.

Так как программа GROMA формально не различает входной формат от выходного, потому-что они имеют некоторые специфические качества, то их описание будет выполнено отдельно.

Входной / выходной формат создается двумя типами данных:

  • Символы позиций данных

    символы, вместо которых программа GROMA запишет в результирующей форматизированной строке соответствующие величины (номер пункта, координаты и т.п.).

  • Альфанумерические знаки

    программа их только запишет в результирующей (отделительные пропуски, запятые, табуляторы и т.п.).

Альфанумерические знаки

Альфанумерические знаки при форматировании только копируются в выходной файл. Обычно речь идет о разделительные знаки (пропуски, запятые, табуляторы и т.п.).

Все альфанумерические знаки, кроме знаков "Табулятор" и "<", можно записать непосредственно в предписание формата. Это вызвано особым посланием этих знаков (табулятором передвигаетесь из эдитора формата на кнопки в диалоговом окне , а знак "<" служит для определения символов позиций данных). Поэтому необходимо записывать эти знаки специальным способом:

  • Табулятор: "\t"

  • Квадратная скобка: "<<"

Пред. | Начало | След.
Глава 38. Форматы входных файлов с измеренными величинами | Уровень выше | Символы позиций данных


Символы позиций данных
Пред. Глава 39. Входной / выходной текстовый формат След.

Символы позиций данных

Символы позиций данных – это текстовые цепочки, представляющие соответствующие данные. При выходе они заменяются конкретными данными из каталога.

Записываются они в ломанных скобках ("<" и ">"), чем однозначно отделяются от остальных альфанумерических данных.

Некоторые символы являются общими для форматов координатных файлов и файлов с измеренными данными (номера пунктов и т.п.), однако большинство из них специфические (см. следующую таблицу).

Таблица 39.1. Символы позиций данных для каталога координат

Символ | Описание
<P> | Предномер
<N> | Собственный номер
<NUM> | Полный номер (номер и предномер)
<CODE> | Код (описание) пункта
<X> | Абсцисса X
<Y> | Ордината Y
<Z> | Аппликата Z
<INFO1> | Дополнительная данная номер 1
<INFO2> | Дополнительная данная номер 2
<INFO3> | Дополнительная данная номер 3
<INFO4> | Дополнительная данная номер 4
<TYPE> | Тип пункта
<PREC> | Код характеристики точности

Таблица 39.2. Символы позиций данных для журнала измерений

Символ | Описание
<P> | Предномер
<N> | Собственный номер
<NUM> | Полный номер (номер и предномер)
<CODE> | Код (описание) пункта
<HZ> | Горизонтальный угол
<V> | Зенитное расстояние
<DH> | Превышение
<SIG> | Высота цели (высота прибора)
Пред. | Начало | След.
Глава 39. Входной / выходной текстовый формат | Уровень выше | Ширина форматированных данных


Ширина форматированных данных
Пред. Глава 39. Входной / выходной текстовый формат След.

Ширина форматированных данных

За обозначение позиции данных можно в ломанных скобках задать требуемую ширину форматированной величины (требуемое количество значащих цифр). Если ширина не задана, то значение будет иметь минимально необходимое количество знаков.

Если предписание формата содержит текст <X:12>, то результирующий сформатированный текст на сооотвествующей позиции будет содержать абсциссу X шириной 12 знаков. Программа заравняет ординату вправо, а слева дополнит пропусками.

Дополнение нулями

Если необходимо, чтобы данные вместо пропусков дополнялись слева нулями, то задайте первым знаком ширины цифру 0 (т.е. напр. <X:012>

Точная ширина – отбрасывание

Если ширина форматированного данного превысит количество знаков, заданных в предписании формата, то ширина формата будет автоматически увеличена, а данное будет изображено со всеми цифрами. Если, по какому-либо поводу, необходимо сохранить установленную ранее ширину, то задайте первым знаком ширины знак #, т.е. напр. <X:#8:4>. В этом случае от форматированного данного будут слева или справа (в зависимости от способа заравнивания) отброшены лишние цифры.

Знак

Если необходимо, чтобы величина всегда имела знак, причем и в случае позитивных величин, то задайте первым знаком ширины знак +, т.е. напр. <X:+12:4>. В этом случае форматированное данное будет всегда содержать знак плюс или минус.

Заравнивание

В зависимости от типа данного программа автоматически выбирает заравнивание влево или вправо. Если необходимо конкретно установить тип заравнивания, то задайте первым знаком ширины букву L для заравнивания влево или букву R для заравнивания вправо, т.е. напр. <X:L12:4>.

Пред. | Начало | След.
Символы позиций данных | Уровень выше | Количество десятичных долей


Количество десятичных долей
Пред. Глава 39. Входной / выходной текстовый формат След.

Количество десятичных долей

За шириной данного после двоеточия можно установить требуемое количество десятичных долей.

Если необходимо установить абсциссу X на ширину в 12 целых знаков и 4 десятичные доли, то запишите в предписании формата текст <X:12:4>.

Если количество десятичных долей не установлено, то программа GROMA использует явный формат, т.е формат, где номера и предномера – целые числа, а остальные согласно установки в Файл->Установка->Входной/выходной формат координат .

Пред. | Начало | След.
Ширина форматированных данных | Уровень выше | Другие установки


Другие установки
Пред. Глава 39. Входной / выходной текстовый формат След.

Другие установки

Диалоговое окно позволяет установить для каждого формата и другие параметры:

  • Неопределенные заменить нулями

    Если соответствующая позиция в данных не определена, то программа при форматировании поместит на ее место пропуски. Если пропуски Вам не подходят (напр. для дальнейшего начитывания данных другими программами), то можно включить эту установку и программа поместит на эти позиции нули.

  • Редуцировать координаты при выходе

    При включении этой команды программа редуцирует все координаты на величины, установленные в Файл->Установка->Редукция.

  • Отделение порядков

    При включении этой команды каждые три порядка координаты всегда отделяются пропуском.

  • Отделитель десятичной части согласно Windows

    Программа использует вместо десятичной точки символ, определенный на командной панели MS Windows.

Пред. | Начало | След.
Количество десятичных долей | Уровень выше | Примеры выходного формата


Примеры выходного формата
Пред. Глава 39. Входной / выходной текстовый формат След.

Примеры выходного формата

Таблица 39.3. Примеры выходного формата для каталога координат

Формат | Результат
<N> <X> <Y> | 1 1044109.820 750010.900
<N:4> <X:14:4> <Y:14:4> | 1 1044109.8200 750010.9000
<N:04>, <X>, <Y> | 0001, 1044109.820, 750010.900
<P:6><N:04>, X=<X>, Y=<Y> | 1000010001, X=1044109.820, Y=750010.900

Таблица 39.4. Примеры выходного формата для журнала измерений

Формат | Результат
<N> <HZ> <D> <DH> <SIG> <CODE> | 1 28.7894 14.370 0.588 1.300 PBPP
Пред. | Начало | След.
Другие установки | Уровень выше | Особенности входного формата


Особенности входного формата
Пред. Глава 39. Входной / выходной текстовый формат След.

Особенности входного формата

Не смотря на то, что в программе GROMA форматы определены для входа и выхода данных, формат для входа данных имеет некоторые особенности.

Если бы формат для входа был определен также, как формат для выхода, то позволял бы начитывать данные из какого-либо файла с фиксированным форматом, т.е. из файла, в котором соответствующие данные на каждой строке размещены на фиксированных позициях (т.е. напр. абсцисса X на позициях 10-22 и т.п.).

Однако обычно текстовый файл этому требованию может и не соответствовать. Он может иметь напр. такой вид:

8 1045656.12 740143.45
9 1045778.3 740227.66
10 1045771.13 740439.01

В этом случае, данные на строке не имеют твердую позицию, поэтому их нельзя начитывать фиксированным форматом (напр., в записимости от величины номера пункта, абсцисса Х начинается на позиции 3-4).

По этой причине в программу включена и возможность т.н. Свободного формата, которая не требует данных на фиксированных позициях, но начитывает их согласно размещения разделительных знаков (пропуски, табуляторы и другие не числовые знаки).

Пред. | Начало | След.
Примеры выходного формата | Уровень выше | Начитывание с помощью фиксированного формата


Начитывание с помощью фиксированного формата
Пред. Глава 39. Входной / выходной текстовый формат След.

Начитывание с помощью фиксированного формата

При начитывании согласно фиксированного формата входная строка разделена только согласно предписанию формата.

Расположение каждой позиции определено суммой ширин предыдущих позиций на строке и количеством всех разделительных альфанумерических знаков.

При предписании формата

<P:6><N:04>, X=<X>, Y=<Y>

предномер должен начинаться в столбике 1, номер - в столбике 7, абсцисса X - в столбике 15, а ордината Y - в столбике 30.

При этом программа не тестирует, если разделительные знаки согласуются со знаками, определенными в предписании формата (здесь после номера пункта программа пропустит четыре знака и не тестирует, если это в действительности знаки ", X=").

  • Преимущества:

    Импорт с помощью фиксированного формата позволяет отфильтровать из файла не используемые альфанумерические данные. Более того, данные, которые записаны непосредственно за собой, можно разделить.

  • Невыгоды:

    Текстовый файл должен иметь фиксированный формат, т.е. позиции данных должны быть размещены на всех строках на тех же позициях.

Пред. | Начало | След.
Особенности входного формата | Уровень выше | Начитывание с помощью свободного формата


Начитывание с помощью свободного формата
Пред. Глава 39. Входной / выходной текстовый формат След.

Начитывание с помощью свободного формата

При начитывании согласно свободного формата входная строка разделена разделительными знаками (пропуски, табуляторы и т.п.). Поэтому данные на входных строках могут и не располагаться на фиксированных позициях.

В импортированном файле может быть любое количество разделительных знаков не смотря на количество разделительных знаков, предусмотренных в предписании формата (напр., если в предписании формата имеются разделительные знаки ", X=", то в файле данных может быть любое количество пропусков, в т.ч. и одна).

  • Преимущества:

    Позиции данных не должны быть размещены на фиксированных позициях на входной строке.

  • Невыгоды:

    Из текстового файла невозможно отфильтровать ненужные данные, а позиции без разделительных знаков нельзя при импорте разделить.

Пред. | Начало | След.
Начитывание с помощью фиксированного формата | Уровень выше | Часть IV. Расширяющиеся модули


Часть IV. Расширяющиеся модули
Пред. След.

Расширяющиеся модули

Содержание

40. Расширяющиеся модули
41. Контрольный чертеж для расчетов
Изображение всего чертежа
Вырез
Увеличение
Уменьшение
Отстранение
Фонт
Печать
Экспорт в DXF
42. Искажение в проекции Кршовака
43. Треугольный калькулятор
44. Перенос файлов
Выбор размещения файла
Параметры переноса
Начтение файла
Перенос файла в прибор
Дальнейшие установки
45. Присоединение дигитайзера
Подготовка приспособления дигитайзера
Тест коммуникации
Калибрация цифрового приспособления
Вычитание пунктов
Определение площадей
46. Уравнивающая плоскость
Задание плоскости
Положение плоскости
Уравнение плоскости
Результирующие величины
47. Топографические (Геометрические) планы
Ввод
Управление программой
Установка модуля и описательное поле
Данные кадастра недвижимостей
Данные прошлого учета земельных участков
Данные для pro BPEJ
Дополнительные данные
Результирующие таблицы
Входы и выходы
48. Расчет трассы коммуникации
Введение
Управление программой
Определение трассы
Расчетные контроли
Расчет пунктов на оси коммуникации
Расчет пикетов на нормалях
Расчет разбивочных элементов
49. Уравнивание сети
Введение
Управление программой
Варианты уравнивания и присоединения сети
Характеристики пунктов
Параметры сети
Вводимые данные
Уравнивание сети
Сохранение уравненных координат
Сравнение этапов
Математическая модель уравнивания
Меню ФАЙЛ
Меню СЕТЬ
50. Заключение
Пред. | Начало | След.
Начитывание с помощью свободного формата | Уровень выше | Глава 40. Расширяющиеся модули


Глава 40. Расширяющиеся модули
Пред. Часть IV. Расширяющиеся модули След.

Глава 40. Расширяющиеся модули

Программа позволяет работать с расширяющимися модулями, которые интегрированы в среду системы GROMA. Эти модули активизируются с помощью меню Средства. Некоторые модули имеются в основной инсталяции (Контрольный чертеж, Расчет искажений в проекции Кршовака). Остальные модули продаются самостоятельно.

Они представлены в основной инсталяции как демонстрационные версии.

Модули наинсталированы в поддиректории Apps системы GROMA.

Пред. | Начало | След.
Часть IV. Расширяющиеся модули | Уровень выше | Глава 41. Контрольный чертеж для расчетов


Глава 41. Контрольный чертеж для расчетов
Пред. Часть IV. Расширяющиеся модули След.

Глава 41. Контрольный чертеж для расчетов

Искажение в проекции Кршовака

Этот модуль изобразит окно, в котором изображаются пункты из последнего расчета. Их можно использовать и при задавании пунктов с клавиатуры для устранения грубых ошибок при задавании. Исходные пункты расчета изображаюся черным, а вычисленные красным цветом. Вспомогательные информации изображаюся зеленым цветом. Содержание окна отстраняется при каждом новом расчете.

Функции для управления модулем находятся в системном меню диалогового окна (меню под иконой Windows в заглавии окна). Большинство из них имеется к диспозиции на панели с кнопками.

Изображение всего чертежа

После включения этой команды изобразится чертеж в таком масштабе, чтобы в окне с котрольным чертежом изобразился полностью.

Пред. | Начало | След.
Глава 40. Расширяющиеся модули | Уровень выше | Вырез


Вырез
Пред. Глава 41. Контрольный чертеж для расчетов След.

Вырез

После включения этой команды можно с помощью левой кнопки мыши выбрать вырез чертежа, который должен быть изображен.

Пред. | Начало | След.
Глава 41. Контрольный чертеж для расчетов | Уровень выше | Увеличение


Увеличение
Пред. Глава 41. Контрольный чертеж для расчетов След.

Увеличение

Эта команда увеличит масштаб изображенного чертежа в два раза.

Пред. | Начало | След.
Вырез | Уровень выше | Уменьшение


Уменьшение
Пред. Глава 41. Контрольный чертеж для расчетов След.

Уменьшение

Эта команда уменьшит масштаб изображенного чертежа на половину.

Пред. | Начало | След.
Увеличение | Уровень выше | Отстранение


Отстранение
Пред. Глава 41. Контрольный чертеж для расчетов След.

Отстранение

Этой командой можно отстранить из окна контрольный чертеж.

Пред. | Начало | След.
Уменьшение | Уровень выше | Фонт


Фонт
Пред. Глава 41. Контрольный чертеж для расчетов След.

Фонт

Этой кнопкой можно установить фонт, которым изображаются текстовые информации.

Пред. | Начало | След.
Отстранение | Уровень выше | Печать


Печать
Пред. Глава 41. Контрольный чертеж для расчетов След.

Печать

Этой кнопкой можно отпечатать контрольный чертеж на принтере, который выбран для печати графики в системе GROMA.

Пред. | Начало | След.
Фонт | Уровень выше | Экспорт в DXF


Экспорт в DXF
Пред. Глава 41. Контрольный чертеж для расчетов След.

Экспорт в DXF

Этой командой можно экспортировать контрольный чертеж в формат DXF, который можно начесть в практически любую графическую систему. С помощью этой команды можно напр. просматривать пункты при уравнивании сети и иной документации.

Пред. | Начало | След.
Печать | Уровень выше | Глава 42. Искажение в проекции Кршовака


Глава 42. Искажение в проекции Кршовака
Пред. Часть IV. Расширяющиеся модули След.

Глава 42. Искажение в проекции Кршовака

Искажение в проекции Кршовака

Этот модуль позволяет по координатам и высоте требуемого пункта вычислить коэффициент для исправления картографического искажения и для исправления высоты над уровнем моря.

Если задать координаты вставленного пункта или перетянуть их из каталога координат и нажать кнопку (Расчет), то программа вычислит масштабный коэффициент для исправления картографического искажения. Если пункт имеет и аппликату Z, то программа вычислит и коэффициент для исправления высоты над уровнем моря.

С помощью зачеркиваемых окон выберите, которые исправления хотите завести и нажмите кнопку (Установить). Вычисленный масштабный коэффициент будет сохранен в установке программы GROMA, а при импорте журналов измерений будут все импортированные длины умножены на этот коэффициент.

Пред. | Начало | След.
Экспорт в DXF | Уровень выше | Глава 43. Треугольный калькулятор


Глава 43. Треугольный калькулятор
Пред. Часть IV. Расширяющиеся модули След.

Глава 43. Треугольный калькулятор

Этот модуль позволяет вычислять элементы обычного плоского треугольника

После задания необходимого количества вводимых величин (не менее трех величин, но ни в коем случае не три угла), программа довычислит оставшиеся величины. Вычисленные данные запишет в ведомость и изобразит форму треугольника.

Если необходимо задать иную комбинацию вводимых величин, необходимо сначала ненужные или определяемые величины выключить с помощью переключателей (программа не позволяет задать более чем три вводимые величины.

Пред. | Начало | След.
Глава 42. Искажение в проекции Кршовака | Уровень выше | Глава 44. Перенос файлов


Глава 44. Перенос файлов
Пред. Часть IV. Расширяющиеся модули След.

Глава 44. Перенос файлов

Модуль служит для двухстороннего переноса файлов между компьютером и прибором, которые используют простую коммуникацию терминального типа.

После запуска модуля появится диалоговое окно, в котором изобразятся файлы, размещенные в актуальной директории. Название актуальной директории показано в заглавии журналов.

Выбор размещения файла

Перед начтением файла необходимо выбрать место, куда пересенный файл поместить. Файл будет помещен в актуальную директорию, содержание которой показано в диалоговом окне модуля.

Актуальную директорию можно выбрать обычным передвижением курсора по перечню директорий с помощью клавиатуры или мыши. Актуальный диск можно выбрать с помощью команды Диск-> Выбор диска или комбинацией клавиш <Alt-F1>.

Пред. | Начало | След.
Глава 43. Треугольный калькулятор | Уровень выше | Параметры переноса


Параметры переноса
Пред. Глава 44. Перенос файлов След.

Параметры переноса

Перед началом коммуникации необходимо так установить параметры переноса, чтобы они были одинаковы в приборе и переносном модуле. Параметры устанавливаются командой Установка->Параметры переноса. В показанном диалоговом окне необходимо верно установить все параметры, иначе не будет коммуникации компьютера и прибора или перенесенные данные будут ошибочны.

Пред. | Начало | След.
Глава 44. Перенос файлов | Уровень выше | Начтение файла


Начтение файла
Пред. Глава 44. Перенос файлов След.

Начтение файла

Если верно установлены все параметры переноса и верно выбрана директория для размещения перенесенных файлов, то перенос можно запустить командой Файл->Начтение файла или клавишей <F9>. После задания этой команды появится диалоговое окно, в котором можно задать название целевого файла. Если переносный модуль запущен в среде системы GROMA, то будет изображен и переключатель Открыть как измерение. Включите-ли его, то перенесенный файл будет открыт в системе GROMA.

После задания и подтверждения названия целевого файла изобразится диалоговое окно с предложением выслать файл. После этого необходимо с помощью команд, заданных в приборе, запустить собственное высылание измеренных данных на серийный порт. Когда перенос данных начнется, в окне переносного модуля появится сообщение о переносе данных и ротирующая черта, информирующая о ходе перноса.

После окончания переноса информационное окно переносного модуля должно автоматически исчезнуть. В случае, если неверно установлена конечная цепочка в параметрах переноса (цепочка, согласно которой опознается конец переносимых данных), информационное окно не исчезнет, но ротирующая черта остановится. В этом случае необходимо окончить перенос нажатием кнопки (Отменить). Перенесенные данные и в этом случае должны быть в порядке.

Пред. | Начало | След.
Параметры переноса | Уровень выше | Перенос файла в прибор


Перенос файла в прибор
Пред. Глава 44. Перенос файлов След.

Перенос файла в прибор

Если необходимо перенести файл в прибор, поместите курсор на этот файл в перечне файлов и выберите команду Файл->Перенос файла, или нажмите клавишу <F10>. Программа для контроля еще раз спросит, если действительно хотите перенести выбранный файл в прибор. Если выбор подтвержден, то программа проведет контроль файла в поисках каких-либо бинарных знаков. Если таковые имеются , то появится еще одно предупреждение.

Если перенос файла подтвержден, то программа изобразит объявление, требующее подготовить прибор для приема данных. После этого необходимо с помощью клавиатуры выбрать функцию для начитывания данных из серийного порта. Когда соответствующая функция выбрана, то нажмите в окне с объявлением кнопку (OK). Тем самым процесс переноса выбранного файла в прибор начат.

Внимание

В случае, если по ошибке вышлете в прибор файл с иной структурой, чем тот, который он может акцептировать (напр. бинарный файл), то может произойти нарушение записей памяти в приборе. Такое препятствие можно преодолет только в авторизованном сервисе.

Пред. | Начало | След.
Начтение файла | Уровень выше | Дальнейшие установки


Дальнейшие установки
Пред. Глава 44. Перенос файлов След.

Дальнейшие установки

В предложении Установка->Среда можно установить другие качества переносного модуля:

  • Первичный и вторичный эдиторы

    Можно также установить, какой эдитор использовать для эдитации файлов. Первичный эдитор включается клавишей <F4>, а вторичный – комбинацией клавиш <Shift-F4>.

  • Резервирование файлов данных

    Этой командой можно включить автоматическое резервирование файлов. При автоматическом резервировании создаются две копии переносимого файла – одна в выбранной директории, т.е. в той, куда файл переносится, а другая – в специальной директории для резервных файлов, название которой задается в эдитационном окне Директория для резервных файлов.

  • Припона файлов данных

    Можно определить, какую припону должны получить перенесенные файлы, если при задавании названия файла не зададите припону.

Пред. | Начало | След.
Перенос файла в прибор | Уровень выше | Глава 45. Присоединение дигитайзера


Глава 45. Присоединение дигитайзера
Пред. Часть IV. Расширяющиеся модули След.

Глава 45. Присоединение дигитайзера

Модуль служит для присоединения приспособления дигитайзера. Он позволяет присоединить цифровой планиметр (тип XPlan или Tamaya) или какой-либо другой дигитайзер.

Подготовка приспособления дигитайзера

Приспособление, с которым должен вести коммуникацию модуль, должно иметь для использования соответствующую конфигурацию.

Цифровой планиметр

Цифровой планиметр типа XPlan или Tamaya присоединен непосредственно с помощью серийного rozhrani. Для нормальной коммуникации необходимо выполнить установку параметров переноса. Никакие другие драйверы или программы не нужны. При конфигурации поступайте следующим образом:

  • Присоединение планиметра

    Планиметр присоединяется к серийному порту компьютера серийным кабелем. Если кабель имеет другой размер, чем свободный порт вашего компьютера, то используйте соответсвующую редукцию.

  • Установка параметров переноса в компьютере

    Параметры переноса (скорость переноса, количество битов данных, количество стопбитов и паритет) должны быть установлены те же в конфигурации модуля дигитализации и в планиметре. В модуле дигитализации параметры переноса устанавливаются нажатием кнопки (Параметры) в зависимости от типа приспособления.

  • Установка параметров переноса в планиметре

    Способ установки в планиметре зависит от производителя и типа и должен быть подробно описан в документации к планиметру. В планиметре XPlan параметров переноса устанавливаются с помощью кнопки <Shift> и <P/NP>.

  • Включчение выхода на серийный порт

    В планиметре должен быть включен выход на серийный порт (данные стандартно показываются только на дисплее).

  • Выбор вычитаемых величин

    На планиметре можно выбрать, которые величины должны вычитаться. Можно выбирать между координатами, площадями, длинами и т.п. Верным считается включение функции цифрового модуля на вычитание координат.

Дигитайзер

Для присоединения дигитайзера необходимо в системе MS Windows наинсталировать оригинальный драйвер, который поставляется производителем дигитайзереров (т.н. Wintab driver). Порядок инсталяции драйвера должен быть описан в оригинальной документации к дигитайзеру.

Пред. | Начало | След.
Дальнейшие установки | Уровень выше | Тест коммуникации


Тест коммуникации
Пред. Глава 45. Присоединение дигитайзера След.

Тест коммуникации

После установки параметров переноса для цифрового планиметра можно отестировать, если приспособление высылает данные в компьютер. Команда Установка->Тест ввода покажет окно, в котором после нажатия вычитающей кнопки на планиметре изобразятся принятые данные. Если после нажатия кнопки в модуле ничего не покажется, то неверно установлены параметры переноса или на планиметре выключено высылание данных на серийный порт.

Замечание

Окно Тест коммуникации предназначено только для цифровых планиметров, вход из дигитайзера в нем не изображается.

Если все установки в порядке, то после нажатия вычитающей кнопки на цифровом приспособлении в окне модуля появятся вычтенные графические координаты (в окнах x' и y').

Пред. | Начало | След.
Глава 45. Присоединение дигитайзера | Уровень выше | Калибрация цифрового приспособления


Калибрация цифрового приспособления
Пред. Глава 45. Присоединение дигитайзера След.

Калибрация цифрового приспособления

Перед каждой дигитализацией необходимо выполнить калибрацию цифрового приспособления. Калибрация состоит в определении идентических пунктов, с помощью которых графические координаты будут трансформированы на реальные. Последовательность задавания идентических пунктов тот же, что и при трансформации координат:

  1. Выберите требуемый тип трансформации. Для графического оригинала выгоднее аффинная трансформация, которая имеет два разные масштаба по осям X и Y (в отличие от трансформации подобия, которая на всех направлениях имеет одинаковый масштаб искажения). Для трансформации подобия необходимо минимум два идентических пункта, а для аффинной трансформации - три. Для надежности результатов дигитализации целесообразно всегда иметь хотя бы на 1-2 идентических пункта больше.

  2. Задайте действительные координаты идентических пунктов в окошка X и Y (лучше всего перетягиванием мышью из каталога координат).

  3. Вычесть графические координаты на цифровом приспособлении. Эти координаты изобразятся в окошках x' и y'.

  4. Добавьте пункт в каталог идентических пунктов нажатием кнопки (Добавить).

В каталоге идентических пунктов можно выключать и включать отдельные пункты с помощью зачеркиваемого окошка вначале каждой строки. Если необходимо пункт совсем исключить, то нажмите кнопку (Отстранить)

Ведомость о калибрации можно просмотреть и сохранить после нажатия кнопки (Ведомость).

Если необходимо начать трансформацию новой основы, нажмите кнопку (Новая трансформация).

Пред. | Начало | След.
Тест коммуникации | Уровень выше | Вычитание пунктов


Вычитание пунктов
Пред. Глава 45. Присоединение дигитайзера След.

Вычитание пунктов

Если определено достаточное количество идентических пунктов, то после вычитания пунктов с графической основы программа автоматически покажет конечные трансформированные координаты в рамке Odecteny bod.

Таким образом определенные координаты можно переносить на любое место в системе GROMA, на котором показана кнопка для графического вычитания пунктов. Если эту кнопку нажать (нажматая кнопка останется нажатой, а кружок с крестом изобразится красным цветом), то после вычитания трансформированными координатами будут заполнены соответствующие входные окна.

Так можно вычесть координаты при добавлении пункта в каталог координат или непосредственно при решении отдельных задач.

Диалоговое окно цифрового модуля не должно быть во время дигитализации закрыто, но после задания идентических пунктов его можно с помощью иконы минимализировать, чтобы оно напрасно не занимало место на площади программы.

Если для дигитализации используется дигитайзер, то можно включить переключатель Автоматическая дигитализация. Модуль будет автоматически высылать в систему GROMA координаты пунктов, если передвинете курсор на расстояние, заданное во входном окне Шаг.

Пред. | Начало | След.
Калибрация цифрового приспособления | Уровень выше | Определение площадей


Определение площадей
Пред. Глава 45. Присоединение дигитайзера След.

Определение площадей

Если не нужно иметь непосредственно координаты пунктов, а достаточно определить площади, то можно использовать сокращенную калибрацию дигитайзера только с помощью известных длин и без идентических пунктов. В этом случае поступаем следующим образом:

  1. Зачеркните в окне для дигитализации выбор Прямое вычитание.

  2. Нажмите кнопку (Калибрация).

  3. В показанное диалоговое окно задайте действительную величину длины между двумя пунктами, причем, как в горизонтальном, так и в отвесном направлениях.

  4. Нажмите кнопку (Ukazat delku) и покажите оба конечные пункты длин на цифровом приспособлении. В диалоговом окне изобразятся измеренные длины (в графических координатах оригинала).

  5. Нажмите кнопку (OK). Этим сокращенная калибрация заканчивается.

После этого дигитайзер будет выдавать координаты в местной системе и в правильном масштабе, которые можно использовать для определения площадей.

Пред. | Начало | След.
Вычитание пунктов | Уровень выше | Глава 46. Уравнивающая плоскость


Глава 46. Уравнивающая плоскость
Пред. Часть IV. Расширяющиеся модули След.

Глава 46. Уравнивающая плоскость

Модуль служит для вычисления уравнивающей плоскости методом наименьших квадратов. Уравнение плоскости вычисляется при условии минимальной суммы квадратов расстояний отдельных пунктов от плоскости. К этому условию можно добавить дополнительное условие отвесности плоскости.

Задание плоскости

Плоскость задается с помощью пространственных координат пунктов. Пункты можно задать в модуль с клавиатуры или перетянуть мышью из каталога координат. Пункты добавляются в перечень пунктов нажатием кнопки (Добавить), а отстраняются нажатием кнопки (Отстранить).

Если при добавлении пункта в перечень пунктов зачеркивается выбор Использовать для уравнения плоскости, то добавляемый пункт будет использован для определения уравнения плоскости. Если этот выбор выключен, то для соответствующего пункта будет вычислено расстояние от плоскости, а для определения плоскости он использован не будет. Пункты, которые были использованы, обозначены в ведомости звездочкой.

После вычисления плоскости вычисляются расстояния от нее всех заданных пунктов.

Пред. | Начало | След.
Определение площадей | Уровень выше | Положение плоскости


Положение плоскости
Пред. Глава 46. Уравнивающая плоскость След.

Положение плоскости

Здесь можно определить требуемое положение результирующей плоскости:

  • Общее

    Плоскость вычислена в общем положении, т.е. так, чтобы наилучшим образом примыкала к заданным пунктам.

  • Отвесное

    Уравнение плоскости вычислено при условии отвесности.

Пред. | Начало | След.
Глава 46. Уравнивающая плоскость | Уровень выше | Уравнение плоскости


Уравнение плоскости
Пред. Глава 46. Уравнивающая плоскость След.

Уравнение плоскости

Уравнение результирующей плоскости можно увидеть нажав кнопку (Уравнение). Уравнение приведено в ведомости.

Пред. | Начало | След.
Положение плоскости | Уровень выше | Результирующие величины


Результирующие величины
Пред. Глава 46. Уравнивающая плоскость След.

Результирующие величины

В диалоговом окне можно выбрать требуемые величины:

  • Проекция

    В каталоге приведены координаты проекций по нормалям заданных пунктов на уравненные плоскости (все эти пункты находятся на результирующей плоскости).

  • Опустить

    Плоскость совмещена с плоскостью XY, поэтому результирующие координаты X и Y – это координаты пунктов на этой плоскости, а аппликата Z – это расстояние заданных пунктов от плоскости. Эти координаты можно использовать, напр., для создания образа в горизонталях при измерении деформаций равнинных площадей.

  • Опустить Z=0

    Результирующие координаты X и Y те же, что и в предыдущем случае, а аппликата Z у всех пунктов нулевая (пункты находятся на опущенной плоскости).

Пред. | Начало | След.
Уравнение плоскости | Уровень выше | Глава 47. Топографические (Геометрические) планы


Глава 47. Топографические (Геометрические) планы
Пред. Часть IV. Расширяющиеся модули След.

Глава 47. Топографические (Геометрические) планы

Топографические (Геометрические) планы

Ввод

Программа служит для автоматического создания формуляров Вычисление площадей, Ведомость существующего и нового состояния данных кадастра недвижимостей и Ведомость данных o BPEJ.

Пред. | Начало | След.
Результирующие величины | Уровень выше | Управление программой


Управление программой
Пред. Глава 47. Топографические (Геометрические) планы След.

Управление программой

Управление программой производится с помощью диалогового окна. Диалоговое окно делится с помощью закладок на отдельные логические целые. Первые пять закладок служат для задавания исходных данных, остальные три – для изображения результирующих формуляров.

Вжодные величины задаются в таблицах. Некоторые позиции заполняются вручную, а некоторые задаются выбором из предложения.

Эдитация таблиц

При задавании данных достаточно поместить курсор на соответствующую ячейку и начать писать. Если ячейка уже содержит какие-то данные, то они смажутся. Если необходимо только исправить исходные данные, то режим эдитации можно включить дважди щелкнув на ячейку.

Если необходимо смазать содержание ячейки, то поместите на нее курсор и нажмите клавиши <Shift-Del>.

Вложение строк

Если заполнять таблицу обычным способом, т.е. постепенно сверху вниз, то нет необходимости беспокоиться о добавлении строк. Программа автоматически добавит незаполненные строки в конце таблицы. Если необходимо вложить незаполненную строку в другое место, чем в конце таблицы, то переместите курсор на строку, перед которой должна быть новая строка вложена, и выберите в предложении Эдитация->Вложить строку или нажмите комбинацию клавиш <Ctrl-Ins>. Перед строкой, на которой имеется курсор, будет вложена новая строка.

Отстранение строк

Если необходимо отстранить целую строку, то поместите на нее курсор и выберите в предложении Эдитация->Отстранить строку или нажмите комбинацию клавиш <Ctrl-Del>. Целая строка в таблице будет отстранена.

Копирование данных

Если необходимо скопировать некоторые данные или блок данных в другое место, поступайте следующим образом:

  1. Обозначте блок, который необходимо скопировать, с поморщью мыши или клавишами курсора совместно с клавишей <Shift>.

    Подсказка

    Если необходимо обозначить целую строку, достаточно только показать мышью на первую ячейку (т.е. ячейку, в которой изображен номер строки).

  2. Выберите команду Эдитация->Скопировать или Эдитация->Перенести, что зависит от того, если данные необходимо оставить на прежнем месте или отстранить.

  3. В другом месте таблицы обозначте блок, куда данные должны быть вложены.

    Важно

    Обозначенная область, куда должны быть скопированы данные, должна иметь такие же размеры (то же количество строк и столбиков), как и копированная область.

Изменение последовательности строк

Если необходимо заменить некоторые строки, то можно использовать копирование данных с помощью ячейки памяти.

Сначала необходимо вложить новую строку на место, куда должны быть данные перекопированы. Потом выше описанным способом перекопировать целую строку. Наконец, исходную строку отстранить.

Составление топографического (геометрического) плана

После задания вводимых данных (или их начтения из файла) можно включить составление топографического плана командой Файл->Составить или клавишей <F4>.

Пред. | Начало | След.
Глава 47. Топографические (Геометрические) планы | Уровень выше | Установка модуля и описательное поле


Установка модуля и описательное поле
Пред. Глава 47. Топографические (Геометрические) планы След.

Установка модуля и описательное поле

Установка модуля

Диалоговое окно с установкой включается командой Топографический план->Выбор. В окне можно изменять следующие параметры:

  • Размеры письма

    Этим переключателем можно выбрать размеры письма для результирующей таблицы. С целью сохранения размеров таблиц можно выбирать только между величинами 6, 7 и 8.

  • Тип плана

    Этим переключателем можно выбрать стандартное составление плана или специфическое – для ЦКП или КП-Ц.

  • Исправление существующего состояния в журнале регистрации

    Этим переключателем можно выбрать, если в журнале регистрации площадей должны быть приведены исправления существующего состояния (зачеркивание существующего состояния и надписывание нового состояния так, как это приводится в расчетах площадей).

  • Показывать перечень покупателей

    Этим переключателем можно выбрать, если под таблицей приводить перечень покупателей.

Описательное поле

Данные, которые должны быть приведены в таблице на топографическом плане (описательное поле), заполняются в диалоговом окне, которое появится после включения команды Топографический план->Описательное поле.

Масштаб графической основы служит для вычисления предельных отклонений в площадях.

Деформация листа плана будет приведена вначале ведомости вычислений.

Внимание

Программа только запишет деформацию в ведомость, но предполагает, что площади уже исправлены и никакое исправление за деформацию листов плана в расчеты не вводит.

Пред. | Начало | След.
Управление программой | Уровень выше | Данные кадастра недвижимостей


Данные кадастра недвижимостей
Пред. Глава 47. Топографические (Геометрические) планы След.

Данные кадастра недвижимостей

Данные кадастра недвижимостей задаются на первых трех закладках диалогового окна.

Существующее состояние КН

В этой таблице необходимо задать парцеллы существующего состояния кадастра недвижимостей, в т.ч. площади и способ их определения. Задаются следующие данные:

  • Старый номер

    Номер парцеллы в кадастре недвижимостей.

  • Площадь

    Площадь парцеллы в m2.

  • Качество

    Способ определения площади участка. Качество можно выбрать из предлагаемого перечня.

  • Вид участка

    Вид участка (культуру) можно выбрать из предлагаемого перечня культур.

  • Способ использования

    Дополнительное необъязательное данное к виду участка. Если оно будет задано, то в результирующем журнале регистрации площадей будет изображено совместно с видом участка в форме дроби.

  • Номер LV

    Номер Свидетельства о собственности.

  • Исправить

    С помощью этого переключателя можно исправить существующую площадь парцеллы в ведомости для расчета площадей и в результирующем журнале регистрации площадей. Если этот переключатель выключен, то, в случае превышения предельного отклонения, программа Вас спросит, если нужно отклонение уравнять или же исправить исходную площадь. Если ни на одной из частей соответствующей парцеллы нельзя провести исправление, то всегда будет выполняться исправление общей площади.

  • Аннулирование

    С помощью этого переключателя можно аннулировать парцеллу. Так обозначенная парцелла появится в списке аннулированных парцел.

  • Идентификатор параграфа (§ Id)

    С помощью этого переключателя можно выбрать идентификатор соответствующего параграфа, согласно которого площадь парцеллы изменена. Если это изменение произойдет (в зависимости от других причин и установок), то далее будет приведено полное содержание причин изменения.

  • Параграф (§)

    После нажатия этой кнопки появится диалоговое окно, в котором можно просматривать и эдитировать перечень параграфов, позволяющих изменять площадь парцеллы. В левой части таблицы находится сокращенный идентификатор, с помощью которого параграфы в таблицах задаются. В правой части находится полное его содержание, которое будет приведено в результирующих таблицах. Начальные знаки полного содержания (до первого пропуска) будут использованы как символ, обозначающий соответствующее исправление.

Новое состояние КН

Здесь заполняются парцеллы нового состояния кадастра недвижимостей. Задаются следующие данные:

  • Новый номер

    Новый номер парцеллы.

  • Площадь

    Вновь определенная площадь парцеллы. Если можно определить площадь из далее заданных частей парцеллы, то нет необходимости ее заполнять.

  • Способ определения

    Способ, с помощью которого была новая площадь определена. Способ можно выбрать из предлагаемого перечня.

  • Вид участка и способ использования

    Вид участка и способ его использования в новом состоянии (подробности см. Существующее состояние).

  • Не уравнивать

    Этим переключателем можно вручную влиять на уравнивание частей парцеллы. Если у парцеллы этот переключатель включен, то уравнивание частей парцеллы на всей площади парцеллы проведено не будет.

  • Покупатель

    Имя и адрес покупателя можно задать двумя способами: Если разговор идет о новом покупателе, который тут еще не появлялся, то его можно непосредственно вписать во входное окно. Если разговор идет о покупателе, который уже был задан, то его можно просто выбрать из перечня.

    Если данные о покупателе в результирующем журнале регистрации площадей должны быть записаны на нескольких строчках, то при задавании эти строки можно разделить знаком \ (обратной косой чертой).

    Если покупатель не будет приведен, то эта парцелла не появится для сравнения с состоянием юридических отношений в формуляре Журнал регистрации существующего и нового состояния данных КН.

Части КН

В этой таблице определяются все парцеллы и парцельные части, которые должны в результирующих таблицах фигурировать. Задают следующие данные:

  • Старый номер

    Существующий номер части согласно настоящего состояния кадастра недвижимостей. Номер можно задать непосредственно с клавиатуры или выбрать из перечня парцел, которые находятся в старом состоянии.

  • Новый номер

    Новый номер, который будет иметь соответствующая часть согласно топографического плана. Номер можно задать непосредственно с клавиатуры или выбрать из перечня парцел, приведенных в новом состоянии.

  • Новая часть

    Новое обозначение части, которое припадет соответствующей части согласно топографического плана.

  • Площадь и способ определения

    Площадь части и способ, каким была площадь определена. Способ определения можно выбрать из перечня.

  • Номенклатура

    Обозначение листа плана, на котором лежит соответствующая часть.

  • Уравнивать

    С помощью этого переключателя можно выбрать, если часть, при уравнивании частей дигитально определенной площади, должна быть исправлена. Этот переключатель имеет три положения:

    • Нейтральное положение

      В этом положении явно не определено, если часть должна быть исправлена. О исправлении части программа решит самостоятельно согласно определения площади. Установка обозначена темносерым квадратиком на светлосером фоне. На это положение переключатель установлен автоматически.

    • Выключено

      Если переключатель находится в этом положении, то часть при выравнивании не будет исправлена. Положение идентифицировано незакрашенным светлосерым квадратиком.

    • Включено

      Если переключатель находится в этом положении, то часть будет исправлена не смотря на другие обстоятельства. Положение идентифицировано красным зачеркиванием.

  • BPEJ

После нажатия этой кнопки появится диалоговое окно, в котором можно для каждой части постепенно задать коды BPEJ и соответствующие им площади.

Пред. | Начало | След.
Установка модуля и описательное поле | Уровень выше | Данные прошлого учета земельных участков


Данные прошлого учета земельных участков
Пред. Глава 47. Топографические (Геометрические) планы След.

Данные прошлого учета земельных участков

Состояние прошлого учета земельных участков

В этом окне задаются данные прошлого учета земельных участков, которые служат для сравнения с состоянием учета юридических отношений.

  • Номер, площадь и свидетельство о собственности

    Здесь заполняются номера и площади всех парцел, которые сравниваются. Если как номер свидетельства о собственности записан нуль, то эта парцелла не будет в сравнении приведена.

  • Основа

    Здесь записывается обозначение вида учета, откуда данные происходят (напр. PK).

  • Исправить

    С помощью этого переключателя можно выполнить исправление существующей площади парцеллы в ведомости для вычисления площадей и в результирующем журнале регистрации площадей. Если этот переключатель выключен, то в случае превышения предельного отклонения, программа спросит, если не хотите отклонение уравнять или исходная площадь должна быть исправлена. Если ни одну из частей соответствующей парцеллы нельзя исправить, то исправление общей площади будет выполняться всегда.

  • Не уравнивать

    Этим переключателем можно вручную влиять на уравнивание частей парцеллы. Если у парцеллы этот переключатель включен, то уравнивание частей парцеллы на общей площади парцеллы проведено не будет.

  • Часть

    Если в перечне частей DPE не заданы все части соответствующей парцеллы, то в журнале регистрации площадей была бы ошибочно показана площадь парцеллы. В этом случае можно включить этот переключатель и программа определит избыточную площадь через вычитание отдельных заданных частей от общей площади.

  • Аннулирование

    С помощью этого переключателя можно выполнить аннулирование парцеллы. Так обозначенная парцелла в перечне аннулированных парцел.

  • Идентификатор параграфа (§ Id)

    Здесь можно выбрать идентификатор соответствующего параграфа, согласно которому парцелла изменена. Если это изменение произойдет (в зависимости от других причин и установок), то далее будет приведено полное содержание причин изменения.

  • Параграф (§)

    В левой части таблицы находится сокращенный идентификатор, с помощью которого параграфы в таблицах задаются. В правой части находится полное его содержание, которое будет приведено в результирующих таблицах. Начальные знаки полного содержания (до первого пропуска) будут использованы как символ, обозначающий соответствующее исправление.

    После нажатия этой кнопки появится диалоговое окно, в котором можно просматривать и редактировать перечень параграфов, позволяющих измененять площади парцеллы. В левой части таблицы находится сокращенный идентификатор, с помощью которого параграфы в таблицах задаются. В правой части находится полное его содержание, которое будет приведено в результирующих таблицах. Начальные знаки полного содержания (до первого пропуска) будут использованы как символ, обозначающий соответствующее исправление.

Части парцел прошлого учета земельных участков

Здесь задаются все части парцел прошлого учета земельных участков для сравнения с состоянием учета юридических отношений.

  • Старый номер, новый номер, новая часть

    Эти три данные служат для однозначного присоединения части прошлого учета земельных участков к части КН. Данные выбираются из перечней, которые приняли величины, заданные в частях парцел КН.

  • Номер DPE, часть

    Здесь заполняется номер парцеллы и обознаяение части согласно прошлого учета земельных участков.

  • Уравнять

    С помощью этого переключателя можно выбрать, если, при уравнивании частей дигитально определенной площади, должно быть к части присоединено исправление.

  • Другие данные

    Другие данные задаются таким же образом, как и у частей парцел кадастра недвижимостей.

Пред. | Начало | След.
Данные кадастра недвижимостей | Уровень выше | Данные для pro BPEJ


Данные для pro BPEJ
Пред. Глава 47. Топографические (Геометрические) планы След.

Данные для pro BPEJ

Данные для составления журнала учета бонитированных земельно-экологических единиц задаются с помощью кнопки (BPEJ), которая изображена на конце каждой строки таблицы с частями парцел КН. После нажатия кнопки появится диалоговое окно, в котором можно для каждой части постепенно задать коды BPEJ и им принадлежащие площади.

Пред. | Начало | След.
Данные прошлого учета земельных участков | Уровень выше | Дополнительные данные


Дополнительные данные
Пред. Глава 47. Топографические (Геометрические) планы След.

Дополнительные данные

Тексты

В этой таблице можно задавать любые тексты для дополнения топографического плана.

  • Изображать

    С помощью этого переключателя можно включить или выключить размещение соответствующего текста, причем нет необходимости его отстранять и снова задавать.

  • Таблица

    Здесь выберете, в какую входную таблицу должен быть помещен текст.

  • Позиция

    В перечне выберите необходимую позицию для размещения текста.

  • Размещение

    Выберите тип относительного размещения, учитывая заданную позицию (Перед или За)

  • Текст

    В этой строке задайте требуемый текст. Если нужно вложить многострочечный текст, разделите его на больше позиций и отдельные позиции задайте в перечень текстов (все с одинаковым размещением).

Пред. | Начало | След.
Данные для pro BPEJ | Уровень выше | Результирующие таблицы


Результирующие таблицы
Пред. Глава 47. Топографические (Геометрические) планы След.

Результирующие таблицы

Заданные вводимые величины обработайте с помощью команды Файл->Обработать или нажатием клавиши <F4>. Программа выгенерирует результирующие таблицы, которые можно просмотреть непосредственно в диалоговом окне или с помощью просмотра перед печатью (Файл->Просмотр).

Пред. | Начало | След.
Дополнительные данные | Уровень выше | Входы и выходы


Входы и выходы
Пред. Глава 47. Топографические (Геометрические) планы След.

Входы и выходы

Сохранение данных в файле

Командами Файл->Сохрани и Файл->Сохрани как или комбинацией клавиш <Ctrl-S> можно задание всего топографического плана записать в файл. Файлы с топографическим планом имеют припону .gp.

Чтение дааных с файла

Топографический план, ранее сохраненный в файле, можно опять начесть из файла командой Файл->Открой или комбинацией клавиш <Ctrl-O>. После начтения топографический план автоматически составляется.

Просмотр перед печатью

Результирующие таблицы можно перед печатью сконтролировать непосредственно в диалоговом окне программы или при просмотре перед печатью, включенного командой Файл->Просмотр или комбинацией клавиш <Ctrl-V>. В окне с просмотром можно выбрать, какая сторона должна быть показана и с каким увеличением.

Печать

Печать таблицы включается командой Файл->Печать или комбинацией клавиш <Ctrl-P>. Перед печатью показано диалоговое окно, в котором можно выбрать входное приспособление.

Экспорт в DXF

Таблицы можно с помощью команды Файл->Экспортируй таблицу сохранить в файле в формате DXF, который можно начесть и в другие аппликации (MicroStation, AutoCAD, apod.). Вид таблицы можно определить в диалоговом окне Файл->Установка DXF.

Пред. | Начало | След.
Результирующие таблицы | Уровень выше | Глава 48. Расчет трассы коммуникации


Глава 48. Расчет трассы коммуникации
Пред. Часть IV. Расширяющиеся модули След.

Глава 48. Расчет трассы коммуникации

Расчет трассы коммуникации

Введение

Программа служит для расчета прямоугольных координат пунктов на трассе коммуникации и пунктов на нормалях к трассе.

Пред. | Начало | След.
Входы и выходы | Уровень выше | Управление программой


Управление программой
Пред. Глава 48. Расчет трассы коммуникации След.

Управление программой

Программа управляется с помощью основного диалогового окна, т.е. также, как и все стандартные расчетные окна системы GROMA.

Вводимые величины можно задать непосредственно с клавиатуры или перетянуть мышью из каталогов координат, открытых в программе GROMA. Все величины можно в каталогах эдитировать, добавлять и отстранять.

Перед расчетом можно в системе GROMA запустить модуль для контрольного чертежа. Сразу после окончания расчета трассы на чертеже будет показано прохождение трассы, в т.ч. с пунктами на оси коммуникации. Пунктов на нормалях может быть много, поэтому автоматически показываются не все, а только для тех нормалей, которые выберем щелкнув на них мышью в каталоге пунктов трассы.

Пред. | Начало | След.
Глава 48. Расчет трассы коммуникации | Уровень выше | Определение трассы


Определение трассы
Пред. Глава 48. Расчет трассы коммуникации След.

Определение трассы

Трасса коммуникации определена перечнем элементов трассы с информацией о них. Каждый элемент определен следующими данными:

  • Тип элемента (прямая, клотоида, дуга окружности).

  • Координаты X, Y начала элемента.

  • Разбивка начала элемента.

  • Дополнительные данные об элементе (радиус, параметр).

Этот перечень является обычно результатом разработки проекта одной из специализированных систем, напр. ROADPAC.

Отдельные элементы задаются в перечень так, что в диалоговом окне заполняют все необходимые данные и нажимают кнопку (Добавить). Новый элемент будет вставлен перед тот элемент перечня, на котором помещен курсор.

После задания трассы, целесообразно ее сразу сохранить в файле командой Файл->Сохрани.

Пред. | Начало | След.
Управление программой | Уровень выше | Расчетные контроли


Расчетные контроли
Пред. Глава 48. Расчет трассы коммуникации След.

Расчетные контроли

Перед расчетом пикетов, заданная трасса подвергается серйозным тестам. Если она не пройдет какой-то тест, то появится извещение о ошибке и расчет будет окончен.

Программа выполняет следующие контроли:

Контроль длины элемента

Программа контролирует, если действительная длина элемента, согласно координат его конечных пунктов и других параметров, отвечает разнице пиветажа между конечными пунктами. Если величина разницы этих двух данных превышает выличину 0.05 м, то появится извещение о ошибке и расчет будет окончен.

Контроль радиусов кривизны

На стыке каждых двух соседних элементов контролируется радиус кривизны, который на этих пунктах должен быть для обеих элементов одинаков. Если величина разницы двух его значений превышает величину 0.50 м, то появится извещение о ошибке и расчет будет окончен.

Контроль связи

На стыке каждых двух соседних элементов контролируется связь трассы с помощью дирекционных углов касательных. Для каждого стыковочного пункта вычисляется дирекционный угол касательной к предыдущему и последующему элементам. Касательные на этих пунктах должны быть тождественны. Если величина угла между этими двумя касательными превышает величину 1", то появится извещение о ошибке и расчет будет окончен.

Пред. | Начало | След.
Определение трассы | Уровень выше | Расчет пунктов на оси коммуникации


Расчет пунктов на оси коммуникации
Пред. Глава 48. Расчет трассы коммуникации След.

Расчет пунктов на оси коммуникации

Если задана вся трасса, то можно приступать к расчету пикетов. В диалоговом окне задайте начальный пикетаж, от которого будут пункты вычисляться и интервал между отдельными пикетами. После нажатия кнопки (Расчет) будут вычислены те пикеты, которые включены в каталог пикетов и где их можно просмотреть, и будет создана расчетная ведомость.

Пункты пронумерованы последовательно от номера 1 в направлении возрастания пикетажа.

Если в системе GROMA включен модуль для контрольного чертежа, то сразу изображается прохождение трассы, на котором главные пункты трассы показаны черным, а пикеты – красным цветом.

Если необходимо сохранить пикеты в каталоге координат, то перетяните их в него мышью из расчетного диалогового окна, т.е. также, как и при других операциях в системе GROMA. Программа спросит, если необходимо сохранить пикеты на оси коммуникации и на нормалях.

Пред. | Начало | След.
Расчетные контроли | Уровень выше | Расчет пикетов на нормалях


Расчет пикетов на нормалях
Пред. Глава 48. Расчет трассы коммуникации След.

Расчет пикетов на нормалях

Если необходимо вычислить координаты пикетов на нормалях к коммуникации, то постепенно задайте в диалоговом окне отдельные длины нормалей, разделив их запятой. Зададите-ли напр. -5,-2,0,2,5, то программа вычислит пикеты на нормалях к трассе на расстояниях –5 м, -2 м, 0 м, 2 м и 5 м.

После нажатия кнопки (Расчет) будут вычисленные координаты сохранены в ведомости вычислений. Если пикеты необходимо показать в диалоговом окне или на контрольном чертеже, то выберите в каталоге пикетов тот пикет, для которого необходимо вычислить нормаль и укажите не него мышью. В тот же момент, в нижней части диалогового окна, в каталоге пикетов на нормалях, этот пикет будет показан.

Если в системе GROMA включен модуль для контрольного чертежа, то на нем пикеты на нормалях изобразятся зеленым цветом.

Пункты пронумерованы последовательно от номера 1 в направлении возрастания пикетажа. В предномере пикета на нормали имеется номер пикета на коммуникации, на которую нормаль опущена.

Если необходимо сохранить вычисленные пикеты в каталоге координат, то перетяните их в него мышью из расчетного диалогового окна, т.е. также, как и при других операциях в системе GROMA. Программа спросит, если необходимо сохранить пикеты на оси коммуникации и на нормалях.

Пред. | Начало | След.
Расчет пунктов на оси коммуникации | Уровень выше | Расчет разбивочных элементов


Расчет разбивочных элементов
Пред. Глава 48. Расчет трассы коммуникации След.

Расчет разбивочных элементов

Если необходимо вычислить разбивочные элементы пикетов, то можно для этого использовать систему GROMA. Вычисленные пикеты перетяяните в каталог координат и используйте задачи „Полярные разбивочные элементы” и „Ортогональные разбивочные элементы”.

Пред. | Начало | След.
Расчет пикетов на нормалях | Уровень выше | Глава 49. Уравнивание сети


Глава 49. Уравнивание сети
Пред. Часть IV. Расширяющиеся модули След.

Глава 49. Уравнивание сети

Введение

Программа служит для уравнивания плановых и высотных геодезических сетей. Уравнивание выполняется на основе метода наименьших квадратов. Уравниваних плановых и высотных геодезических сетей выполняется отдельно. Кроме уравненных координат программа предлагает много характеристик точности и контрольных данных как для контроля расчета, так и для поиска грубых ошибок в измеренных данных.

Пред. | Начало | След.
Расчет разбивочных элементов | Уровень выше | Управление программой


Управление программой
Пред. Глава 49. Уравнивание сети След.

Управление программой

Управление программой выполняется с помощью основного диалогового окна, т.е. также, как и все стандартные расчетные окна системы GROMA. Это значит, что управление не должно быть для Вас проблемой.

Вводимые величины можно задавать непосредственно с клавиатуры или из каталогов, открытых в программе GROMA. Все величины можно каталогах эдитировать, добавлять и отстранять.

Если необходимо величину, сохраняемую в каталоге изменить, то поступайте следующим образом:

  • Покажите на соответствующую позицию в каталоге. Измеренные данные или координаты будут выписаны на эдитационных строчках.

  • Исправьте данные для требуемых величин.

  • Нажмите кнопку (Добавить).

Программа не позволяет сохранять в каталоге больше данных с одинаковыми номерами пунктов. Если соответствущие данные в каталоге уже имеются, то они только актуализированы согласно заданных величин, а если нет, то программа их только в каталог добавит. Поэтому при эдитации данных с каталога нет необходимости использовать кнопку (Отстранить), так как программа проведет актуализацию автоматически.

Пред. | Начало | След.
Глава 49. Уравнивание сети | Уровень выше | Варианты уравнивания и присоединения сети


Варианты уравнивания и присоединения сети
Пред. Глава 49. Уравнивание сети След.

Варианты уравнивания и присоединения сети

Программа позволяет присоединить уравненную сеть к реферец-системе несколькими способами.

Трансформация Гельмерта

Если все пункты уравниваемой сети имеют характеристику Свободный, то уравнивание будет выполняться при условием исправления приближенной конфигурации

[(dx2 + dy2)] = min

для всех пунктов сети. Уравненная сеть помещена трансформацией Гельмерта на все пункты сети.

Избранная трансформация Гельмерта

В этом варианте хотя бы два пункта должны иметь характеристику Гельмерт, а остальные Свободный. Уравнивание сети осуществится при тех же условиях, как и предыдущие варианты. Для размещения уравненной сети на референц-систему использованы те же пункты с характеристикой Гельмерт.

Опорный пункт и дирекционный угол

В этом варианте при уравнивании сохранены координаты опорного пункта и дирекционный угол с опорного пункта на пункт с исходный дирекционным углом. Поэтому один пункт в сети должен иметь характеристику Свободный пункт, один Опорный дирекционный угол, а остальные пункты сети должны иметь характеристику Свободный.

Жесткая сеть

Жесткая сеть содержит два и более пунктов с характеристикой Свободный. Координаты этих пунктов при уравнивании не изменятся. Измерения между опрными пунктами не влияют не результаты уравнивания, но влияют только на конечные характеристики точности. Остальные пунты имеют характер Свободный.

Пред. | Начало | След.
Управление программой | Уровень выше | Характеристики пунктов


Характеристики пунктов
Пред. Глава 49. Уравнивание сети След.

Характеристики пунктов

Пункты, используемые при уравнивании сети, могут иметь разные характеристики в зависимости от того, каким образом будут участвовать в этом уравнивании. Характеристики устанавливаются независимо для уравнивания в плане или для уравнивания по высоте.

Характеристики для уравнивания в плане

  • Опорные пункты

    Опорные пункты имеют фиксированные, не изменяемые при уравниванием координаты. После уравнивания сети они будут иметь те же координаты, какие имели при вводе.

    Важно

    Между опорными пунктами не должны измеряться ни длины, ни направления. Измерения между опорными пунктами не влияют на конечные уравненные координаты, но негативно влияют на средние квадратические ошибки.

  • Неизменяемая X, Неизменяемая Y

    У пунктов с этой характеристикой при уравнивании не изменяются координаты X или Y.

  • Свободные пункты

    Свободные пункты – это обычные пункты сети, координаты которых должны быть уравнены. Координаты всех свободных пунктов при уравнивании будут изменены. Если сеть содержит только пункты этого типа, то сеть будет также совмещена с помощью трансформации Гельмерта со всеми пунктами сети.

  • Исходный дирекционный угол

    Эта характеристика используется совметсно с опорным пунктом. Если один из пунктов имеет характеристику Опорный пункт, а один Исходный дирекционный угол, то после уравнивания будут сохранены координаты опорного пункта и дирекционный угол с опорного пункта на пункт с характеристикой „Исходный дирекционный угол”.

  • Гельмерт

    Если после уравнивания необходимо совместить сеть с помощью трансформации Гельмерта только с избранными пунктамы сети, обозначьте их характеристикой Гельмерт, а остальные - характеристикой Свободный.

Характеристики для уравнивания высот

  • Опорные пункты

    Опорные пункты имеют фиксированную, не изменяемую при уравнивании высоты. После уравнивания сети они будут иметь ту же высоту, какую имели при вводе.

  • Свободные пункты

    Свободные пункты – это обычные пункты сети, высота которых должна быть уравнена. Высоты всех свободных пунктов при уравнивании будут изменены. Если сеть содержит только пункты этого типа, то сеть будет также по высоте совмещена с помощью трансформации Гельмерта со всеми пунктами сети.

  • Гельмерт

    Если после уравнивания необходимо совместить сеть по высоте с помощью трансформации Гельмерта с избранными пунктами сети, то обозначьте высоту избранных пунктов характеристикой Гельмерт, а у остальных пунктов - характеристикой Свободная.

Если после уравнивания необходимо изменить характеристику какого-либо пункта, то поступайте следующим образом:

  1. Выберите соответсвующий пункт из каталога приближенныых координат.

  2. Измените характеристику этого пункта для уравнивания в плане или по высоте. Одновременно можно изменить и какие-либо другие данные.

  3. Нажмите кнопку (Добавить). Если приданный пункт имеет тот же номер, что и существующий в каталоге приближенных координат, то в каталог придан он не будет, а только исправлен согласно заданных данных.

Если необходимо изменить характеристику многих пунктов сразу, то поступайте следующим образом:

  1. Выберите в каталоге приближенных координат требуемые пункты. При выборе можно использовать клавиши <Shift> и <Ctrl> так, как это обычно делается в Windows.

  2. Если в каталоге выбрано много пунктов, то во входных окошках будут показаны только характеристики для уравнивания (другие данные массово изменять нельзя). Измените характеристики пунктов для уравнивания в плане или по высоте. Если одну из характеристик изменять не нужно, то оставьте ее не определенной ([-]).

  3. Нажмите кнопку (Добавить). Характеристики для уравнивания будут в каталоге исправлены.

Пред. | Начало | След.
Варианты уравнивания и присоединения сети | Уровень выше | Параметры сети


Параметры сети
Пред. Глава 49. Уравнивание сети След.

Параметры сети

В диалоговом окне Установка->Параметры сети можно установить некоторые параметры. Некоторые из параметров служат только для целей документации (описательне данные о сети), но другие необходимы для собственного уравнивания (ср. кв. ошибки, статистические тесты). Подробнее эти параметры описаны в реководстве по применению.

Пред. | Начало | След.
Характеристики пунктов | Уровень выше | Вводимые данные


Вводимые данные
Пред. Глава 49. Уравнивание сети След.

Вводимые данные

Как вводимые данные для уравнивания служат приближенные координаты пунктов сети, измеренные горизонтальные направления, измеренные горизонтальные длины и их ср. кв. ошибки (далее только геометрические величины). O геометрических величинах считаем, что они переведены на линию, соединяющую центры закрепленных знаков. Этот перевод можно выполнить с помощью средств системы GROMA.

Включение и выключение позиций

В каталогах перед отдельными позициями изображено зачеркиваемое окошко, с помощью которого можно временно включать и выключать данные, при этом их нет необходимости отстранять из каталога или добавлять в него.

В некоторых случаях программа может неиспользуемые позиции автоматически выключить. Это следующие случаи:

  • Пункты, на которых не выполнялись никакие измерения.

  • Измерения, которые выполнялись на пунктах, которые не приведены в каталогах пунктов.

  • Измеренные направления на станции, которые содержат только одно измерение.

Приближенные координаты вводимых пунктов

Для всех пунктов, включенных в сеть, должны быть заданы приближенные координаты. Приближенные координаты можно задать вручную, перетянуть из каталога координат программы GROMA (напр. из предыдущего уравнивания, из предыдущего этапа) или можно оставить, чтобы система массово вычислила приближенные координаты на основе журнала измерений.

Перетягивание координат из программы GROMA

Если необходимо использовать для уравнивания приближенные координаты, которые уже имеются в одном из каталогов координат в системе GROMA, достаточно их только обозначить и перетянуть блоком в ту часть диалогового окна для уравнивания сети, в которой приближенные координаты задаются (см. Руководство для программы GROMA, Перетягивание позиций). Все пункты будут автоматически приданы в каталог координат.

Важно

Так приданные пункты будут иметь все характеристики, установленные в перечне характеристик перед перетягиваем. Если у некоторых пунктов необходимо изменить характеристики, то изменения можно выполнить дополнительно или перетянуть пункты по частях, а требуемую характеристику установить всегда перед перетягиванием соответствующего блока.

Массовый расчет приближенных координат

Если приближенные координаты пунктов сети не имеются, то программа их может массово вычислить. Чтобы массовые вычисления были верны, необходимо выдержать определенную последовательность:

  1. В программе GROMA откройте все каталоги координат, которые необходимы для групповых расчетов.

  2. Откройте журнал измерений, на основе которой будете вычислять приближенные координаты.

  3. В журнале измерений обозначте все измерения, которые будут использованы при уравнивании как ориентирные. Измерения на пункты, обозначенные как пикеты, игнорированы.

  4. На Установка->Среда включите команду Искать во всех открытых файлах.

  5. Перетяните название входного файла с измерениями в диалоговое окно для уравнивание сети (в часть для задания приближенных координат пунктов). Название файла появится на позиции входной файл с измерениями.

  6. В перечне характеристик пунктов (Тип) установите характеристику, которая будет иметь в сети наибольшее количество пунктов.

  7. В Установка->Параметры сети установите ср. кв. ошибку измеренного направления и измеренные длины.

  8. Нажмите кнопку (Начесть данные).

Программа массово вычислит координаты всех станций из журнала измерений, добавит их каталог приближенных координат и одновременно в журналы измеренных направлений добавит все измерения, которые, по ее мнению, будут использованы для уравнивания сети. Пикеты в фале с измерениями не использует. Если в файл измеренных величин будут добавлены некоторые измерения, которые Вы не хотите использовать для расчета или, если Вы хотите добавить еще некоторые измерения, то необходимо соответствующие изменения выполнить вручную добавлением или отстранением отдельных данных.

Для массового начтения исправьте (опорные пункты, свободные пункты и т.п,). Массовое изменение характеристики пунктов описана в главе Характеристики пунктов.

Программа для вычисления координат пунктов использует групповой расчет координат пунктов полярным методом в программе GROMA. Она может обработать полярный метод, свободную станцию и обратную угловую засечку (по ориентированным направлениям). Перед началом расчета должны быть к диспозиции координаты хотя бы самых необходимых пунктов, по которым можно получить остальные пункты на основе измеренных данных. При некоторых конфигурациях (напр. только цепи треугольников с измеренными линиями или, если между известными пунктами непосредственно не проводились измерения) могут массовые вычисления сорваться. В этом случае для вычисления приближенных координат можно использовать отдельные расчетные задачи системы GROMA.

Важно

Если в сети некоторые длины измерены в обеих направлениях, то необходимо сначала так обработать журнал измерений, чтобы он содержал только одно среднее значение. Во вводимых данных после уравнивания сети не может ни одна геометрическая величина повторяться несколько раз. Для обработки журнала измерений можно использовать команду Измерения->Обработка журнала systemu GROMA.

В ведомости измеренных направлений задайте все направления, которые хотите использовать для уравнивания сети. Также как и у приближенных координат, направления можно задавать клавиатурой, перетянуть их из журнала измерений или дать возможность программе самой массово их дополнить (см. Приближенные координаты вводимых пунктов). У каждого измеренного направления должна быть задана оценка ср. кв. ошибки. При перетягивании или при массовых вычислениях программа дополнит ср. кв. ошибку направления, которая установлена в Установка->Параметры сети.

Журнал измеренных длин

В журнале измеренных длин задайте все длины, которые хотите использовать для уравнивания сети. Также как и у приближенных координат, длины можно задавать клавиатурой, перетянуть их из журнала измерений или дать возможность программе самой массово их дополнить (см. Приближенные координаты вводимых пунктов). У каждой измеренной длины должна быть задана оценка ср. кв. ошибки. При перетягивании или при массовых вычислениях программа дополнит ср. кв. ошибку длины, которая установлена в Установка->Параметры сети.

Программа предполагает, что вводимые длины приведены к горизонту и в них введены поправки за все математические и физические редукции.

Журнал измеренных превышений

В журнале измеренных превышений задайте все превышения между пунктами сети, которые хотите использовать для уравнивания сети. Также как и у остальных данных, превышения можно задавать клавиатурой, перетянуть их из журнала измерений или дать возможность программе самой массово их дополнить (см. Приближенные координаты вводимых пунктов). У каждой измеренного превышения должна быть задана приближенная длина, по которой определяется вес для уравнивания. Если длина не задана, то программа ее перед расчетом определит по приближенным координатам. При установке параметров сети перед вычислениями необходимо установить ср.кв. ошибку отдельного превышения выбрать, каким способом вычислять веса отдельных превышений. Веса можно получить из соотношения

pi = 1/si,

или

pi = m0/si2

где pi - вес соответствующего превышения, m0 - ср. кв. ошибка отдельного превышения, а si - длина в км.

Внимание

Программа предполагает, что все вводимые превышения перевычислены относительно соединяющей закрепленных знаков (т.е. исправлены за высоту прибора и сигнала). Эти исправления можно выполнить при обработке журнала непосредственно в системе GROMA.

Пред. | Начало | След.
Параметры сети | Уровень выше | Уравнивание сети


Уравнивание сети
Пред. Глава 49. Уравнивание сети След.

Уравнивание сети

Если правильно заданы все вводимые величины, то можно уравнять сеть нажатием кнопки (Расчет). На экране программа покажет последовательность вычислений и после его окончания в результируюшей части диалогового окна изобразит уравненные координаты и их ср. кв. ошибки. Подробная ведомость вычислений изобразится после нажатия кнопки (Ведомость).

Внимание

Для правильной интерпретации результатов уравнивания, в частности характеристик точности, необходимо иметь хотя бы начальные знания из теории уравнительных вычислений и математической статистики. Необходимо также помнить, что при небольшом количестве избыточных измерений, характеристики точности не совсем надежны и имеют небольшую информационную способность.

Пред. | Начало | След.
Вводимые данные | Уровень выше | Сохранение уравненных координат


Сохранение уравненных координат
Пред. Глава 49. Уравнивание сети След.

Сохранение уравненных координат

Если уравненные координаты Вас удовлетворяют, то их можно сохранить в любом каталоге координат системы GROMA обычным перетягиванием мышью.

Замечание

При перетягивании мышью необходимо указать в какую-либо часть диалогового окна, в которой показаны уравненные координаты, но не на собственный каталог координат. Если указать прямо в каталог конечных координат, то в нем изобразится курсор на соответствующей позиции, но перетянуть ее в каталог координат программы GROMAневозможно.

Пред. | Начало | След.
Уравнивание сети | Уровень выше | Сравнение этапов


Сравнение этапов
Пред. Глава 49. Уравнивание сети След.

Сравнение этапов

Программа позволяет сравнивать отдельные этапы уравнивания сети. Если уравнивание уже выполнено, то программа спросит о названии файла из референц-сети (файл типа .net), и если в нем сохранены уравненные координаты, составит в ведомости таблицу с величинами и дирекционными углами сдвигов между двумя этапами.

Пред. | Начало | След.
Сохранение уравненных координат | Уровень выше | Математическая модель уравнивания


Математическая модель уравнивания
Пред. Глава 49. Уравнивание сети След.

Математическая модель уравнивания

Сеть уравнена методом уравнивания посредственных измерений с условиями. Как посредственные величины использованы горизонтальные длины и углы. Линейная модель уравнивания представлена соотношением

D v = A h - l,

где D - матрица линейного оператора трансформации измеренных величин на посредственные величины, v – вектор поправок геометрических величин, A - матрица линейного оператора проекта сети, h - вектор поправок конфигурации и l вектор правых сторон линейная модели сети

при условии

vT* P v = min

Модель решается при дополнительных условиях на исправление конфигурации, которые можно записать в виде

G h = 0

Исправление конфигурации дано соотношением

h = (AT P A + GT G)-1 AT P l = N-1 AT P l

В процессе вычисления программа выполняет ряд контролей, результаты которых сохраняет в ведомости. К этим контролям относятся:

  • контроль инверсии (двойная норма матрицы остается),

  • контроль условия G h = 0,

  • норма вектора AT P w = 0,

  • двойной расчет поправок геометрических величин,

  • двойной расчет поправок посредственных величин ,

  • двойной расчет [pvv],

  • контрольный расчет wT P w.

Кроме того, программа выполняет ряд внутренних контролей консистентности вводимых данных.

Величины расчетных поправок геометрических величин тестированы на грубые ошибки согласно установленных рисков (альфа и бета). При превышении теста программа расчитает оценку ошибки геометрической величины. Эта оценка довольно надежная при условии единичности ошибки в файле измерений.

Пред. | Начало | След.
Сравнение этапов | Уровень выше | Меню ФАЙЛ


Меню ФАЙЛ
Пред. Глава 49. Уравнивание сети След.

Меню ФАЙЛ

Команды меню Файл служат для манипуляции с файлами и окончания программы.

Открой

Этой командой можно начесть из файла данные для уравнивания сети. Программа может работать с двумя типами файлов:

  • Groma: Собственный формат системы GROMA

  • CVUT: Текстовый формат, используемый в ЧВУТ в Праге

Сохрани

Команда служит для сохранения сети в файле. Если сеть уже названа (если была сохранена или начтена из файла), то программа сотранит сеть без дополнительного вопроса под старым названием. Если название сети еще не было задано, то программа о нем перед сохранением спросит.

Сохрани как

Команда служит для сохранения сети в файле. От предыдущей команды она отличается тем, что о названии файла спросит всегда.

Конец

Этой командой оканчиваете работу с программой. Если сеть после последнего сохранения была изменена, то программа спросит, если необходимо ее сохранить.

Пред. | Начало | След.
Математическая модель уравнивания | Уровень выше | Меню СЕТЬ


Меню СЕТЬ
Пред. Глава 49. Уравнивание сети След.

Меню СЕТЬ

Параметры сети

В этом диалоговом окне необходимо установить некоторые параметры уравнивания сети.

Местность

Название местности, которое сохраняется в ведомости.

Дата

Дата измерения в сети.

Этап

Название этапа, который сохраняется в ведомости.

Ср. кв. ошибка отдельного измерения – расчет планового положения

Априорная ср.кв. ошибка m0, которая будет использована при уравнивании. Если измеренные длины отсутствуют, задайте здесь ср.кв. ошибку направления отдельного измерения, а если длины измерялись, то задайте ср.кв. ошибку отдельного измерения длины. После уравнивания тестируется отношение этой априорной ср.кв. ошибки и апостериорной ср. кв. ошибки отдельного измерения, определенной на основе уравнивания. Это отношение должно приближаться к 1.

Ср. кв. ошибка отдельного измерения – расчет высот

Априорная ср.кв. ошибка m0, которая будет использована при уравнивании. После уравнивания тестируется отношение этой априорной ср.кв. ошибки и апостериорной ср. кв. ошибки отдельного измерения, определенной на основе уравнивания. Это отношение должно приближаться 1.

Ср. кв. ошибка направления

Оценка ср.кв. ошибки измеренного направления [cc].

Вес превышения

Веса превышений вычислены на основе зависимостей, приведенных Руководстве по применению.

Ср. кв. ошибка длины

Оценка ср.кв. ошибки измеренной длины. Ср. кв. ошибка задается в виде A + Bppm, где A – суммируемая часть, а B – умножаемая часть ср.кв. ошибки, т.е. так, как принято обозначать точность электрооптических дальномеров. Напр. при установке 3+2ppm для длины 2000 м предусмотрена ср.кв. ошибка 3 мм + 2*2 мм = 7 мм.

Альфа, Бета

Параметры Альфа и Бета (в процентах) для тестирования статистических гипотез о соблюдении точности измерений.

Отстранить сеть

Этой командой можно отстранить всю сеть. Если сеть после последнего сохранения была изменена, то программа спросить, если Вы хотите ее сохранить.

Пропустить пункт

Если необходимо из сети выпустить пункт, обозначьте его курсором в каталоге приближенных координат и выберите эту команду. Поссле ее включения появится диалоговое окно, в котором можно подтвердить или изменить номер пункта, который необходимо отстранить. Различие, в случае нажатия кнопки (Отстранить), состоит в том, что эта команда исключит из сети не только приближенныые координаты избранного пункта, но и все измерения, в которых данный пункт фигурирует.

Исправить ср. кв. ошибки направлений

После задания этой команды всем измеренным направлениям задается апприорная ср.кв. ошибка направления, устанавливается в параметрах сети. Эту команду используйте тогда, когда необходимо дополнительно (напр. на основе ведомости из предыдущего расчета) массово исправить ср.кв. ошибки всех направлений.

Исправить ср. кв. ошибки длин

После включения этой команды, у всех измеренных длин априори установлена средняя квадратическая ошибка направления согласно параметров сети. Эта команда используется тогда, когда необходимо дополнительно (напр. на основе ведомости предыдущего расчета) массово исправить средние квадратические ошибки всех длин.

Изобразить контрольный чертёж

С помощью этого приказа можно в системе GROMA изобразить контрольный чертёж сети, при этом сеть не нужно вычислять. Этот контрольный чертеж можна напечатать. После вычислений контрольный чертеж изобразится автоматически.

Сравнение этапов

Если уравнивание сети уже произведено, то, после включения этой команды, программа спросит о названии файла из референц-сети (файл типа .net), сохранены-ли в нем уравненные координаты, составит в ведомости таблицу с величинами и сдвигами между двумя этапами.

Пред. | Начало | След.
Меню ФАЙЛ | Уровень выше | Глава 50. Заключение


Глава 50. Заключение
Пред. Часть IV. Расширяющиеся модули

Глава 50. Заключение

Желаем Вам успешной и приятной работы с программой GROMA. В случае каких-либо неясностей или проблем можете с нами связаться по адресу

GEOLINE, spol. s r.o.
Na Mokrine 6
130 00 Praha 3
(02) 7177 2694
(02) 6631 0188
<http://www.groma.cz>
<info@groma.cz>

Мы готовы предоставить Вам любую информацию о программе GROMA, о том, какие новинки имеются в последней версии программы, и о возможных условиях upgrade.

Пред. | Начало
Меню СЕТЬ | Уровень выше