Informace o databázových serverech podporovaných systémem Groma
Další

Informace o databázových serverech podporovaných systémem Groma

Jan Sehnal

Copyright © 2004, 2015 Jan Sehnal

Obsah

Obecný postup při nastavení databází
1. Instalace a konfigurace databázových serverů
MySQL
Oracle
2. Poinstalační konfigurace databáze
Spuštění postalační konfigurace databáze
Ovládání nástroje pro konfiguraci databáze
3. Připojení systému Groma k databázi
4. Inicializace databáze
5. Založení projektu
6. Import dat z výměnného formátu nebo vzorových dat
Další
Obecný postup při nastavení databází


Obecný postup při nastavení databází
Předcházející Další

Obecný postup při nastavení databází

Před zahájením práce s databází je třeba naistalovat databázový server, který bude sloužit jako úložiště dat. Systém Groma v současné době podporuje databáze Oracle a MySQL. K databázím se připojuje prostřednictvím ODBC driverů. Postup instalace je pro každý typ databáze jiný, budou zde tedy popsány všechny postupně.

Bez ohledu na typ použitého serveru je třeba postupně provést tyto kroky:

  • Instalace databázového serveru

    Na jednom z počítačů v síti je třeba instalovat databázový server, na němž budou ukládána všechna data. K serveru se mohou připojovat všechny stanice, na nichž běží systém Groma. Data jsou tedy sdílená a uložená centrálně, což je výhodné z důvodu administrace a zálohování.

  • Instalace ODBC driveru

    Prostřednictvím ODBC driveru se systém Groma připojuje k databázi. ODBC driver je třeba instalovat na každé stanici, na níž má běžet systém Groma. ODBC drivery ke svým databázím poskytují jejich výrobci.

  • Poinstalační konfigurace databázového serveru

    Některé servery vyžadují po instalaci úpravu nastavení. Zejména bývá třeba explicitně povolit vzdálený přístup k databázi. S tím souvisí i nastavení pravidel firewallu systému Windows na klientské i serverové straně tak, aby byla povolena komunikace se serverem. Obecně se jedná o povolení TCP komunikace na příslušném portu, na němž databáze běží.

    Dále je třeba vytvořit prázdnou databázi, do níž budou data ukládána, a uživatelský účet, pod nímž se budou uživatelé systému Groma k serveru přihlašovat. Oba tyto kroky lze provést přímo ze systému Groma.

  • Připojení systému Groma k databázi

    Po všech předchozích krocích je možno se systémem Groma připojit k databázi.

  • Inicializace databáze (vytvoření tabulek, import systémových číselníků)

    Před zahájením práce na nové zakázce je třeba založit projekt a nastavit všechny potřebné údaje.

  • Založení projektu

  • Import dat z výměnného formátu nebo vzorových dat

    Po provedení všech předchozích kroků je možno naimportovat do databáze data, a to v podobě souboru s výměnným formátem, zálohy projektu, atd.

Předcházející | Domů | Další
Informace o databázových serverech podporovaných systémem Groma | Nahoru | Kapitola 1. Instalace a konfigurace databázových serverů


Kapitola 1. Instalace a konfigurace databázových serverů

Kapitola 1. Instalace a konfigurace databázových serverů

MySQL

MySQL je open-source databáze, která je velmi často využívána ve spojení s webovými aplikacemi, ale lze ji velmi dobře využít i v jiných oblastech. Je relativně malá a jednoduchá, ale dostatečně výkonná a poskytuje všechno, co je pro systém Groma třeba. Lze ji provozovat, mimo jiné, na platformách Windows i Linux.

1. Stažení instalačních souborů

Informace o stažení databáze MySQL naleznete zde. V následující ukázce instalace byl použit server verze 5.6.22 a ODBC driver verze 5.3.

2. Instalace serveru a ODBC driveru

Instalační program je dodáván ve formě MSI balíčku pro službu Windows Installer. Po jeho spuštění se objeví úvodní tabulka:

Po stisknutí tlačítka (Next) budete dotázáni na typ instalace. Protože standardní instalace instaluje mnoho komponent, které pro systém Groma nejsou potřebné, je vhodnější zvolit uživatelskou instalaci a vybrat pouze nezbytné součásti:

V dalším dialogovém okně vám vyberete komponenty, které chcete nainstalovat. Požadované komponenty vyberete ve stromě v levém panelu a pomocí zelené šipky je přemístíte do pravého panelu.

Nejprve je třeba vybrat vlastní databázový server. Při instalaci v 64bitové verzi Windows můžete použít jak 32bitovou, tak 64bitovou verzi serveru. Doporučujeme použít 64bitovou verzi:

Dále vyberte ODBC driver pro připojení k serveru. Na rozdíl od databázového serveru, zde musíte zvolit 32bitovou verzi (musí se shodovat s architekturou aplikace, která driver využívá. Groma je 32bitová, je tedy třeba zvolit 32bitový driver):

Po stisknutí tlačítka (Next) bude zobrazen seznam komponent zvolených k instalaci:

Po potvrzení proběhne instalace serveru.

Po dokončení instalace je zobrazeno okno, v němž zobrazen výsledek instalace:

Dále je zobrazeno okno s přípravou ke konfiguraci:

V prvním okně s nastaveními můžete ponechat následující přednastavené hodnoty:

V tomto okně budete požádáni o zadání hesla k administrátorskému účtu. Zvolené heslo si pečlivě poznamenejte a uschovejte, bez něj nelze dělat další operace s databází (zakládání databáze, uživatelů, atd.).

Další uživatelské účty v tomto kroku vytvářet nemusíme, vytvářejí se až později pomocí nástrojů systému Groma:

Volby v dalším okně opět mohou zůstat nezměněné:

Dále se zobrazí okno, v němž lze sledovat postup konfigurace:

Výsledek by měl vypadat takto:

Dále už se zobrazí pouze dvě okna potvrzující úspěšnou instalaci:

3. Samostatná instalace ODBC driveru

ODBC driver lze nainstalovat i samostatně. Samostatná instalace se použije v případě, že se připojujete z více klientských stanic k jednomu serveru. V takovém případě se server instaluje pouze jednou a na klientských stanicích stačí nainstalovat pouze ODBC driver.

Bez ohledu na architekturu instalovaných Windows je nutno v každém případě použít 32bitovou verzi (musí se shodovat s architekturou aplikace, která driver využívá - Groma je 32bitová, je tedy třeba zvolit 32bitový driver).

Po spuštění instalačního programu je zobrazena úvodní obrazovka:

V dalším dialogovém okně je třeba potvrdit souhlas s licenčními podmínkami:

V dalším dialogovém okně můžete zvolit typickou instalaci:

Další dialogové okno zobrazí seznam komponent k instalaci:

Pokud při instalaci nenastane nějaká chyba, bude na závěr zobrazena informace o dokončení instalace:

4. Konfigurace pro vzdálený přístup

Přejete-li si přistupovat k databázi z jiného počítače, je třeba ještě provést několik úprav konfigurace:

  • Povolení komunikace na firewallu: Ujistěte se, že jsou na obou počítačích nastavena pravidla ve firewallu (je-li zapnut) tak, aby byla umožněna komunikace na TCP portu 3306.

  • Nastavení adresy serveru v konfiguraci Gromy: V konfiguračním souboru pro práci s databázemi Groma8\sql\db.ini je třeba v příslušném databázovém profilu (viz Uživatelská příručka systému Groma) upravit v položce "server" atribut "server=" tak, aby byl nastaven na název nebo IP adresu počítače, na němž běží databázový server. Standardně je tento atribut nastaven na hodnotu "localhost".

Předcházející | Domů | Další
Obecný postup při nastavení databází | Nahoru | Oracle


Oracle
Předcházející Kapitola 1. Instalace a konfigurace databázových serverů Další

Oracle

Oracle je v současné době jeden z nejpropracovanějších databázových systémů. Jediná jeho nevýhoda je, že neexistuje žádná bezplatná verze, a ceny komerčních licencí jsou poměrně vysoké.

1. Stažení

Systém lze bezplatně stáhnout a nainstalovat, ale pouze pro testovací účely - pro komerční nasazení je třeba platná licence. Instalační CD lze stáhnout přímo ze stránek Oracle (http://www.oracle.com)

2. Instalace

Instalace se spustí automaticky po vložení instalačního média. Při instalaci je použit průvodce, takže by měla být jasná a bezproblémová.

Předcházející | Domů | Další
Kapitola 1. Instalace a konfigurace databázových serverů | Nahoru | Kapitola 2. Poinstalační konfigurace databáze


Kapitola 2. Poinstalační konfigurace databáze

Kapitola 2. Poinstalační konfigurace databáze

Systém Groma obsahuje funkce, které zjednodušují poinstalační konfiguraci databáze.

Spuštění postalační konfigurace databáze

Funkci pro konfiguraci databáze naleznete v nabídce systému Groma, v menu Databáze - Vytvoření databáze a uživatele.

Předcházející | Domů | Další
Oracle | Nahoru | Ovládání nástroje pro konfiguraci databáze


Ovládání nástroje pro konfiguraci databáze
Předcházející Kapitola 2. Poinstalační konfigurace databáze Další

Ovládání nástroje pro konfiguraci databáze

Po spuštění se zobrazí dialogové okno, v němž je třeba zadat přihlašovací údaje:

  • Jméno: přihlašovací jméno

  • Heslo: heslo pro přihlášení k serveru

  • Instance/server: název nebo IP adresa databázového serveru, v případě Oracle název instance

  • Ovladač: ODBC ovladač příslušné databáze (musí být nainstalován, lze najít v ovládacích panelech)

  • Typ DB: typ databázového serveru (název ODBC driveru)

Tyto přihlašovací údaje systém používá při vytváření databáze a uživatele. Musí se tedy jednat o přihlašovací udaje k účtu, který má práva tyto adminstrativní úkony provádět.

Vytvoření databáze

  • Jméno: název databáze, která má být vytvořena

  • Velikost (pouze pro Oracle a SQL Server): implicitní velikost databáze

  • Cesta k databázovým souborům (pouze pro Oracle a SQL Server): adresář, v němž budou datové soubory umístěny. Implicitní hodnota je převzatá z registru pro zvolený typ databáze (je-li tento nástroj spuštěn přímo na serveru)

Po stisknutí tlačítka Vytvořit program vytvoří dle zadaných parametrů databázi. V systému Oracle je navíc vytvořen tablespace stejného jména, jako je název vytvářené databáze. K takto vytvořené databázi se lze připojit systémem Groma, který po připojení k prázdné databázi automaticky nabídne vytvoření všech potřebných tabulek.

Po stisknutí tlačítka Odstranit program odstraní databázi zadaného jména.

Poznámka

V systému Oracle byl při vytváření databáze vytvořen i příslušný tablespace, který ale při odstranění databáze tímto příkazem odstraněn nebude - pokud si přejete jej odstranit, musíte k tomu použít některý z nástrojů dodávaných k systému Oracle (např. Enterprise Manager).
Varování

V systému Oracle je odstraněn uživatel i s databází a veškerými daty v jednom kroku.

Vytvoření uživatele

  • Jméno: název uživatelského účtu, která má být vytvořena

  • Heslo: heslo k uživatelskému účtu

Po stisknutí tlačítka Vytvořit program vytvoří dle zadaných parametrů uživatelský účet.

Poznámka

Pro správnou funkčnost je třeba účtu nastavit práva k příslušné databázi, takže je třeba mít vyplněn i název datamáze v rámečku Databáze.

Po stisknutí tlačítka Odstranit program odstraní uživatelský účet zadaného jména.

Varování

V systému Oracle je odstraněn uživatel i s databází a veškerými daty v jednom kroku.

Předcházející | Domů | Další
Kapitola 2. Poinstalační konfigurace databáze | Nahoru | Kapitola 3. Připojení systému Groma k databázi


Kapitola 3. Připojení systému Groma k databázi

Kapitola 3. Připojení systému Groma k databázi

K databázi se připojíte ze systému Groma pomocí příkazu Databáze - Připojit k databázi. Máte-li server nainstalován lokálně, a neměnili-li jste při inicializaci databáze přednastavené parametry (zejména název databáze), není třeba dělat žádné další změny, a připojení by mělo úspěšně proběhnout.

V případě, že jste v přednastavených hodnotách něco změnili, bude pravděpodobně třeba upravit soubor sql/db.ini systému Groma. V něm je nastaven název databáze a název/adresa serveru. Podrobně je struktura souboru popsána v Uživatelské příručce systému Groma.

Předcházející | Domů | Další
Ovládání nástroje pro konfiguraci databáze | Nahoru | Kapitola 4. Inicializace databáze


Kapitola 4. Inicializace databáze

Kapitola 4. Inicializace databáze

Po prvním připojení k databázi je třeba ji inicializovat. Při tomto procesu jsou vytvořeny všechny nezbytné tabulky a naimportovány systémové číselníky. Dialogové okno pro inicializaci databáze se zobrazí automaticky po připojení k prázdné databázi. Proces spustíte stisknutím tlačítka OK.

Tento nástroj můžete kdykoli vyvolat v systému Groma příkazem Databáze - Inicializovat databázi.

Varování

Spustíte-li tento nástroj na databázi s daty, všechna data budou ztracena. Program smaže a znovu vytvoří všechny potřebné tabulky.

Předcházející | Domů | Další
Kapitola 3. Připojení systému Groma k databázi | Nahoru | Kapitola 5. Založení projektu


Kapitola 5. Založení projektu

Kapitola 5. Založení projektu

Po přípravě databáze je třeba založit projekt. Dialogové okno pro nastavení projektu se vyvolá příkazem Databáze - Nastavení projektu. V okně vyplňte údaje o zakázce, projekt uložte tlačítkem Uložit a okno zavřete tlačítkem OK.

Předcházející | Domů | Další
Kapitola 4. Inicializace databáze | Nahoru | Kapitola 6. Import dat z výměnného formátu nebo vzorových dat


Kapitola 6. Import dat z výměnného formátu nebo vzorových dat
Předcházející

Kapitola 6. Import dat z výměnného formátu nebo vzorových dat

Po založení projektu můžete otevřít grafické prostředí příkazem Nástroje - Grafika. Pomocí nabídky Projekt - Manažer projektu můžete do zvoleného projektu naimportovat data z výměnného formátu nebo celou zálohu projektu.

Předcházející | Domů
Kapitola 5. Založení projektu | Nahoru